Formule "si" a plusieurs niveaux ....

[Fermé]
Signaler
-
Messages postés
54851
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 octobre 2021
-
Bonsoir,

Alors voila mon problème :

J'ai un tableau avec différentes données jusqu'ici ça va ...

J'aimerai une formule dans ce style
Si A1 <> 0;D1 ou si B1<>0;E1 ou si C1<>0;F1;0

en bref si la cellule A1 contient une valeur, alors affichée la valeur contenu dans la cellule D1 ou si la cellule B1 contient une valeur alors affichée la valeur contenu en E1 etc ... si aucune condition remplie alors 0

J'espère que vous m'aiderez à résoudre ce problème ....


2 réponses

Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 653
Bonjour,
Il faut hiérarchiser vos conditions. Si j'ai bien compris vos propos, essayez :
=SI(A1<>"";D1;SI(B1<>"";E1;SI(C1<>"";F1;0)))
Messages postés
54851
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 octobre 2021
16 764
Bonjour Morticia.

"Si A1 <> 0;D1 ou si B1<>0;E1 ou si C1<>0;F1;0"

Si j'ai bien interprété ta question il faut

Dans la cellule D1 écrire la formule =SI(A1<>0;A1)
Dans la cellule E1 écrire la formule =SI(B1<>0;B1)
Dans la cellule F1 écrire la formule =SI(C1<>0;C1)

Cordialement.