Formule excel convertir jour en heure

Résolu/Fermé
kekoa7 - Modifié par kekoa7 le 17/03/2011 à 14:30
 Mary - 27 oct. 2015 à 11:11
Bonjour,

J'ai un problème avec un formule excel :-(
j'aimerai savoir comment faire pour convertir des heures en jours soit 8h/jours.

Exemple j'ai 27h et j'aimerais pas qu'il me dise 3jours et 9h mais plutôt 4 jours et 1h

J'espère que qqun pourra m'aider!

Merci infiniment

3 réponses

pijaku Messages postés 12259 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 9 août 2022 2 708
Modifié par pijaku le 17/03/2011 à 14:42
Bonjour,

1- revoir les bases des mathématiques... 3x8=24, 27-24 = 3 donc pas 3 jours et 9 heures, mais 3 jours et 3 heures...

2- 27 en A1, dans la cellule ou vous voulez obtenir le résultat :
=ENT(A1/8)&" jours "&MOD(A1;8)&" heures"

EDIT : Pour faire "plus propre" : =SI(MOD(A1;8)=0;ENT(A1/8)&" jours";SI(MOD(A1;8)=1;ENT(A1/8)&" jours "&MOD(A1;8)&" heure";ENT(A1/8)&" jours "&MOD(A1;8)&" heures"))
Franck P
0
mic13710 Messages postés 1088 Date d'inscription samedi 26 novembre 2005 Statut Membre Dernière intervention 13 mai 2021 352
17 mars 2011 à 14:45
Soit en B1 votre total d'heures, copiez/collez cette formule dans la cellule de votre résultat :
=SI(ENT(B1/8);ENT(B1/8)&" J";"")&SI(B1-ENT(B1/8)*8;" "&B1-ENT(B1/8)*8&" H";"")

Michel
0
mic13710 Messages postés 1088 Date d'inscription samedi 26 novembre 2005 Statut Membre Dernière intervention 13 mai 2021 352
17 mars 2011 à 14:51
Et à la lumière de la proposition de pijaku avec l'utilsation de mod (je ne l'avais pas trouvé, honte à moi) la formule ci-dessus devient :
=SI(ENT(B1/8);ENT(B1/8)&" J";"")&SI(MOD(B1;8);" "&MOD(B1;8)&" H";"")

Michel
0
Merci à vous pour cette formule bien utile ;)
0
mic13710 Messages postés 1088 Date d'inscription samedi 26 novembre 2005 Statut Membre Dernière intervention 13 mai 2021 352
28 mars 2011 à 13:04
Ça fait très exactement 262 heures que la réponse a été donnée. J'espère pour vous, cher kekoa, que depuis le temps votre problème est résolu.
Merci de bien vouloir le dire et si ça vous convient, de marquer le sujet comme résolu, sinon, nous avons l'impression d'avoir travaillé pour rien.

Michel
0
pijaku Messages postés 12259 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 9 août 2022 2 708
29 mars 2011 à 08:33
Salut michel,
Toi comme moi savons le problème résolu. kekoa ne reviendra pas. Il a eu sa réponse...
Bon à la base il était bien poli, bien gentil, c'est tout ce qu'on lui demande.
A+
0
mic13710 Messages postés 1088 Date d'inscription samedi 26 novembre 2005 Statut Membre Dernière intervention 13 mai 2021 352
29 mars 2011 à 09:22
Salut pijaku,
Que la question ait été résolue, c'est une certitude. Je suis peut-être vieux jeu mais un merci à la fin, c'est à mon sens un minimum, surtout que ça ne coute rien.
0
pijaku Messages postés 12259 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 9 août 2022 2 708
29 mars 2011 à 11:35
C'est un lot quotidien ici. On s'y fait, à contre coeur, mais on s'y fait!
Bonne journée à toi
0
haggardian Messages postés 1 Date d'inscription lundi 29 avril 2013 Statut Membre Dernière intervention 29 avril 2013
29 avril 2013 à 11:23
je vous remercie à la place de de kekoa7, votre formule m'a aidé bcp
0
pijaku Messages postés 12259 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 9 août 2022 2 708
29 avril 2013 à 11:29
de rien, ravi qu'elle te soit utile.
A+
0