Extraction de ligne d'un txt sous windev

Fermé
Frop - 16 mars 2011 à 10:42
newkiss Messages postés 127 Date d'inscription mardi 7 septembre 2010 Statut Membre Dernière intervention 12 janvier 2015 - 17 mars 2011 à 12:24
Bonjour à tous,

Ma question est assez simple mais je débute en windev et j'aimerais extraire la ligne 18 d'un fichier texte.

Pour être précis j'ai besoin des caractère n° 44 à 66 de la ligne 18 mais aussi
- des caractère 44 à 57 de la ligne 19;
- des caractère 44 à 56 de la ligne 20;
- des caractère 44 à 54 de la ligne 21;
- des caractère 44 à 55 de la ligne 22.

C'est possible de les récupérer et de les mettre dans 5 variables différentes ?


Je boss sur windev 15.

Merci de votre aide

2 réponses

C'est encore moi !
Je suis parvenu à extraire les lignes complètes ! c'est un début mais je n'arrive toujours pas à récupéré uniquement un morceau de ligne...

Personne pour m'aider ?

Merci
0
newkiss Messages postés 127 Date d'inscription mardi 7 septembre 2010 Statut Membre Dernière intervention 12 janvier 2015 11
17 mars 2011 à 12:24
Par exemple

nIDFichier est un entier
nIDFichier = fOuvre(sCheminFichier,foLecture)
sLigne est une chaîne
sVal est une chaîne
nNumLigne est un entier =0
SI nIDFichier <> -1 ALORS
	BOUCLE
		sLigne = fLitLigne(nIDFichier)
		nNumLigne++
		SI sLigne <> EOT ALORS SORTIR
		SELON nNumLigne
			CAS 18
				sVal = sLigne[[44 A 66]]
			CAS 19
				sVal = sLigne[[44 A 57]]
			CAS 20
				sVal = sLigne[[44 A 56]]
			CAS 21
				sVal = sLigne[[44 A 54]]
			CAS 22
				sVal = sLigne[[44 A 55]]
			AUTRE CAS
				
		FIN
		
	A FAIRE TANTQUE sLigne <> EOT 
	
FIN
fFerme(nIDFichier )

0