Debian squeeze ] - Problème de son

Fermé
Monk-hey - Modifié par Monk-hey le 15/03/2011 à 19:24
mamiemando Messages postés 33199 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 19 juillet 2024 - 17 mars 2011 à 00:45
Bonjour,


Tout d'abord, excusez moi de vous déranger.

Depuis que j'ai installer Debian Squeeze, j'ai des problèmes de son ; Je ne peut avoir du son que lorsque j'ai des écouteurs, ou des baffes de branchées sur mon ordinateur. Alors que celui-ci est déjà équipé (il s'agit d'un portable hp-g62).
Sous ubuntu 10.10, je n'avais aucun soucis.

J'ai testé différentes choses avec alsa, mais je ne pense pas que le problème vienne de là.

Merci d'avance pour vos réponses. :)



A voir également:

5 réponses

mamiemando Messages postés 33199 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 19 juillet 2024 7 763
15 mars 2011 à 20:08
Il se peut que ça vienne d'alsa. Tu peux t'inspirer des options suggérées ici si tu as une carte intel :
http://doc.ubuntu-fr.org/audio_intel_hda

Le cas échéant reporte-nous le modèle de carte que tu utilises :

lspci


Vérifie que tout est à jour :

aptitude update
aptitude safe-upgrade


Si ça ne change rien essaye de compiler ta propre version d'alsa avec module-assistant :
http://www.mistra.fr/tutoriel-debian-module-assistant.html

Bonne chance
mamiemando Messages postés 33199 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 19 juillet 2024 7 763
16 mars 2011 à 01:29
Pour que les options que tu passes à alsa soient prises en compte il faut recharger le module correspondant et que tu recharges le module (voir commandes rmmod, lsmod et modprobe). Pour plus de détails :

man rmmod
man modprobe
man lsmod


(q pour quitter).

Si tu ne sais pas faire le plus simple est de rebooter une fois la configuration d'alsa modifiée.

Bonne chance
Merci de ta réponse.

Lorsque j'utilise la commande lspci | grep -i audio, j'obtiens ceci :

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
01:00.1 Audio device: ATI Technologies Inc Manhattan HDMI Audio [Mobility Radeon HD 5000 Series]


Alors que dans système ==> préférences ==> Son : il me propose HDA intel (alsa mixer) et HD Audio generic (alsa mixer).

J'ai tout de même regardé le lien que tu m'as donné. Mais rien ne semble marcher.

Je pense que je vais tenté de recompiler alsa.
Bonjour,

J'ai donc entrepris de compiler alsa. En suivant ce tutoriel : http://doc.ubuntu-fr.org/tutoriel/comment_compiler_les_drivers_alsa

Mais au moment du make, j'ai cette erreur :

make[5]: *** /usr/src/alsa/alsa-driver-1.0.24.12.ge9da1.282.g1c191/acore/hrtimer.o Erreur 1
make[4]: *** /usr/src/alsa/alsa-driver-1.0.24.12.ge9da1.282.g1c191/acore Erreur 2
make[3]: *** [_module_/usr/src/alsa/alsa-driver-1.0.24.12.ge9da1.282.g1c191] Erreur 2
make[2]: *** [sub-make] Erreur 2
make[1]: *** [all] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.32-5-amd64 »
make: *** [compile] Erreur 2


Savez-vous d'où cela vient ?

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
mamiemando Messages postés 33199 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 19 juillet 2024 7 763
Modifié par mamiemando le 17/03/2011 à 00:45
Dans ton extrait il n'y a pas le message d'erreur. Je t'invite à faire la compilation avec module-assistant ça t'évitera pas mal de soucis.
http://www.mistra.fr/tutoriel-debian-module-assistant.html