Div à 100% ne remplit pas toute la largeur??

Résolu/Fermé
olivierrobins Messages postés 225 Date d'inscription lundi 17 janvier 2011 Statut Membre Dernière intervention 26 janvier 2012 - 3 mars 2011 à 19:36
olivierrobins Messages postés 225 Date d'inscription lundi 17 janvier 2011 Statut Membre Dernière intervention 26 janvier 2012 - 4 mars 2011 à 10:16
Bonjour,

Je suis actuellement en train de travailler sur un site, et j'ai un petit souci. Je dois mettre une image en arrière-plan an bas de page. Le contenu du site a une largeur fixe (1000px) et l'image d'arrière-plan doit faire la largeur complète du navigateur.

Donc j'ai simplement créé une structure avec 3 div l'une sous l'autre (header, center et footer) avec une largeur de 100%, et à l'intérieur le contenu est composé de div à 1000px de large.

Le problème, c'est que les div principales, dont celle contenant l'arrière-plan, ne remplissent pas tout l'écran en largeur (ni en hauteur) et laissent du blanc à gauche et en bas.

Y'a t'il un moyen de corriger ça?
Le site est là:
http://www.espritbains.com
(c'est sur la page d'accueil que je travaille actuellement, et l'image d'arrière-plan est bien évidemment la grande image d'eau en bas de la page)

D'avance mille mercis pour toute aide que vous pouvez me donner.
(p.s. c'est relativement urgent)

Olivier

4 réponses

Stéphane18 Messages postés 372 Date d'inscription jeudi 3 mars 2011 Statut Membre Dernière intervention 20 février 2019 133
3 mars 2011 à 19:57
Salut d'après firebug c'est ici que ça ce passe pour l'écart du bas:

div#footer_content{
	width:1000px;
	clear:left;
	margin:50px auto 50px auto;
}


Enlève la valeur 50px sachant que tu en a mi une en haut et en bas !!
1
Thordendall Messages postés 2385 Date d'inscription mardi 9 novembre 2010 Statut Membre Dernière intervention 27 janvier 2023 743
3 mars 2011 à 20:01
j'ai supprimé mon post car je suis carrément passé à coté dans firebug... chapeau bas Stéphane18 ^^
0