[JAVA]ce qu'il faut pour programmer en JAVA ? [Fermé]

Signaler
-
 Sahar -
Salut

je suis débutant en java et j'aimerais savoir ce qu'il faut pour programmer en JAVA sous linux. Plus précisement, j'aimerais savoir ce qu'il faut comme logiciel pour réaliser des makefile, compiler de gros projets avec pas mal de fichiers sources et tout logiciel qui pourrait simplifier la vie lors de la gestion et l'édition des fichiers.

Je vous remercie d'avance

6 réponses

Télécharge un EDI Java :
http://java.developpez.com/outils/edi/

Tu as des cours et tutoriels Java ici :
http://java.developpez.com/cours/

Sans oublier les excellentes F.A.Q Java :
http://java.developpez.com/faq/
9
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
169
Date d'inscription
lundi 7 novembre 2005
Statut
Membre
Dernière intervention
25 juillet 2010
73
Bonsoir,

Il faut installer le sdk de http://www.java.sun.com

Comme éditeur, éclipse est très efficace:
http://www.eclipse.org

Pour la gestion de projets, on peut utiliser ant:
http://ant.apache.org

Philippe
Bonjour,

Je cherche à télécharger un logiciel pour ecrire des petits programmes en java

J'ai MAC OS X et je ne sais pas du tout quel logiciel choisir, et la plupart de ceux que je trouve marchent sur Linux ou Windows...

Pouvez vous me conseiller sur le choix d'un logiciel (je voulais prendre Dreamweaver car je sais déja l'utiliser pour php et html mais j'en aurais besoin tout au long de l'année et il coute beacoup trop cher...)

Merci pour votre aide, très bonne soirée à tous!


Ambre
Bonjour,

- Outils de developpements Java pour Mac : https://mac.developpez.com/telecharger/index/categorie/121/Outils-pour-Mac
Tu as par exemple Eclipse, Netbeans etc...
Messages postés
74
Date d'inscription
dimanche 26 avril 2009
Statut
Membre
Dernière intervention
26 février 2011
2
Merci paul :)
Je suis aussi sur Mac je veux télécharger Creator mais ils me sortent beaucoup de liens, je ne sais pas lequel prendre, je suis débutante. :s