Htaccess accès restreint à répertoire

Résolu
Bonjour,

J'ai créer un .htaccess .htpasswd dans un répertoire du site dont je souhaite protéger l'accès par un identifiant et un mot de passe.

.htaccess:
AuthUserFile /htdocs/public/www/securise/.htpasswd 
AuthName "Veuillez renseigner votre identifiant et votre mot de passe" 
AuthType Basic 
<Limit GET POST> 
Require valid-user 
</Limit> 


.htpasswd:
identifiant:code 


Une fois ces fichiers ligne, la fenêtre demandant login et mot de passe apparait, ainsi que le message contenu dans le AuthName.

En revanche une fois cette fenêtre validée par les bons mot de passe, voilà ce qui est renvoyé :

___________________

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
___________________

J'ai trouvé le chemin absolu à préciser grace à un realpath en php. Donc je ne vois pas d'où viens mon erreur.

Si quelqu'un est capable de résoudre ce problème , et de m'aider un très grand merci d'avance!!!!!

8 réponses

  1. alléluia!!!

    Il y a des jours comme ça où tu finis par te demander si tu n'est pas maso, la solution est on ne peut plus simple et j'imagine s'applique à la plupart des hébergeurs, merci widi pour ton 2nd lien!!!! Mon erreur était de pas penser tout de suite que l'hébergeur y était pour quelque chose.

    En gros aucun htpasswd et htaccess a créer sois même, sur le site d'amen "espace client => HEBERGEMENT => FTP : Gestionnaire de fichiers => rendez-vous dans le répertoire à protéger => Protéger par un mot de passe" et voilà, autant dire que plus facile c'est pas possible!

    Donc je me suis pourrie mon vendredi pour rien, en espérant que cela serve à d'autre!!!

    Merci Widi encore une fois pour ta participation!
    3
    1. salut
      tu as oublié ceci, je sais pas si c'est obligatoire après le AuthUserFile /htdocs/public/www/securise/.htpasswd

      AuthGroupFile /dev/null

      Bon courage
      0
      1. Merci beaucoup Widi pour ta réponse.

        Cette ligne je crois n'est pas obligatoire, je l'ai quand même remise au cas où mais le problème reste le même! Je ne vois pas quoi faire...:(

        Merci quand même!!!!
        0
        1. bon alors ton problème ne peut venir que de ton chemin
          AuthUserFile
          c qui ton hebergeur?
          0
          1. Oui moi aussi je vois que ça, mon hébergeur c'est amen, et justement j'ai essayé de voir sur leur site dans la F.A.Q mais je ne vois pas trop comment rechercher.

            merci widi pour ton aide
            0
            1. Je vais jeter un coup d'oeil, merci encore Widi!!!!

              Bonne soirée
              0
              1. Apparemment, les problèmes qui pourrait me concerner sont :

                ______________________________________
                Le serveur Apache utilise le module d'authentification PAM. Il faut donc rajouter la ligne : :
                AuthPAM_Enabled off dans votre fichier.htaccess
                Les erreurs fréquentes au sujet des fichiers .htaccess/.htpasswd :
                1 - mauvais droits d'accès aux fichiers. Ils doivent être lisibles par tout le monde :
                CHMOD 644.
                Sinon, le serveur renvoie une erreur 500 (Internal Error).
                2 - erreur de syntaxe dans le fichier .htaccess (ou mauvaise utilisation d'une directive) :
                le serveur renvoie une erreur 500 (Internal Error).
                _________________________________________________

                J'ai rajouté AuthPAM_Enabled off, ça ne suffit pas le problème persiste

                Sinon CHMOD 644. c'est du chinois pour moi, aucune idée de ce que je dois faire ou vérifier

                Ou erreur de syntaxe, mais là ça m'aide pas à savoir où...

                Je continues mes recherches
                0