Récupérer numero de ligne sous excel

Fermé
proexcel - 22 nov. 2010 à 15:49
michel_m
Messages postés
16568
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
14 mai 2022
- 22 nov. 2010 à 16:38
Bonjour,

J'ai 2 colonnes sous excel. Je dois comparer chaque valeur de la premiere colonne avec toutes les valeurs de la deuxieme colonne (ce sont des refs en lettres à comparer et non des chiffres).

Quand il trouve les lettres correspondantes (dans la 2eme colonne), il devra me retourner le numero de la ligne où il est apparu cette correspondance (dans la 2eme colonne).
Il n'y a qu'une seule possibilité de correspondance entre les 2 colonnes et les 2 colonnes n'ont pas la meme longueur (1er colonne : 30 lignes et 2eme colonne : 100 lignes).

Merci de toute aide.

1 réponse

michel_m
Messages postés
16568
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
14 mai 2022
3 280
22 nov. 2010 à 16:38
bonjour

1)colonne :A1:A30
2° colonne B1:B100

en C1
=SI(NB.SI(B$1:B$100;A1)>0;EQUIV(A1;B$1:B$100;0);"")
à tirer vers le bas sur 30 lignes
0