Excel, comment retirer des nombre d'un liste

Résolu/Fermé
Signaler
-
Messages postés
55418
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 janvier 2022
-
Bonjour,

mon titre n'est pas très explicite, voici ma question :
Je fais dans excel une liste de numéro de 1 à 99
sous la forme : A1 : 1 A2 : 2... A99 : 99
Je voudrais que quand j'entre dans une cellule (par exemple B4) un numero (ex: 33) la liste deviennent 1,2,..,32,34,35...98,99

connaissez vous une solution ?
merci pour votre aide !


3 réponses

Messages postés
16547
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2022
3 260
Bonjour,

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Address <> "$B$4" Then Exit Sub
    If Application.CountIf(Columns(1), Range("B4")) > 0 Then
        Range(Columns(1).Find(Range("B4"), Range("A65536"), xlValues).Address).Delete Shift:=xlUp
    Else
        MsgBox Range("B4").Value & " inconnu dans colonne A!", vbCritical
    End If
End Sub


comment installer ?
copier cette macro
clic droit sur le nom de l'onglet de la feuille concernée (en bas de l'écran)
visualiser le code
coller
si tu n'as jamais utilisé de macros, cocher menu options-macros-sécurité- niveau moyen
1
merci michel je vais essayer ça !
0
Messages postés
55418
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 janvier 2022
17 224
Bonjour Max.

Pour créer ta liste, tu tapes 1 en A1 ; dans la cellule B1 tu écris la formule
=SI(A1=99;"-";SI(A1+1=$B$4;A1+2;A1+1)) que tu recopies jusqu'en CU1.
0