Excel test logique sur une plage de données [Résolu/Fermé]

Signaler
-
 Victor -
Bonjour,

Problème rencontré :

A partir d'un fichier, je dois retranscrire la valeur correspondant à une cellule à partir d'une plage de données située sur un autre fichier.
J'ai réussi à résoudre la retranscription du total de plusieurs valeurs correspondant à une cellule à partir de la formule Somme.si. Mais, avec une seule valeur, la formule Somme.si renvoi des résultats erronés (j'ai bien trié les données) et la formule Si ne permet pas des plages de données.
Description technique :Fichier résultat (par exemple vente filiale X): critère (nombre par exemple Nos des articles vendus) se trouvant de A1 à A100, plage de résultat sur B1 à B100 (nombre par exemple prix)
Fichier référence (par exemple catalogue global des articles avec prix) : critères de A1 à A500 (Nos des articles) et valeurs B1 à B500 (nombre par exemple prix).

Le problème est donc comment retranscrire sur le fichier de la filiale le prix de l'article X à partir du fichier catalogue.

Un grand merci par avance de vos contributions

2 réponses

Messages postés
9820
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
27 novembre 2020
1 098
Bonjour,
Une solution : la formule en [B1] de la feuille résultat et la tirer vers le bas, les références étant dans la feuille 2
=RECHERCHEV(A1;Feuil2!$A$1:$B$500;2;FAUX) 


S'il s'agit de deux classeurs, alors en [B1] du classeur [Résultat]
Les références étant sur le classeur [référence.xls]
=RECHERCHEV(A1;[référence.xls]Feuil1!$A$1:$B$500;2;FAUX) 

Salutations.
Le Pingou
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Bonjour Le Pingou,

Un grand merci, effectivement RECHERCHEV solutionne mon problème, en fait je l'avais essayé, mais j'avais fait l'erreur de ne pas prendre en compte toute la base de donnée en référence. Meilleures salutations. Victor
Messages postés
213
Date d'inscription
dimanche 20 janvier 2008
Statut
Membre
Dernière intervention
24 janvier 2012
41
bonjour

la fonction recherche v ne te convient pas?
Bonjour Zorgon80,
Un grand merci, la formule fonctionne. Meilleures salutations. Victor