Algorithme

[Fermé]
Signaler
-
Messages postés
9688
Date d'inscription
vendredi 23 avril 2004
Statut
Contributeur
Dernière intervention
2 octobre 2020
-
Bonjour,
svp je voudrai un algorithme qui fait la résolution d'une fonction de second degré svp x²+bx+c=0
merci c urgent

8 réponses

Messages postés
316
Date d'inscription
jeudi 29 octobre 2009
Statut
Membre
Dernière intervention
28 novembre 2010
81
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
9688
Date d'inscription
vendredi 23 avril 2004
Statut
Contributeur
Dernière intervention
2 octobre 2020
1 308
si (z=b*b-4*c)<0
 pas de solution réelle
sinon
  solution1=( b-sqrt(z))/2
  xolution2=(-b-sqrt(z))/2
fin si
--
La vrai soumission c'est quand les esclaves s'inquiètent du cours du coton.
Char Snipeur
merci mais svp je veux du début jusqu'à fin lool tous l'algorithme merci
Messages postés
316
Date d'inscription
jeudi 29 octobre 2009
Statut
Membre
Dernière intervention
28 novembre 2010
81
Mais l'algorythme pour quel language ? Du C ou alors un logiciel comme AlgoBox ?
un algorithme pour c un traitement sur cahier juste avant la programmation pour écrire sur un cahier comme par exemple ça
résoudre ax+b=0
=>
def_var
a,b,x
debut
ecrire ("dommer a")
lire (a)
ecrire ("donner b")
lire (b)
si (b=0)
alors x<---0
sinon
x<-----a/b
fin si
ecrire ("solution x",x)
fin
c comme ça je veux l'écrire le prog de la résolution du bébut jusqu'à la fin
merci
merci de me répondre :)
Messages postés
9688
Date d'inscription
vendredi 23 avril 2004
Statut
Contributeur
Dernière intervention
2 octobre 2020
1 308
il y a la réponse dans le lien de supertomtom.
Et estime toi heureux d'avoir une réponse vu la façon dont tu demandes. Nous ne sommes pas là pour faire tes exercices.
De plus, tes messages sont à peine français, fait un petit effort pour construire des phrase correctes ! (pas de langage SMS)
j'ai dit que j'ai besoin d'aide et c pa pour me faire mes exercice je voulai savoir si c juste ce ke j'ai fait ou nn mais dit moi vous éte tou le temps comme ça arrangant vous n'étent pas des dieu dessendai sur terre arroganr et lit ça si ça te palit ou nn merci
Messages postés
9688
Date d'inscription
vendredi 23 avril 2004
Statut
Contributeur
Dernière intervention
2 octobre 2020
1 308
"je veux" déjà c'est mal parti !
Si tu as fait quelque chose, mets le, on te dira si c'est juste. Là tu dit "donnez moi la solution".
En attendant, si tu ne fait pas un effort sur l'écriture, je fait intervenir un modérateur.
"arrangant" ne veux rien dire. Mais si je comprends bien (et vu comme tu écris c'est un gros effort) tu te demande si je suis souvent comme ça ? Et bien, non, juste avec les gens désagréable qui n'ont même pas la politesse de prendre 3 secondes pour écrire un message lisible et correct, et qui en plus exigent des réponses toutes faites sans faire le moindre effort.
Messages postés
30
Date d'inscription
samedi 2 octobre 2010
Statut
Membre
Dernière intervention
9 novembre 2012
3
Variables a, b, c : Entiers
Variables X1, X2, Delta : Réel
DEBUT
Ecrire « Entrez a : »
Lire a
Ecrire « Entrez b : »
Lire b
Ecrire « Entrez c : »
Lire c
Si a <> 0 Alors
Delta ? (b * b) - (4 * a * c)
Ecrire « Delta est : », Delta
Si Delta = 0 Alors
X1 ? -b /(2 * a)
Ecrire « X1 est : », X1
Sinon Si Delta > 0 Alors
X1 ? ( (-b) + (?Delta ))/(2 * a)
X2 ? ( (-b) - (?Delta ))/(2 * a)
Ecrire « X1 est : », X1
Ecrire « X2 est : », X2
FIN Si
Sinon
Si b = 0 Alors
Si c = 0 Alors
Ecrire « La solution est R »
Sinon
Ecrire « Pas de solution »
FIN Si
Sinon
X1 ? -c / b
Ecrire « X1 est : », X1
FIN Si
FIN Si
FIN