Erreur d'addition sur excel [Résolu/Fermé]

Signaler
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour,
erreur sur une simple addition sur un bulletin de paye
871,41 €

-25,20 €
-5,25 €

840,97 € est la somme calculée par excel donc un centime de différence
impossible de faire corriger
colonne paramétrée en compta 2 décimales partout
galère si je dois vérifier toutes les fiches de paye
help

windows XP excel 2007 (enregistré sous cl 1997-2003)







1 réponse

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 446
bonjour

Erreur d'addition sur excel

On ne peut pas tout à fait affirmer cela car les calculs excel sont justes !

Tes montants affichés 2 décimales doivent provenir de calculs et excel conserve toutes les décimales sauf si pour chaque calcul tu prends soin d'arrondir à 2 décimales.

Lorsque tu appliques simplement un format tu n'as qu'un affichage sur 2 décimales mais pas l'arrondi réel.
Avec -5,246 affiché -5,25 et 871,411 affiché 871,41 tu obtiens 840,97 €
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

ok pour la réponse mais comment régler le problème, j'ai le même souci avec des sommes format nombre, décimal 0 merci ;
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 954
Bonjour

en complément des infos de l'ami gb (bonjour) et en attendant qu'il revienne
à placer comme recommandé dans les calculs de %:
=ARRONDI(formule;2) vous donnera un résultat à deux décimales strictement conforme à la valeur affichée.


crdlmnt
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 446
comment régler le problème ?

Tu as aussi la réponse : pour chaque calcul tu prends soin d'arrondir à 2 décimales

Donc au lieu de : =A1/B1
=ARRONDI(A1/B1;2) : au plus près
ou =ARRONDI.INF(A1/B1;2) à la décimale inférieure
ou =ARRONDI.SUP(A1/B1;2) à la décimale supérieure
selon ton besoin et cela pour tous tes calculs.