Excel Somme de cellule si elles sont positif [Résolu/Fermé]

Signaler
-
Messages postés
8350
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 janvier 2021
-
Bonjour,

Je fais une somme de nombres de différentes ligne dans excel :

=SOMME(C68:J68;C62:N62;C56:N56;C50:N50;C44:N44;C38:N38;C32:N32;C26:N26;C20:N20;C14:N14;K8:N8;I8;J8)

Je voudrais faire la somme que des nombres >0 et ignorer les nombres <0

Comment faire pour donner cette condition dans ma somme.

Je suis débutant 0!

Merci

3 réponses

Messages postés
8350
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 janvier 2021
1 570
=SOMME.SI(C68:J68;">0")+SOMME.SI(C62:N62;">0")+SOMME.SI(C56:N56;">0")+...
Messages postés
8700
Date d'inscription
dimanche 8 avril 2007
Statut
Contributeur
Dernière intervention
22 janvier 2020
1 140
Bonjour,
Avec une fonction perso ?
Function Additionner() As Double   
Dim Plage As Range   
Dim Cel As Range   
    Application.Volatile  
    Set Plage = Union([C68:J68], [C62:N62], [C56:N56], [C50:N50], _
     [C44:N44], [C38:N38], [C32:N32], [C26:N26], [C20:N20], _
     [C14:N14], [K8:N8], [I8:J8])
    For Each Cel In Plage   
        If Cel.Value > 0 Then Additionner = Additionner + Cel   
    Next Cel   
End Function


Et dans la cellule où tu veux le total..
=Additionner()

A+
L'expérience instruit plus sûrement que le conseil. (André Gide)
Si tu te cognes à un pot et que ça sonne creux, c'est pas forcément le pot qui est vide. ;-)(Confucius)
Merci pour votre aide.
J'ai utiliser la 1ere méthode qui fonctionne......
Pour les fonctions, je suis pas assez bon, je suis un débutant, je viens juste de commencer avec excel.

Merci à vous
Messages postés
8350
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 janvier 2021
1 570
met le poste en résolu