Occurence valeur excel dans plage de données

Résolu/Fermé
Raphix - 30 juin 2010 à 09:18
 raphix - 30 juin 2010 à 14:50
Bonjour à tous,

Voilà deux jours que je parcours les forums pour trouver une solution à mon problème, je m'en remets donc à vous et aux génies des formules excel..
J'ai un tableau récapitulant des infos sur les permis de construire..près de 10000 enregistrements et qui contiennent une ou plusieurs parcelles de référence.

ex:

Permis de C Parcelle1 Parcelle2 PArcelle3 Parcelle4
1 754AB111 754AB212 754AB213
2 736BD145
3 754AB212 754AB213
4 736BD145

Je souhaiterais savoir combien de fois apparait la parcelle qu'elle apparaisse en colonne parcelle1 2 3 ou 4. Manuellement ce serait trop long, auriez vous une astuce pour résoudre mon problème...
Merci d'avance

3 réponses

dobo69 Messages postés 1584 Date d'inscription vendredi 24 juillet 2009 Statut Membre Dernière intervention 30 juin 2013 799
Modifié par dobo69 le 30/06/2010 à 09:34
bonjour,

un fonction d'excel fait cela simplement :
=NB.SI('plage';'parcelle')

selon l'exemple ci-joint :
http://www.cijoint.fr/cj201006/cijDAu2ldu.xls

Si vous n'avez besoin de rien, demandez-moi.
0
Merci pour la rapidité de la réponse! C'est la formule que j'utilisais mais sans figer ma plage de données.

Encore merci
0
xkristi Messages postés 4264 Date d'inscription lundi 18 décembre 2006 Statut Membre Dernière intervention 19 août 2022 564
30 juin 2010 à 10:15
Bonjour !

P1 p8 p2 p3
p2 p4 p5 p1
p3 p6 p1 p2

nbre de Parcelles P1
=NB.SI(A2:D4;A2)
tu comptes dans ton tableau
le contenu de A2 soit p1


0
Mike-31 Messages postés 18174 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 26 janvier 2023 5 032
30 juin 2010 à 11:19
Salut,

A moins que ce soit par colonne "combien de fois apparait la parcelle qu'elle apparaisse en colonne parcelle1 2 3 ou 4"

dans ce cas pour compter la colonne A le critère étant en F2 par exemple
=NB.SI(A:A;F2)

pour la colonne B
=NB.SI(B:B;F2)

pour la C
=NB.SI(C:C;F2)

etc ...

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0
Mike-31 Messages postés 18174 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 26 janvier 2023 5 032
30 juin 2010 à 14:19
En réfléchissant à la demande, il se pourrait que ce soit une recherche inverse, à partir d'un numéro ex. 754AB212 identifier la parcelle Parcelle1 et Parcelle2 avec peut être le nombre de numéro par parcelle.
Si Raphix suivait sa discussion, nous ne serions pas dans l'expectative

Mike-31
0
Merci pour vos réponses, une simple fonction "nb.si" réglait l'affaire. Il fallait seulement que je fige ma plage avec des $ pour ne pas me retrouver avec un simple comptage des valeurs.
Ex.

Parcelle1 Parcelle2 PArcelle3 Parcelle4 Occurence
754AB111 754AB212 754AB213 1
736BD145 2
754AB212 754AB213 1
736BD145 1

En figeant la plage, on obtient:

Parcelle1 Parcelle2 PArcelle3 Parcelle4 Occurence
754AB111 754AB212 754AB213 1
736BD145 2
754AB212 754AB213 2
736BD145 2


A bientot
0