Mettre en "trunk" un switch Cisco et un HP

Fermé
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010 - 22 juin 2010 à 09:11
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010 - 5 juil. 2010 à 09:04
Bonjour à tous,

Voilà, j'ai un problème, dans mon entreprise, on m'a demandé de relier ensemble deux switchs Cisco l'un avec l'autre en mode trunk avec le vtp domain et tout et tout ...

Ca a très bien fonctionné et je n'ai pas eu trop de mal, seulement, là on vient de me demander de rajouter à cette configuration, un switch HP procurve 2524 ...

Si je créé les Vlans déjà créés sur mon Cisco 2960 qui est configuré en mode "serveur", ça me fait un conflit et les deux switch plantent vu que les mêmes Vlans sont créés sur les deux switchs.

Je me suis dis que ça devait être à cause du fait qu'ils soient créés eux deux et deux fois.
J'ai donc essayé de chercher comment faire pour configurer l'équivalent du mode "trunk" sur les HP mais je n'ai pas trouvé :s

Mon but est de relier les deux switchs afin que le Cisco serveur transmettent tous les Vlans au HP et que je puisse le rajouter à la configuration en lui affectant des ports aux Vlans créés sur le Cisco ...

Voilà, j'espère que quelqu'un saura m'aider car je bloque :s
J'ai retiré le mode "spanning-tree" et j'ai configuré le Vlan 1 sur mon port 24 en tagged pour qu'ils puissent être relié à un matériel administrable et je voulais savoir ce qu'il me manquait pour que le lien s'établisse entre les deux switchs et que les Vlans transitent du Cisco au HP.

Merci d'avance à tous et bonne journée ^^

Cordialement, Aurélien.


A voir également:

11 réponses

brupala Messages postés 109104 Date d'inscription lundi 16 juillet 2001 Statut Membre Dernière intervention 4 mars 2024 13 569
23 juin 2010 à 15:33
Salut,
tu n'es pas prêt de t'en sortir de cette façon:
1/ le vtp est propriétaire cisco donc incompatible avec le HP.
2/ le terme trunk ne désigne pas la même chose chez HP et cisco:
chez cisco un port trunk est un port taggé.
chez HP c'est un port multilink (plusieurs ports ethernet groupés en un sel: lacp, etherchannel chez cisco (channel-group))
donc un port trunk cisco doit être relié à un port juste taggé HP.
pour le vtp, il ne faut même pas y penser, il faudra configurer les vlans en manuel sur le HP.
1
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
23 juin 2010 à 15:43
D'accord, donc si je comprends bien ce que tu me dis, l'idée de trunk n'existe pas sur HP, il n'y a aucun moyen de faire transiter des Vlans d'un switch Cisco sur un switch HP ?

Mais j'avais déjà essayé de les créer manuellement, ça créait une collision, les mêmes Vlans étant créés sur les deux switchs...

Ce n'est donc pas une option :s

D'autre part, pour ce qui est du switch HP, j'ai juste taggé le Vlan1 (par défaut pour ne pas en créé un) affecté au port 24 sans spanning-tree afin de récupérer de ce Vlan (qui a une adresse IP) les Vlans du switch Cisco qui est connecté à mon Vlan 136 (avec la même plage d'adresse IP et le même masque que le HP).

Cette méthode ne peut donc pas fonctionner ?

Dans ce cas, comment relier deux switchs un HP et un Cisco ensemble et pouvoir se servir des mêmes Vlans sur les deux ? :s
0
Butters64 Messages postés 327 Date d'inscription mardi 19 août 2008 Statut Membre Dernière intervention 14 janvier 2013 4
Modifié par Butters64 le 23/06/2010 à 15:51
chez hp ou autre constructeur c'est le 802.1q.
Il faut activer le protocole sur le port relié au switch cisco et y attribuer les vlan autorisés.
VTP comme le dit brupala c'est cisco, regarde si tu n'as pas le protocole GVRP qui est le vtp mais chez les autres
0
brupala Messages postés 109104 Date d'inscription lundi 16 juillet 2001 Statut Membre Dernière intervention 4 mars 2024 13 569
Modifié par brupala le 23/06/2010 à 16:03
non,
il faut configurer chaque vlan du cisco en vlan taggé sur le HP, à cette condition le traffic des vlans passera entre les deux, mais il faut configurer les vlans manuellement.
les vlans n'ont pas d'adresse ip, ce sont les interfaces de routage sur le vlan qui ont une adresse ip éventuellement.
Aussi,
les vlans sur le cisco doivent être dot1q (802.1q) pas ISL qui est aussi propriétaire cisco.
le trunk sur un HP c'est un etherchannel cisco
le port taggé HP est un trunk 802.1q cisco
et GVRP est incompatible avec VTP
0
Butters64 Messages postés 327 Date d'inscription mardi 19 août 2008 Statut Membre Dernière intervention 14 janvier 2013 4
23 juin 2010 à 16:00
Seul le Vlan d'administration possède un ip sur les équipements.
Le 802.1q c'est un standard définit IEEE!
Sinon brupala a raison, crée les vlans manuellement et pour la partie cisco tu fais le mode trunk allowed + vlan propagés et sur hp, je regarde sur la doc si je trouve
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
24 juin 2010 à 09:18
Merci beaucoup à tous les deux.
Je vais réessayer et voir ce que ça donne, je vous tiens au courant !
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
22 juin 2010 à 10:21
Bon, en cherchant un peu (pas mal même ^^), j'ai pu trouver dans une doc online d'HP cette commande là :

trunk ethernet 24 trk1

Qui me permet de rajouter le port 24 en mode trunk dans le groupe trk1 (trunk 1).

J'ai donc affecté ce port 24 en trunk, lui est affecté en tagged le Vlan 1.

Que me reste-t-il à faire pour que les Vlans créés sur mon switch cisco server puissent transiter vers mon switch HP Procurve ?

Merci d'avance.
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
22 juin 2010 à 11:40
Je vous mets là les différentes configurations que j'ai mis sur les ports concernés.

Switch HP :

Port 24, mode trunk dans le groupe trunk 1, il est tagged au Vlan 1 avec une adresse IP en 10.0.0.248

Switch Cisco :

Port 8, mode trunk sans VTP sans rien, en no shutdown (même si ce n'est pas nécessaire), sur le Vlan 10 avec une IP en 10.0.0.250 (les deux switchs ont un masque identique en 255.255.255.0).

Avant que je n'affecte le port 8 en trunk, il était en mode access toujours sur le Vlan 10 avec les mêmes configs et le ping du Switch HP vers le Switch Cisco fonctionnait parfaitement.

Depuis que je l'ai mis en mode Trunk, le ping ne passe plus ...
J'ai lu quelque part que le spanning-tree devait être désactivé pour les ports trunks, or, il est activé sur tous les ports et même le port trunk !

Cependant, j'ai fait un "no spanning-tree" et rien à faire, je n'arrive pas à désactiver le spanning-tree sur plusieurs ports en même temps ni même sur un port ...

Le fait que le ping ne passe plus peut venir de ça ?

Merci d'avance.
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
22 juin 2010 à 14:15
Personne ne saurait ce qui ne va pas SVP ?
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
23 juin 2010 à 09:20
Petite relance, je n'ai toujours pas réussi à faire fonctionner le trunk :s
D'ailleurs, lorsque je branche mon câble croisé sur le vlan 10 en mode access de mon Cisco et que je tente un ping du Cisco vers HP ou inversement, le ping passe.
Cependant, lorsque je configure le même port du Vlan 10 du Cisco en trunk, là ça ne fonctionne plus, c'est bien que le lien ne se fait pas, il le bloque car pour lui c'est un réseau différent :s

J'ai activé le GVRP car on m'a dit que c'était l'équivalent du VTP du Cisco sur HP mais toujours aucun changement.

Si quelqu'un saurait comment faire SVP :s
0
Butters64 Messages postés 327 Date d'inscription mardi 19 août 2008 Statut Membre Dernière intervention 14 janvier 2013 4
23 juin 2010 à 13:39
Salut,

Quand tu dis : D'ailleurs, lorsque je branche mon câble croisé sur le vlan 10 en mode access de mon Cisco et que je tente un ping du Cisco vers HP ou inversement, le ping passe.
C'est à dire, tu connecte un ordi a un port qui est en mode accèssur le cisco et tu arrives à faire un ping sur l'adresse ip de management de ton switch hp?
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
23 juin 2010 à 14:15
Exactement, je suis connecté à mon Switch Cisco par telnet et à mon switch HP par port console.

Je peux donc faire les tests d'un côté comme de l'autre.

Ca répond quand le port du Cisco est en mode access mais quand je le mets en mode trunk là plus de réponse !
0
Butters64 Messages postés 327 Date d'inscription mardi 19 août 2008 Statut Membre Dernière intervention 14 janvier 2013 4
23 juin 2010 à 15:12
C'est le port où tu as l'ordi de connecté que tu passes en mode trunk?
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
23 juin 2010 à 15:15
Non, non, c'est un autre port, le port trunk relie juste mon switch Cisco à mon switch HP.
Il est en no spanning-tree aussi !
0
Butters64 Messages postés 327 Date d'inscription mardi 19 août 2008 Statut Membre Dernière intervention 14 janvier 2013 4
23 juin 2010 à 15:23
ok le port qui raccorde les 2 switchs.
Tu as créé tes vlans des 2 côtés dans la vlan database et tu as activé le 802.1q sur ton port trunk.

sous cisco c'est du genre

switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan "Numéro de vlan"
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
23 juin 2010 à 15:39
Justement non, je n'ai pas créé mes Vlans sur les deux Switchs car le but est que les Vlans créés sur le switch Cisco se transmettent au switch HP via le "trunk".
Si je créé les Vlans sur les deux switchs, alors il y a collision et ça ne fonctionne pas.

Pour le trunk, c'est fait sur le Cisco sauf pour la commande switchport trunk encapsulation dot1q qui ne fonctionne pas (je me suis renseigné sur le net et c'est automatiquement en dot1q donc pas besoin de le mettre, la commande n'est même pas valide.)

Merci pour ton aide, si tu as d'autres idées elle sont la bienvenue ^^
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
28 juin 2010 à 09:50
Désolé du retard tout d'abord mais j'étais malade ...

Bref, bon alors si j'ai bien compris, il faudrait d'une part que je retire le VTP de mon Cisco et que je ne rajoute pas le GVRP sur le HP.

D'autre part que sur tous les ports affectés aux Vlans sur le Cisco je tape la commande : switchport trunk allowed vlan 10 (pour le Vlan 10 par exemple).
Que sur le Switch HP je mette tous les ports nécessaires en tagged du Vlan concerné et que je recréé tous les Vlans.

Après cela c'est censé marcher normalement ?

Je veux savoir ça par simple curiosité car le problème que je rencontre c'est que je ne peux pas supprimer le VTP sur mon Cisco sachant que les deux Switchs Cisco sont en prod' ...

N'y a-t-il aucune solution ?
0
brupala Messages postés 109104 Date d'inscription lundi 16 juillet 2001 Statut Membre Dernière intervention 4 mars 2024 13 569
Modifié par brupala le 30/06/2010 à 12:48
Tu n'as pas besoin de supprimer le vtp sur tes cisco,
on t'a dit plus haut de configurer manuellement tes vlans sur le HP , de tagger sur les cisco le port trunk en 802.1q (pas en isl) ainsi que sur le HP .
tu l'as fait ?
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
30 juin 2010 à 14:10
Bah sur les Ciscos je ne peux pas les tagger en 802.1q car je n'ai pas l'option, les ports sont automatiquement configurés en 802.1q sur un Cisco 2960G !
Pour le HP, je n'ai pas trouvé comment faire, je les ai mis en tagged tous mais leur mettre le protocole 802.1q, je ne sais pas si c'est ça ou s'il faut faire autre chose :s
0
brupala Messages postés 109104 Date d'inscription lundi 16 juillet 2001 Statut Membre Dernière intervention 4 mars 2024 13 569
Modifié par brupala le 1/07/2010 à 00:05
t'en fais pas, les HP, comme les cisco récents ne connaisssent que 802.Q, c'est donc résolu à ce niveau...
ça communique ou pas ?
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
1 juil. 2010 à 08:41
Bah en fait pour t'avouer tout pour le moment je suis sur un autre problème ...
Il m'a dit de laisser ça de côté de et m'occuper d'un HP ...
J'ai lancé un sujet si tu veux sur ça, je te mets le lien (si ça marche xD) :
https://forums.commentcamarche.net/forum/affich-18308046-xmodem

Si tu t'y connais :s
Une fois cela résolu, je recommencerai le trunk HP / Cisco, désolé !
Et merci de ton aide !
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
28 juin 2010 à 16:18
Personne n'a d'idée SVP ? :s
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
29 juin 2010 à 08:47
Personne ne sautait comment faire ?
C'est urgent svp :s
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
30 juin 2010 à 08:33
Personne n'aurait une idée SVP ?
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
1 juil. 2010 à 15:28
Voici les configs de mon Cisco et de mon HP ...
(PS : J'interconnecte le port 8 du Cisco avec le port 24 du HP !)

------------------------------------------------------------------------------------------------

Cisco :

Switch_CIV_2960_1#show running-config
Building configuration...

Current configuration : 7869 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname Switch_CIV_2960_1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$nQjN$RgZJTQXFb./H3biYg/5qP/
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
!
!
no cluster run
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
crypto pki trustpoint HTTPS_SS_CERT_KEYPAIR
enrollment selfsigned
serial-number
revocation-check none
rsakeypair HTTPS_SS_CERT_KEYPAIR
!
!
crypto pki certificate chain HTTPS_SS_CERT_KEYPAIR
certificate self-signed 01
3082028A 308201F3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
51311B30 19060355 04031412 53776974 63685F43 49565F32 3936305F 312E3132
300F0603 55040513 08393130 38374130 30301F06 092A8648 86F70D01 09021612
53776974 63685F43 49565F32 3936305F 312E301E 170D3933 30333037 31393539
35355A17 0D323030 31303130 30303030 305A3051 311B3019 06035504 03141253
77697463 685F4349 565F3239 36305F31 2E313230 0F060355 04051308 39313038
37413030 301F0609 2A864886 F70D0109 02161253 77697463 685F4349 565F3239
36305F31 2E30819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100C7D1 83526F9E 168D98BE 3C0292F3 F592CFEE C3BEB636 CF3398AF FCD37BFA
9E1BD1DA F9878012 4F206773 F87B7F7B 3CCB5D16 4B4F4983 E0F34BAC 0A8E041C
3C31D087 F17FF9F7 8F3ED2C6 F982D31C 38F81F9E 71B8B749 2DC25931 F6F84689
CEB3BB37 B973982F E3A64C61 A0993078 51577E74 03ADB4EB 9D4473EE DECB42C6
0B9B0203 010001A3 72307030 0F060355 1D130101 FF040530 030101FF 301D0603
551D1104 16301482 12537769 7463685F 4349565F 32393630 5F312E30 1F060355
1D230418 30168014 06E42893 63D86D7A 6AF32EF3 917F2ABD 5D4F20C8 301D0603
551D0E04 16041406 E4289363 D86D7A6A F32EF391 7F2ABD5D 4F20C830 0D06092A
864886F7 0D010104 05000381 810099A9 8BF6213F CFA058C4 BBF09DEA B9517B9A
E3ECE47E DB7DC1F2 AC9351C0 BF390FC6 D70388B7 9D67C276 631A14B5 8B2E58A2
7680A0C5 64386E00 4043F7A3 68FD133A E0B44731 02E78B0C 87F0A8BD 48298CD8
A23A2E35 2AF2D708 86B01869 0F8D437D 0579C05E A752E648 35D8AD10 BEEDF313
496E32CD B2E872C7 18348615 3C95
quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/2
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/3
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/4
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/5
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/6
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/7
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/8
switchport trunk native vlan 136
switchport trunk allowed vlan 1
switchport mode trunk
!
interface GigabitEthernet0/9
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/10
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/11
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/12
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/13
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/14
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/15
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/16
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/17
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/18
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/19
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/20
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/21
switchport access vlan 13
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/22
switchport access vlan 13
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/23
switchport access vlan 13
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/24
switchport mode trunk
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan10
no ip address
no ip route-cache
!
interface Vlan12
no ip address
no ip route-cache
!
interface Vlan136
ip address 10.77.136.250 255.255.255.0
no ip route-cache
!
ip http server
ip http secure-server
ip sla enable reaction-alerts
!
line con 0
line vty 0 4
password 7 013F0F014E1807062F580F5940
login
length 0
line vty 5 15
login
!
end

Switch_CIV_2960_1#

---------------------------------------------------------------------------------------------------

HP :

Switch_CIV_2524# show running-config

-- MORE --, next page: Space, next line: Enter, quit: Control-C

Running configuration:

; J4813A Configuration Editor; Created on release #F.05.72

hostname "Switch_CIV_2524"
cdp run
interface 1
speed-duplex 100-full
exit
interface 2
speed-duplex 100-full
exit
interface 3
speed-duplex 100-full
exit
interface 4
speed-duplex 100-full
exit
interface 5
speed-duplex 100-full
exit
interface 6

-- MORE --, next page: Space, next line: Enter, quit: Control-C
speed-duplex 100-full
exit
interface 7
speed-duplex 100-full
exit
interface 8
speed-duplex 100-full
exit
interface 9
speed-duplex 100-full
exit
interface 10
speed-duplex 100-full
exit
interface 11
speed-duplex 100-full
exit
interface 12
speed-duplex 100-full
exit
interface 13
speed-duplex 100-full
exit

-- MORE --, next page: Space, next line: Enter, quit: Control-C
interface 14
speed-duplex 100-full
exit
interface 15
speed-duplex 100-full
exit
interface 16
speed-duplex 100-full
exit
interface 17
speed-duplex 100-full
exit
interface 18
speed-duplex 100-full
exit
interface 19
speed-duplex 100-full
exit
interface 20
speed-duplex 100-full
exit
interface 21
speed-duplex 100-full

-- MORE --, next page: Space, next line: Enter, quit: Control-C
exit
interface 22
speed-duplex 100-full
exit
interface 23
speed-duplex 100-full
exit
interface 24
speed-duplex 100-full
exit
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 25-26
ip address dhcp-bootp
no untagged 1-24
exit
vlan 10

name "vlan_admin"
untagged 1-12
ip address 10.77.136.248 255.255.255.0
exit
vlan 136
name "vlan_firewal"
tagged 21-24
exit
vlan 12
name "vlan_save"
tagged 13-16
exit
vlan 13
name "vlan_ghost"
tagged 17-20
exit
gvrp
no aaa port-access authenticator active
spanning-tree protocol-version stp
spanning-tree priority 1
spanning-tree 1-23 priority 1
password manager

Switch_CIV_2524#

--------------------------------------------------------------------------------------------------
0
Butters64 Messages postés 327 Date d'inscription mardi 19 août 2008 Statut Membre Dernière intervention 14 janvier 2013 4
Modifié par Butters64 le 2/07/2010 à 09:40
interface GigabitEthernet0/24
switchport mode trunk
switchport trunk allowed 10,12,13,136
pour mettre les vla,n sur ton liens trunk si jamais tu veux qu'il communique avec le hp.
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
2 juil. 2010 à 09:48
Merci pour ton aide.
Pour info, ce n'est pas sur le port 24 qu'il se fait mon trunk Cisco mais sur le port 8 (le port 24 est le port qui est en prod et en trunk VTP avec un autre Cisco).
J'ai donc modifié mes deux Switchs comme suit mais toujours aucun changement ...

HP :

[quote]Switch_CIV_2524# show runn

-- MORE --, next page: Space, next line: Enter, quit: Control-C

Running configuration:

; J4813A Configuration Editor; Created on release #F.05.72

hostname "Switch_CIV_2524"
cdp run
interface 1
speed-duplex 100-full
exit
interface 2
speed-duplex 100-full
exit
interface 3
speed-duplex 100-full
exit
interface 4
speed-duplex 100-full
exit
interface 5
speed-duplex 100-full
exit
interface 6

-- MORE --, next page: Space, next line: Enter, quit: Control-C
speed-duplex 100-full
exit
interface 7
speed-duplex 100-full
exit
interface 8
speed-duplex 100-full
exit
interface 9
speed-duplex 100-full
exit
interface 10
speed-duplex 100-full
exit
interface 11
speed-duplex 100-full
exit
interface 12
speed-duplex 100-full
exit
interface 13
speed-duplex 100-full
exit

-- MORE --, next page: Space, next line: Enter, quit: Control-C
interface 14
speed-duplex 100-full
exit
interface 15
speed-duplex 100-full
exit
interface 16
speed-duplex 100-full
exit
interface 17
speed-duplex 100-full
exit
interface 18
speed-duplex 100-full
exit
interface 19
speed-duplex 100-full
exit
interface 20
speed-duplex 100-full
exit
interface 21
speed-duplex 100-full

-- MORE --, next page: Space, next line: Enter, quit: Control-C
exit
interface 22
speed-duplex 100-full
exit
interface 23
speed-duplex 100-full
exit
interface 24
speed-duplex 100-full
exit
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 25-26
ip address dhcp-bootp
no untagged 1-24
exit
vlan 10
name "vlan_admin"
untagged 1-12
no ip address
tagged 24

exit
vlan 136
name "vlan_firewal"
untagged 21-23
ip address 10.77.136.248 255.255.255.0
tagged 24
exit
vlan 12
name "vlan_save"
untagged 13-16
tagged 24
exit
vlan 13
name "vlan_ghost"
untagged 17-20
tagged 24
exit
no aaa port-access authenticator active
spanning-tree protocol-version stp
spanning-tree priority 1
spanning-tree 1-23 priority 1
password manager

Switch_CIV_2524#/quote

Cisco :

[quote]Switch_CIV_2960_1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch_CIV_2960_1(config)#int
Switch_CIV_2960_1(config)#interface gi
Switch_CIV_2960_1(config)#interface gigabitEthernet 0/24
Switch_CIV_2960_1(config-if)#swi
Switch_CIV_2960_1(config-if)#exit
Switch_CIV_2960_1(config)#swi
Switch_CIV_2960_1(config)#in
Switch_CIV_2960_1(config)#interface gi
Switch_CIV_2960_1(config)#interface gigabitEthernet 0/8
Switch_CIV_2960_1(config-if)#swi
Switch_CIV_2960_1(config-if)#switchport mo
Switch_CIV_2960_1(config-if)#switchport mode tr
Switch_CIV_2960_1(config-if)#switchport mode trunk
Switch_CIV_2960_1(config-if)#swi
Switch_CIV_2960_1(config-if)#switchport tr
Switch_CIV_2960_1(config-if)#switchport trunk allo
Switch_CIV_2960_1(config-if)#switchport trunk allowed 10,12,13,136
^
% Invalid input detected at '^' marker.

Switch_CIV_2960_1(config-if)#switchport trunk allowed vlan 10,12,13,136
Switch_CIV_2960_1(config-if)#exit
Switch_CIV_2960_1(config)#exit
Switch_CIV_2960_1#wr m
Building configuration...
[OK]
Switch_CIV_2960_1#sho
Switch_CIV_2960_1#show ru
Switch_CIV_2960_1#show running-config
Building configuration...

Current configuration : 7880 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname Switch_CIV_2960_1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$nQjN$RgZJTQXFb./H3biYg/5qP/
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
!
!
no cluster run
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
crypto pki trustpoint HTTPS_SS_CERT_KEYPAIR
enrollment selfsigned
serial-number
revocation-check none
rsakeypair HTTPS_SS_CERT_KEYPAIR
!
!
crypto pki certificate chain HTTPS_SS_CERT_KEYPAIR
certificate self-signed 01
3082028A 308201F3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
51311B30 19060355 04031412 53776974 63685F43 49565F32 3936305F 312E3132
300F0603 55040513 08393130 38374130 30301F06 092A8648 86F70D01 09021612
53776974 63685F43 49565F32 3936305F 312E301E 170D3933 30333037 31393539
35355A17 0D323030 31303130 30303030 305A3051 311B3019 06035504 03141253
77697463 685F4349 565F3239 36305F31 2E313230 0F060355 04051308 39313038
37413030 301F0609 2A864886 F70D0109 02161253 77697463 685F4349 565F3239
36305F31 2E30819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100C7D1 83526F9E 168D98BE 3C0292F3 F592CFEE C3BEB636 CF3398AF FCD37BFA
9E1BD1DA F9878012 4F206773 F87B7F7B 3CCB5D16 4B4F4983 E0F34BAC 0A8E041C
3C31D087 F17FF9F7 8F3ED2C6 F982D31C 38F81F9E 71B8B749 2DC25931 F6F84689
CEB3BB37 B973982F E3A64C61 A0993078 51577E74 03ADB4EB 9D4473EE DECB42C6
0B9B0203 010001A3 72307030 0F060355 1D130101 FF040530 030101FF 301D0603
551D1104 16301482 12537769 7463685F 4349565F 32393630 5F312E30 1F060355
1D230418 30168014 06E42893 63D86D7A 6AF32EF3 917F2ABD 5D4F20C8 301D0603
551D0E04 16041406 E4289363 D86D7A6A F32EF391 7F2ABD5D 4F20C830 0D06092A
864886F7 0D010104 05000381 810099A9 8BF6213F CFA058C4 BBF09DEA B9517B9A
E3ECE47E DB7DC1F2 AC9351C0 BF390FC6 D70388B7 9D67C276 631A14B5 8B2E58A2
7680A0C5 64386E00 4043F7A3 68FD133A E0B44731 02E78B0C 87F0A8BD 48298CD8
A23A2E35 2AF2D708 86B01869 0F8D437D 0579C05E A752E648 35D8AD10 BEEDF313
496E32CD B2E872C7 18348615 3C95
quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/2
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/3
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/4
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/5
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/6
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/7
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/8
switchport trunk native vlan 136
switchport trunk allowed vlan 10,12,13,136
switchport mode trunk
!
interface GigabitEthernet0/9
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/10
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/11
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/12
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/13
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/14
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/15
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/16
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/17
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/18
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/19
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/20
switchport access vlan 136
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/21
switchport access vlan 13
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/22
switchport access vlan 13
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/23
switchport access vlan 13
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/24
switchport mode trunk
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan10
no ip address
no ip route-cache
!
interface Vlan12
no ip address
no ip route-cache
!
interface Vlan136
ip address 10.77.136.250 255.255.255.0
no ip route-cache
!
ip http server
ip http secure-server
ip sla enable reaction-alerts
!
line con 0
line vty 0 4
password 7 013F0F014E1807062F580F5940
login
length 0
line vty 5 15
login
!
end

Switch_CIV_2960_1#/quote
0
Butters64 Messages postés 327 Date d'inscription mardi 19 août 2008 Statut Membre Dernière intervention 14 janvier 2013 4
2 juil. 2010 à 13:31
sur hp je vais pas m avancer, je connais pas leur commandes.
Question bête, t as pensé à faire un no shutdown sur tes ports du cisco?
0
yusuke93000 Messages postés 23 Date d'inscription mardi 22 juin 2010 Statut Membre Dernière intervention 5 juillet 2010
2 juil. 2010 à 14:05
Hum lol ^^
En fait pour tout te dire, j'ai tenté pour voir si c'était pas une erreur bête ou de port de reconfigurer ce port 8 en access et en Vlan 136, en enlevant le trunk et ça passe niquel !
Non, non, c'est pas une erreur comme ça, c'est une erreur bien chiante a trouvé malheureusement :s
Merci de ton aide, c'est sympa, j'apprécie !
Je galère vraiment à trouver de l'aide quand même, ça va faire 2 semaines que je suis dessus xD
0
Butters64 Messages postés 327 Date d'inscription mardi 19 août 2008 Statut Membre Dernière intervention 14 janvier 2013 4
2 juil. 2010 à 14:38
La conf cisco a l'air d'etre ok, il faut chercher du coté du hp.
Je vais essayer de chercher
0