Un pb w3c avec un link css [Résolu/Fermé]

Signaler
-
Messages postés
18516
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
5 mars 2021
-
Bonjour a tous, voila, j'aibeau cherhcer et meme dans les fonctionnaliter de w3c, je ne parviens pas a trouver mon bug.

quand je passe la page http://trident.u7n.org au validateur html du w3c http://validator.w3.org/... il me dis:
Line 50, Column 98: Required attributes missing on element link.

...trident.u7n.org/module/random/lightbox.css" rel="stylesheet" type="text/css" />

Element-specific attributes for element link:
    Global attributes
    href
    rel
    media
    hreflang
    type
    sizes
    Also, the title attribute has special semantics on this element. 


J'ai beau essayer de comprendre le bug, je ne trouve pas. pouvez vous m'aidez?

5 réponses

Messages postés
318
Date d'inscription
lundi 23 juillet 2007
Statut
Membre
Dernière intervention
28 mars 2012
30
Salut,

Remplace
 />
par
>

Fonctionne pas, toujours la même erreur.
Messages postés
18516
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
5 mars 2021
4 269
Place la balise <link> dans <head>.

Melheureusement, je ne peux pas, ce css est charger quand on demande a un module d'etre sur le site, sinon il nest pas necessaire.
Messages postés
18516
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
5 mars 2021
4 269
Tu peux appeler une fonction « includePluginsFiles(); » dans le head.
Forcément, tu dois déjà faire du PHP avant d'inclure les templates.