Suppression espace fin de cellule

[Résolu/Fermé]
Signaler
Messages postés
176
Date d'inscription
lundi 29 septembre 2008
Statut
Membre
Dernière intervention
21 mai 2014
-
Messages postés
17465
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 août 2021
-
Bonjour,

J'ai une suite de cellule.
Certaines ont un espace à la fin et d'autre n'en n'ont pas.

Je ne peux donc pas me servire de la fonction suppression des doublons...

est ce que quelqu'un sait s'il est possible de supprimer cet espace? ou de recopier toutes les cellule sans le dernier espace?

nota : toutes les cellule n'ont pas le même nombre de caractères.


A voir également:

2 réponses

Messages postés
17465
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 août 2021
4 684
Salut,

Pour la suppression des espace en début et fin de valeur, il y a la fonction SUPPRESPACE pour valeur en A1 copier la formule et incrémenter vers le bas

=SUPPRESPACE(A1)
8
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
2477
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
18 juin 2021
987
Bonjour,
Le procédé qui suit est un peu lourd mais faute de mieux!!
Créer une colonne en incrémentant la formule:
=SI(CODE(DROITE(A1))=32;STXT(A1;1;NBCAR(A1)-1);A1)
Cette formule suppose que l'espace est bien un code 32.
Faire un copier/ collage spécial "valeur" avant d'extraire sans doublon.