Ignorer cellules vides [Résolu/Fermé]

Signaler
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour,

J'ai une formule dans une cellule qui se valide quand les conditions sont remplies.
Je souhaiterais que cette cellule n'affiche rien quand il n'y a pas tous les paramètres c-a-d qu'elle reste vide.
Pour l'instant j'ai un message DIV/0 (logique) mais je ne trouve pas la formule pour dire que s'il n'y a rien donc rien.
En espèrant que vous me répondiez car je galère depuis des jours.
Je vous remercie.

4 réponses

Messages postés
2950
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 270
Bonjour,

Tu peux t'inspirer de ceci :

=si(A1="";"";faire ceci)
ou
=si(A1=0;"";faire ceci)
tu fais un test sur la cellule vide (ici, tu dois avoir une division par 0) et tu demandes à ne rien afficher si la condition est remplie (vide ou 0) sinon tu demandes ton calcul.

A+

pépé
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57107 internautes nous ont dit merci ce mois-ci

Messages postés
52050
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
13 816
Impossible de t'aider :
* Tu ne dis pas quel logiciel tu utilises.
* S'il s'agit d'un logiciel de Microsoft, il faut préciser la version (2003/2007 ?)
* Tu n'indiques pas quelle est ta formule actuelle, qu'il faudrait compléter.
En l'absence de ces informations, je ne peux que te conseiller d'utiliser la fonction SI et la fonction ESTERREUR (si comme je le suppose tu utilises un tableur).
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Bonjour
tout ce que vous pourrez faire au niveau de la cellule diviseur ne fera jamais disparaitre le code #DIV/0 qui apparait lorsque excel, comme dans toutes les mathématiques, signale qu'il ne sait pas diviser par 0.
Pour faire disparaitre ce code, il faut travailler au niveau de la cellule résultat, et donc écrire:
=SI(Cell diviseur =0;"";Cellule divisée/ cellule diviseur)
Crdlmnt
Ps: un conseil si vous devez repartir de cette cellule pour d'autres calculs, préférez ;0; à;""; car ce signe est dans bien des cas pris par excel pour du texte.
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 106
bonjour

Avec la formule que tu as mise sur l'autre poste, cela devrait donner :

=SI(ESTVIDE(D49);"";SI(N49=1;(M49*$M$6)/D49;SI(N49=2;(M49*$M$7)/D49;SI(N49=3;(M49*$M$8)/D49;SI(N49<=0;(M49*$M$5)/D49)))))
Génial merci !
Sur l'autre post on m'a demandé de rester sur la discussion initiale, mais ne connais pas la manip. c'est la 1ère fois que j'utilise un forum. Désolée
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 106
Bonsoir,

Pas de souci, il faut que tu répondes pour donner des compléments sur le même sujet pour que tout le monde arrive à suivre sinon tu ne retrouverai pas tes réponses.