Excel - fonction 'si' sur plage de cellule [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
mardi 1 décembre 2009
Statut
Membre
Dernière intervention
28 avril 2010
-
Messages postés
5
Date d'inscription
mardi 1 décembre 2009
Statut
Membre
Dernière intervention
28 avril 2010
-
Bonjour,

Je cherche à écrire une formule de contrôle mais sans succès.. La formule en question ne porte pas sur 1 cellule mais sur une plage de cellule. L'un d'entre vous pourrait-il m'aider ?

Problématique :

Soit 2 colonnes : A et B.
Plage de la colonne A -> (A1 : A10)
Plage de la colonne B -> (B1 : B10)

Certaines cellules de la plage (B1 : B10) sont vides, d'autres ont un montant d'inscrit.

Dans une unique formule qui serait en B25 par exemple, je voudrais que :
- si, dans la plage (B1 : B10) certaines cellules sont "renseignées"(ou "non vides") et que les cellules de la colonne A (qui leur sont contigues) sont vides, alors inscrire le message "erreur".
- Et, a contrario, si les celules de la plage B indiquée sont vides et que les celules de la colonne A qui leur sont contigues sont également vides, alors c'est OK.

Bref, je voudrais faire un contrôle sur la plage B de mon document et m'assurer que si B1 est vide alors A1 est vide ou si B1 est renseignée alors A1 l'est aussi.. Et ainsi de suite pour les lignes 2, 3 ... jusqu'à 10.

Merci d'avance pour votre aide !

ps : je n'arrive pas à joindre une pièce type feuille excel.

5 réponses

Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Bonjour essayez en B25 la formule:
=SI(SOMMEPROD((B1:B10<>"")*(A1:A10=""))>0;"erreur";"OK")
ceci vous signalera qu'il y a une ligne défectueuse mais par contre ne vous dira pas laquelle.
Crdlmnt
Messages postés
16431
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
9 avril 2021
3 162
Bonjour,

mal compris...
Une seule formule en B25 pour l'ensemble ?

si on a par ex B1 non vide et A1 vide et d'autre part A8 non vide et B8 vide, que fait on ?
Messages postés
53608
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 avril 2021
15 653
Pour joindre un fichier (Excel ou n'importe quel autre), coller le lien qui sera créé dans https://www.cjoint.com/ ou http://cijoint.fr
--
C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂
Messages postés
23995
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 avril 2021
6 723
Bonjour tout le monde,

Vaucluse, je crois qu'il faut signaler également en erreur A rempli et B vide (?)
Si c'est le cas alors :
=SI(SOMMEPROD((B1:B10<>"")*(A1:A10="")+(B1:B10="")*(A1:A10<>""))>0;"erreur";"OK")
eric
Messages postés
5
Date d'inscription
mardi 1 décembre 2009
Statut
Membre
Dernière intervention
28 avril 2010

Bonjour,

Un grand merci à Vaucluse, Raymond, Eriiic (ainsi qu'à ceux qui ont essayé de trouver une solution) !

La formule suggérée par eriiic est impeccable :

=SI(SOMMEPROD((B1:B10<>"")*(A1:A10="")+(B1:B10="")*(A1:A10<>""))>0;"erreur";"OK")

Effectivement, je cherchais également à signaler un message d'erreur si, par exemple, A8 était remplie et B8 ne l'était pas..

Merci à vous !