Fonction si imbriquée dans Excel

Résolu/Fermé
Signaler
-
 MouradB -
Bonjour

Je souhaiterais utiliser une formule dans excel (et si possible obtenir le résultat direct dans une cellule), mais n'y arrive pas. Quelqu'un pourrait-il me venir en aide ? Si oui, un GRAND MERCI

Voilà ce que je souhaite obtenir :

si(J6<1.05;0 et si J6 compris entre 1.05 et 1.10;2000*B6 et si J6 compris entre 1.10 et 1.12;3000*C6)

Merci à tous ceux qui voudront bien me répondre

Meilleures salutations

Martine LABOURBE

21 réponses


Bonjour,

suggestion :

=SI(J6 < 1,05;0;SI((J6 < 1,1);2000 * B6;SI(J6 < 1,12;(3000 * B6);0)))

Lupin
33
Tout à fait ce que je cherchais. Grand merci, Lupin.
0
Messages postés
1723
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
4 décembre 2021
543
Je n'ai toujours absolument rien ompris à ton problème (Alpha? Béta?) mais je pense pouvoir t'indiquer une piste:

en C1 tu mets:
=Si(ET(A1>1;B1="");1;0)

je pense que c'est le ET que tu ne connaissais pas?
9
Je n'arrive à enchainer plusieurs SI(ET
exemple=Si(ET(A1>1;B1="");1;0);Si(ET(A2>1;B1="");2;0) ;Si(ET(A1>1;B1="");11)
0
Messages postés
55387
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 janvier 2022
17 220
Déjà 28 messages dans cette vieille discussion lancée il y a 8 ans !
Tu aurais mieux fait de créer une nouvelle discussion ...

=Si(ET(A1>1;B1="");1;0);Si(ET(A2>1;B1="");2;0) ;Si(ET(A1>1;B1="");11)
La parenthèse entre le 0 et le SI doit être supprimée chaque fois, ce qui donne
=Si(ET(A1>1;B1="");1;0 ;Si(ET(A2>1;B1="");2;0 ;Si(ET(A1>1;B1="");11)
Après le 11 en fin de formule il manque le résultat à afficher si le test est négatif
=Si(ET(A1>1;B1="");1;0 ;Si(ET(A2>1;B1="");2;0 ;Si(ET(A1>1;B1="");11 ;0)
Il faut y avoir autant de parenthèses fermantes que de parenthèses ouvrantes ; tu en as 6 d'ouvertes, mais seulement 4 de fermées ; il faut en ajouter 2
=Si(ET(A1>1;B1="");1;0 ;Si(ET(A2>1;B1="");2;0 ;Si(ET(A1>1;B1="");11 ;0) ))

Ensuite je suppose que ton troisième test concernait la cellule A3, et non A1 encore une fois ?
=Si(ET(A1>1;B1="");1;0 ;Si(ET(A2>1;B1="");2;0 ;Si(ET(A3>1;B1="");11 ;0) ))
Enfin il faut éviter de refaire 3 fois le test sur B1 ; un seul suffit !
=SI(B1="";SI(A1>1;1;SI(A2>2;2;SI(A3>1;11;0)));0)

La formule est maintenant écrite avec une syntaxe correcte, mais je ne suis pas certain que dès le départ ton raisonnement logique soit juste !
En effet si A1>1 le premier test est VRAI, donc le calcul s'arrête et la cellule affiche le résultat 1, sans avoir l'occasion de tester le contenu de A2 ; est-ce bien ce que tu souhaitais ?
0
Bonjour j'ai besoin d aide :)

J essaye de faire une fonction SI et OU imbriqué mais le résultat est tjs 0... alors qu i ldevrait changer en fonction de la valeur de D4 :

voici la formule :

= SI(OU(D4=1111;D4=1112;D4=1113;D4=1118;D4=1119);"BUN";SI(OU(D4=120;D4=1200;D4=1201;D4=121;D4=1218;D4=1219;D4=122;D4=123;D4=125;D4=126;D4=127;D4=128;D4=129;D4=512;D4=124;D4=201;D4=202;D4=203;D4=204;D4=205;D4=206;D4=207;D4=208;D4=209;D4=210;D4=212;D4=211;D4=301;D4=302;D4=303);"SUN";SI(OU (D4=310;D4=311;D4=3110;D4=312;D4=313;D4=314;D4=315;D4=316;D4=401;D4=402;D4=403;D4=404;D4=405;D4=406;D4=407;D4=408;D4=409;D4=341;D4=342);"sun";SI(OU(D4=510;D4=511;D4=5110;D4=513;D4=419;D4=420;D4=421;D4=422;D4=423;D4=424;D4=501;D4=502;D4=503;D4=504;D4=603;D4=711;D4=712;D4=700;D4=701;D4=7010;D4=702;D4=7021;D4=7022);"SUBL";0))))

merci de votre aide...
7
Messages postés
1723
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
4 décembre 2021
543
C'est juste une question de parenthèses:
=SI(Total>30000;((Total-30000)*20%)+1499,9+2249,85;SI(Total>=15000;((Total-15000)*15%)+1499,­9;Total*10% ))
7
pour que ta formule fonctionne, tu dois mettre les nombres décimaux avec un point et non une virgule. Tes parenthèse sont OK.
0
Messages postés
2
Date d'inscription
dimanche 17 février 2008
Statut
Membre
Dernière intervention
17 février 2008
7
merci LatelyGeek mais ça ne fonctionne pas

de 0 à 14499 € il gagne 10%
de 15000 à 29990 il gagne 15%
et au delà de 30000 il gagne 20%

en sachant que les paliers s'ajoutent

peut - être que je n'ai pas sû mexpliquer.

meerci encore
6
Messages postés
1723
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
4 décembre 2021
543
=SI(Total>30000;Total-30000*20%+1499,9+2249,85;SI(Total>=15000;Total-15000*15%+1499,9;Total*10% ))
4
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 590
bonjour

Sans doute avec SOMMEPROD :

=SOMMEPROD((B26:B216>=20)*(C26:C216="oui"))
3
ah oui en effet ça marche !!!

Merci beaucoup !!!
0
Messages postés
1723
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
4 décembre 2021
543
C'est quoi ta question, au juste???

Pour le moment, je te répondrais: Non, tu te trompes: 1 et 15, ça fait 16!!!!!
2
merci pour ta réponse toi!!
0
Messages postés
2
Date d'inscription
dimanche 17 février 2008
Statut
Membre
Dernière intervention
17 février 2008
7
Bonjour,
J'ai besoin d'aide. voilà je dois calculer les commissions de mes commerciaux.

SI total>30000 alors total-30000*20%+1499,9+2249,85
SItotal est compris entre 15000 et 29990 alors total-15000*15%+1499,9
SI total <14999 alors total*10%

Voilà si quelqu'un peut m'aider car je suis complétément perdue.

Merci de votre aide;
1

est ce que quelqu'un pourrait me venir en aide ? merci d'avance
1 et 15 = 15,5
15,01 et 30 = 22,5
1
Bonjour la compagnie,

Je vous explique mon problème !

Voila dans mon tableau de vérification des mesures relevées que j'utilise pour controler des appareils,

Pour une catégorie Alpha, si la valeur A est supérieur à 1 alors C =0 et D=1 (comme le 2eme cas où A=3 et B=0.5--> l'appareil a été réglé et on trouve donc une 2eme valeur qu'on indique !

Pour une catégorie béta, la valeur A > 1 (A=2-->1er cas) mais elle na pas besoin de révision car c'est un appareil particulier et comme je n'ai rien indiqué dans B (B="") j'aimerai qu'elle affiche un 1 dans C (comme ci dessous)

A B C D
2 1 0
3 0.5 0 1

Donc j'aurai voulu trouvé la fontion qu'il faut utiliser dans la cellule C pour que selon ce qui a dans A et dans B elle m'affiche le numéro correspondant dans C (0 ou 1) --> comme l'exemple ci dessus
1
JE RECTIFIE

A1=2
A2=3

B1 = "" rien d'indiqué
B=0.5

C1=1
C2=0

D1=0
D2=1
0
Alpha et Beta c'était juste pour différencier les 2 lignes : c'est tout :)

je vais essayer la formule

merci
1
PARFAIT GENIALE !!!

Si je connaissais la formule ET mais mal emplyée,

voici pour mon cas : =SI(N67="";"";SI(ET(ABS(N67)>1;P67<>"");0;1))

Merci à tous !!!
1
Bonjour,
Est-il possible de calculer le nombre de mois avant les 21 ans et de faire apparaître si plus de 21 ans "21 ans révolu"
si quelqu'un a la solution génial merci

=SI(-((ANNEE(G1)-ANNEE(C7))*12+MOIS(G1)-MOIS(C7)-252)>0;"=(somme{(-((ANNEE(G1)-ANNEE(J3))*12+MOIS(G1)-MOIS(J3)-252})";SI(-((ANNEE(G1)-ANNEE(C7))*12+MOIS(G1)-MOIS(C7)-252)<=0;"21ans révolu"))
1
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 590
bonjour

Pas du génial mais du simple basique avec date naissance en C7 et date test en G1 :
=SI((G1-C7)/365,25>21;"21 ans révolu";"21 ans dans "&ENT(((7670+C7)-G1)/30,5)&" mois")
1
Merci génial pourqoui faire complquer quand on peut faire simple
co and co
0
Messages postés
1723
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
4 décembre 2021
543
Dans la zone "La formule est" de la mise en forme conditionnelle, il faut mettre:

=SI(((G1-C7)/365,25)+91>21

les 91 jours correpondant aux trois mois (à la louche. On peut faire plus précis si besoin est...)

Attention aux références absolues ou relatives (à indiquer avec un $ si besoin est. J'ai repris ta formule mais je ne sais pas ce que contiennent G1 et C7...)
0
Bonjour
Merci de m'avoir répondu.
la cellule G1 correspond à la date du jour
dans la cellule C7 figure la date de naissance.
J'ai essayé le formule dans la mise en forme conditionnelle en mettant "égal" mais ça ne fonctionne pas il me manque apparament une paranthése j'ai essayé un peu partout mais sans résultat. Il faut dire je ne suis pas très douée un petit coup de main supplémentaire serait le bien venu.
Merci
0
Bonjour,

avec cette formule: =SI(AE4>40;"maintenir";SI(AF>200;"maintenir";"retirer")) , AE=Volume de ventes/produit et AF=CA/par produit

j'espérais afficher "maintenir" quand les qtités vendues sont > à 40 et quand c faux afficher "maintenir" si le CA dépasse 200 et retirer si inférieur ou égal.

Seulement lorsqu'il devrait afficher retirer il me demande un nom. J'ai du louper un truc.

Merci de votre aide
0
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 590
bonjour

J'ai du louper un truc : sans doute les guillemets...
0
Besoin de votre aide SVP. URGENT!

Je dois afficher ds une cellule B6 le nombre 12 si B4<1 ou 22 si 1<=B4<3 ou 30 si 3<=B4<5 ou B4*6,5 si B4>=5 . Comment faire ?
Voici ma proposition qui ne marche pas: =SI(B4<1;12;SI(1<=B4<3;22;SI(3<=B4<5;30;B4*6,5))) .
0
Bonjour
Je reviens avec ma formule des 21 ans. maintenant je cherche mais sans succès une fomule de mise en forme conditionnelle. Je voudrais mettre une alerte quand il ne reste plus que 3 mois avant les 21 ans.
Merci
-1