[EXCEL] Recherche avec résultats multiples [Résolu/Fermé]

Signaler
Messages postés
25
Date d'inscription
lundi 14 décembre 2009
Statut
Membre
Dernière intervention
12 juillet 2010
-
 alexandra_c -
Bonjour,
je possede un fichier dans lequel la valeur "A" est associée avec plusieurs valeurs (disons 1, 2 et 3). Mon objectif est que lorsque dans un cellule il y a ecrit "A" on puisse choisir dans la cellule adjacente entre 1, 2 et 3 dans un menu deroulant.
La je parle que pour une valeur "A" mais le but et détendre le procédé pour plusieurs valeurs.

Merci d'avance.

4 réponses

Messages postés
6284
Date d'inscription
lundi 28 janvier 2008
Statut
Membre
Dernière intervention
29 avril 2020
1 217
applique cette formule dans données/validation/liste

=SI($A$1="a";$C$1:$C$3;0)

avec en A1 la case où tu écris a, en c1 C2 et C3 tu mets 1,2 et 3
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Messages postés
16219
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
1 octobre 2020
3 038
Bonjour,

Sur excel il existe un outil "données-validation-liste " qui te permet de réaliser ce que tu sembles souhaiter
je te joins un classeur avec différents cas (sur ta demande il n'y a pas besoin de VBA)
https://www.cjoint.com/?cdjVm37zmT

en espèrant que....
Bonjour Michel,
Je pense avoir le même besoin de Kinslown, mais le lien ne fonctionne plus. Est-il possible d'avoir de nouveau le classeur?

Vous remerciant,
Messages postés
16219
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
1 octobre 2020
3 038
Merci Michel.
Dans mon cas, je ne pense pas que cette méthode soit utilisable, ou alors il faudrait pouvoir nommer automatiquement les zones?!
Je vais créer une nouvelle question.
Merci encore pour ta réponse,
Cordialement,
Messages postés
25
Date d'inscription
lundi 14 décembre 2009
Statut
Membre
Dernière intervention
12 juillet 2010
2
Merci beaucoup vos deux conseils m'ont bien aider!
Messages postés
6284
Date d'inscription
lundi 28 janvier 2008
Statut
Membre
Dernière intervention
29 avril 2020
1 217
De rien

bonne journée à toi