Excel liste déroul afficher céllules associés

Résolu/Fermé
Signaler
Messages postés
3
Date d'inscription
dimanche 22 novembre 2009
Statut
Membre
Dernière intervention
23 novembre 2009
-
Messages postés
55035
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 novembre 2021
-
Bonjour,
J'essai de mettre en place fichier de facturation sur excel pour mon frère.
Dans une première feuille j'ai la liste des articles à la vente ex:

1 (A)Désignation (B)Prix unitaires HT (C)Taux de T.V.A.
2 article 1 10,00 € 5,50%
3 article 2 20,00 € 19,60%
4 article 3 30,00 € 5,50%

Dans une autre feuille "facturation" je souhaite créer dans la colonne A sur une dizaine de ligne une liste déroulante ou il pourra choisir les articles. Comment puisje faire pour que suivant le choix de l'article, j'ai le bon prix la TVA correspondant qui s'affiche à côté dans les cellules B et C par exemple.

Je vois bien que des pb bien plus complexe sont traités, j'imagine donc que celui ci l'est déjà mais je ne sais pas le trouver.

Merci par avance.

4 réponses

Messages postés
3
Date d'inscription
dimanche 22 novembre 2009
Statut
Membre
Dernière intervention
23 novembre 2009
4
Bonjour,
Merci Ricky pour ton aide.
J'ai essayé la formule que tu m'as proposée. J'ai l'impression que c'est bien ce que je cherche mais pour le moment dans la case B2 par exemple apparait #REF.

Si je reprend la formule
=recherchev , d'après moi pas de pb
A1; ok je veux qu'il regarde la cellule à côté
Articles!A2:C10; ok il va la rechercher dans cette plage de données
2; là par contre je vois pas, à quoi corresponde ce 2 ?? (no_index_col)
FAUX récupère la valeur proche à priori


Merci par avance.

Alexandre
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 420
Salut,

exemple si ta liste d'articles et sur la feuille Articles et ton tableau s'étend de A2 à C10
et que ta liste déroulante est sur la feuille facturation en cellule A1

donc dans la cellule B2 de la feuille facturation tu vas inscrire:
=RECHERCHEV(A1;Articles!A2:C10;2;FAUX)

et dans la cellule C2 : =RECHERCHEV(A1;Articles!A2:C10;3;FAUX)

si je comprends bien ce que tu veux
Messages postés
55035
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 novembre 2021
16 975
Remplacer Articles!A2:C10 par Articles!$A$2:$C$10
En effet quand tu recopies
=RECHERCHEV(A2;Articles!A2:C10;2;FAUX) en B3 elle devient
=RECHERCHEV(A1;Articles!A3:C11;2;FAUX) ; il faut "bloquer" la plage de données.
Mais la manière la plus élégante consiste à donner le nom "Plage" à la plage de cellules A2:C10 de la feuille "Articles" et à écrire les formules
=RECHERCHEV(A1;Plage;2;FAUX) en B2
=RECHERCHEV(A1;Plage;3;FAUX) en C2

Le 2 et le 3 indiquent qu'il faut lire la réponse dans la deuxième ou la troisième colonne de la plage.
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 420
Remplacer Articles!A2:C10 par Articles!$A$2:$C$10 


Mais oui je suis bête je n'ai pas pensé à ça du tout, merci Raymond.

Et effectivement le meilleur moyen de ne pas faire de telles erreur est de nommer la plage de référence.

Bonne journée
Messages postés
3
Date d'inscription
dimanche 22 novembre 2009
Statut
Membre
Dernière intervention
23 novembre 2009
4
Merci beaucoup a tou les deux pour votre aide!!!

Le fichier fonctionne parfaitement.

Merci encore

Bonne soirée

alexandre
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 420
Salut,

fait plaisirs

Tu pourras mettre ton post en "résolu"

Merci
Messages postés
55035
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 novembre 2021
16 975 >
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013

Rassure-toi : On ne peut pas toujours penser à tout ...
... et nous sommes bien là pour nous entr'aider, n'est-ce pas ?
Donc à charge de revanche !
Cordialement.