Excel somme si avec 3 critères [Résolu/Fermé]

Signaler
Messages postés
108
Date d'inscription
mardi 16 septembre 2008
Statut
Membre
Dernière intervention
20 novembre 2009
-
Messages postés
108
Date d'inscription
mardi 16 septembre 2008
Statut
Membre
Dernière intervention
20 novembre 2009
-
Bonjour,

Bon voila ca fait plus de 10 jours que je cherche une solution, jai essayé somme si, somme prod et autres et ca ne fonct ionne pas

Voila ce que je veux
De A1 a A2000 jai des années, de B1 a B2000 des mois, de C1 a C2000 des vendeur et de D1 a D2000 qte des ventes

donc ca se lis comme ceci 2009, septembre, michel, 1

sur une 2ieme feuille jai des indicateur qui font des cumul par années et par mois qui alimente des graphique.


Donc exemple sur indicateur A6 cest michel donc je veux en A7 la somme des ventes de michel si A1:A2000="indicateur! A3" et si B1:B2000= indicateur!B3 et si C1:C2000= indicateur!D3

Merci de bien vouloir maider je cherche et continue de chercher mais bon je retombe toujours sur les meme sujets qui jusqua maintenant ne mont pas aisé.

Merci

Graphick

9 réponses

Messages postés
25634
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
5 631
Bonsoir
essayez=SOMMEPROD((Champ1=donnée1)*(champ2= donnée2)*(Champ3=Donnée3);Champ4)
Champ étant les limites de champ dans cahque recherche(les mêmes lignes pour tous les items) et doinnée les valeurs à trouver (ces info pouvant etre les adresse de cellule où elles sont placées.)
Crdlmnt
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
1367
Date d'inscription
dimanche 11 mai 2008
Statut
Membre
Dernière intervention
10 décembre 2016
117
Bonsoir,

Toujours sur la brèche?

Merci de déposer un exemple de fichier ICI et au travail.

@ +
Messages postés
108
Date d'inscription
mardi 16 septembre 2008
Statut
Membre
Dernière intervention
20 novembre 2009
8
Tiens voici un exemple Sloubi76, mais ca reste ce que je voulais faire avec le fichier que je tai déposé lautre jour, regarde dans indicateur a côté de michel c ce que je veux faire mai je ny arrive pas.

Merci de m'aider



http://www.cijoint.fr/cjlink.php?file=cj200910/cij9TxdMu3.xls
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 370
Salut,

la solution t'a été donné par Vaucluse, il suffit d'adapter sa formule feuille 2 en C, en E la même formule avec les plages de la feuille1 nommées ce qui réduit considérablement la formule

https://www.cjoint.com/?kwvapFLzY2

A+
Mike-31

Un problème sans solution est un problème mal posé  (Einstein)
Messages postés
108
Date d'inscription
mardi 16 septembre 2008
Statut
Membre
Dernière intervention
20 novembre 2009
8
=SOMMEPROD((B4:B7=C18)*(C4:C7=C15)*(E4:E6=C16);M4:M7)

Donc voici ma formule si j'ai bien compris la solution mais voila j'ai toujurs le même problème

erreur N/A valeur n'est pas disponible.............


??????

Je comprends pas
Messages postés
1367
Date d'inscription
dimanche 11 mai 2008
Statut
Membre
Dernière intervention
10 décembre 2016
117
Bonsoir,

Une adaptation avec ta précédente feuille
http://www.cijoint.fr/cjlink.php?file=cj200910/cijBVX0OaU.xls
Les adaptations sont à ta guise

@ +
Messages postés
108
Date d'inscription
mardi 16 septembre 2008
Statut
Membre
Dernière intervention
20 novembre 2009
8
ok merci beaucoup

=SOMMEPROD((année=$S$1)*(mois=$N$1)*(noms=C7);Quantité)

mais reste que je ne comprend pas une chose cest sur 2 feuilles tu dit année mais tu ne spécifie pas la feuille saisie ???? et pourtant ca marche

désolé mais sommeprod cest la première fois que j'utilise
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 370
Re,

la formule que tu as mis sur ton post 5 est faite pour fonctionner sur la feuille 1

et lorsque tu défini une plage, il faut quelle soit identique sur tous les critères, la plage E s'arrête en E6 alors qu'elle devrait être E7

=SOMMEPROD((B4:B7=C18)*(C4:C7=C15)*(E4:E6=C16);M4:M7)
ci-dessous ta formule rectifiée
=SOMMEPROD((B4:B7=C18)*(C4:C7=C15)*(E4:E7=C16);M4:M7)

pour la mettre sur la feuille Indicateur il faut ajouter le nom de la feuille devant chaque plage

=SOMMEPROD((Feuil1!B4:B7=C18)*(Feuil1!C4:C7=C15)*(Feuil1!E4:E7=C16);Feuil1!M4:M7)

ensuite si tu dois incrémenter cette formule il faut rajouter des $ pour que tes références cellules soit absolue (sinon elles vont se décalerà chaque ligne 1 exemple ci-dessous
=SOMMEPROD((Feuil1!B5:B8=C19)*(Feuil1!C5:C8=C16)*(Feuil1!E5:E8=C17);Feuil1!M5:M8)

formule correcte
=SOMMEPROD((Feuil1!$B$4:$B$7=C18)*(Feuil1!$C$4:$C$7=C15)*(Feuil1!$E$4:$E$7=C16);Feuil1!$M$4:$M$7)

Avec les plage nommées la formule est plus simple, on n'a plus à identifier ni la feuille ni la plage

=SOMMEPROD((année=C18)*(mois=C15)*(noms=C16);ventes)

A+
Mike-31

Un problème sans solution est un problème mal posé  (Einstein)
Messages postés
108
Date d'inscription
mardi 16 septembre 2008
Statut
Membre
Dernière intervention
20 novembre 2009
8
Merci Mike très apprécié tes explications

et merci a tout ceux qui ont répond.

Graphick