[DEBIAN] Installer carte ATI - BUG

Résolu/Fermé
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014 - 20 sept. 2009 à 13:43
 Utilisateur anonyme - 26 oct. 2009 à 20:51
Bonjour, je désire installer ma carte graphique sous debian lenny, le soucis c'est que sous lenny le programme envy ne fonctionne pas, j'ai recherché sur internet pour l'installer autrement et j'ai suivi ce tuto :
http://ubunteros.tuxfamily.org/spip.php?article142

Le problème c'est que quand je tape la commande : module-assistant a-i fglrx j'ai une erreur :
"Les en-têtes du noyau pour la version cible n'ont pas pu être trouvés et vous
n'avez pas indiqué d'autre en-têtes valables à utiliser."
Ensuite il me met :
"Si le noyau actuellement utilisé a été fourni avec votre distribution Debian, veuillez installer le paquet linux-headers-2.6.27-14-generic. Si votre répertoire source (ou les en-têtes) de votre noyau est situé dans un endroit inhabituel, veuillez indiquer à la variable d'environnement KERNELDIRS le chemin de ce répertoire, ou (solution alternative) veuillez indiquer le répertoire source à utiliser pour la construction avec l'option --kernel-dir de module-assistant."
Et enfin :
Le paquet fglrx-source n'a pas pu être construit, voir /var/cache/modass/fglrx-source*buildlog* pour plus de détails."

Voila je précise que j'ai déjà touché au noyau vu que pour installer ma carte wifi j'ai du installer linux-headers-2.6.27-14-generic

Je ne connais pas bien Linux je m'en sort comme je peux donc si quelqu'un peut m'aiguiller, je lui en serais reconnaissant, si vous avez besoin d'info demandez moi.
Voila merci.
A voir également:

43 réponses

Utilisateur anonyme
20 sept. 2009 à 13:55
Salut ;)

Pour avoir les headers de ton noyaux automatiquement :
aptitude install linux-headers-`uname -r`


Attention le paquet remplaçant désormais fglrx-kernel-src est fglrx-source

Sinon il y a la solution sgfxi qui est un script installant automatiquement les pilotes graphiques sur Debian tout comme le fait Envy sur Ubuntu, mais il faut lancer le script en console ;)

https://techpatterns.com/forums/about933.html

peux tu coller ici ce que répondent ces commandes?

uname -r
aptitude search fglrx
lspci | grep VGA
cat /etc/X11/xorg.conf | egrep -v '^(#|;|$)'


@+
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
20 sept. 2009 à 14:49
fglrx est bien installé et avec apt-get il ne trouve pas les headers dans les dépots et sinon j'ai pas bien compris comment fonctionnesgfxi, enfin bref je te donne le résultat des commandes :
uname -r
2.6.27-14-generic

aptitude search fglrx
p fglrx-amdcccle - control panel for the non-free AMD/ATI r5x
i A fglrx-atieventsd - external events daemon for the non-free AM
p fglrx-control - control panel for the non-free AMD/ATI r5x
v fglrx-control-qt3 -
i fglrx-driver - non-free AMD/ATI r5xx, r6xx, r7xx display
i A fglrx-glx - proprietary libGL for the non-free AMD/ATI
i A fglrx-glx-ia32 - proprietary libGL for the non-free AMD/ATI
i fglrx-kernel-src - kernel module source for the non-free AMD/
i fglrx-source - kernel module source for the non-free AMD/

lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series

cat /etc/X11/xorg.conf | egrep -v '^(#|;|$)'
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection
Section "Files"
EndSection
Section "Module"
EndSection
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
Option "XkbOptions" "lv3:ralt_switch"
EndSection
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection
Section "Monitor"
Identifier "Configured Monitor"
EndSection
Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection
Section "Device"
Identifier "Configured Video Device"
EndSection
Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection
Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
EndSection
Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
Utilisateur anonyme
20 sept. 2009 à 21:15
Re ;)

Étrange, ton xorg.conf semble déjà configuré par aticonfig.
'Identifier "aticonfig Layout" '

Maintenant tu as des sections en double, comme "monitor" et "screen" et aussi "device"
Tu peux d'abord faire une copie de xorg.conf (en root)

cp -v /etc/X11/xorg.conf /etc/X11/xorg.conf.bak


Et ensuite supprimer ou commenter # les sections en double, de préférence garder celle générées par aticonfig.
Ensuite redémarres X, au cas ou ça plante, tu restaures comme ceci:

cp -v /etc/X11/xorg.conf.bak /etc/X11/xorg.conf


Pour savoir si tu as le DRI activé tapes:

glxinfo | grep rendering

Qui doit te répondre "yes"

Sinon, la solution sgfxi, tu télécharges le script sur ton bureau ou dans ton /home, et tu le rends exécutable avec la commande
chmod +x /home/chemin/vers/script


Ensuite entre en root dans une console virtuelle (ctrl+alt+F1)

Et pour le lancer, tu te place dans le bon répertoire (celui contenant le script) avec cd
cd /home/chemin/vers/script

et tu le lances en root:
sh sgfxi


Ensuite tu te laisses guidé ;))
Et tu redémarres

le script est ici

Bonne chance.



Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
20 sept. 2009 à 23:15
Peut-être que malgré mes bugs ça a tout de même installé en partie le pilote, d'ailleurs le glxinfo | grep rendering me donne :
"No protocol specified
Error: unable to open display :0.0

Une idée ?
Si j'y arrive pas j'essaierai sgfxi

Voila merci

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
21 sept. 2009 à 18:20
Bon j'ai essayé avec sgfxi mais bon apparemment j'ai un problème d'headers du kernel enfin je sais pas trop et j'ai regardé je trouve pas les headers pour le noyeau 2.6.27 donc j'y arrive pas. Je vois aucune solution, si vous pouvez m'aider, avec la première ou deuxième "solution" ça m'est égal, mais j'aimerais que ça marche ^^.

Voila merci de votre attention.
Utilisateur anonyme
21 sept. 2009 à 19:48
Salut ;)
Avais tu essayer:

aptitude install linux-headers-`uname -r`


As tu compilé ton noyau toi même, ou provient-il d'une mise à jour de Lenny ? (Je suis en Squeeze)
Si je ne me trompe pas le noyau Lenny étais le 2.6.26 avant que je ne migre.

Si tu as compilé ton noyau toi même il faudra recompiler en choisissant les sources complètes.

Peux tu coller le résultat de :

ls -l /usr/src/
0
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
21 sept. 2009 à 21:41
total 1394
drwxr-sr-x 2 root src 88 sep 20 12:39 ati
-rw-r--r-- 1 root root 1424854 jan 11 2009 fglrx.tar.bz2
lrwxrwxrwx 1 root src 31 sep 20 10:54 linux -> linux-headers-2.6.27-14-generic
drwxr-xr-x 4 root root 624 sep 21 13:08 linux-headers-2.6.26-2-amd64
drwxr-xr-x 18 root root 456 sep 21 13:08 linux-headers-2.6.26-2-common
drwxr-xr-x 3 root root 72 sep 21 13:08 linux-kbuild-2.6.26

J'ai rien compiler je viens d'installer Debian et j'ai du mettre à jour le noyau en installant le .deb :
linux-image-2.6.27-14-generic_2.6.27-14.39_amd64.deb
je donne le nom du fichier comme ça je me plante pas, donc j'ai installé ça pour installer intrepid pour avoir internet avec ma carte atheros.
Enfin voila donc si faut compiler le noyau je veux bien mais par contre je sais pas du tout comment faire. enfin dites moi ce que vous en pensez merci.
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
22 sept. 2009 à 18:28
Aucune idée ?
Utilisateur anonyme
22 sept. 2009 à 22:20
lrwxrwxrwx 1 root src 31 sep 20 10:54 linux -> linux-headers-2.6.27-14-generic 


Tes headers sont là.

Par contre je ne vois pas fglrx-source.

colle le résultat de:

su-
(mot de passe root)
aptitude install fglrx-driver fglrx-source module-assistant
module-assistant prepare
module-assistant update
module-assistant auto-install fglrx-source
aticonfig --initial -f
0
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
23 sept. 2009 à 13:01
Merci de ta réponse comme tu l'as demandé voici le résultat des commandes :
sryder:/home/twanou# aptitude install fglrx-driver fglrx-source module-assistant
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 0o seront utilisés.
Écriture de l'information d'état étendu... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait

sryder:/home/twanou# module-assistant prepare
Récupération des sources du noyau de la version : 2.6.27-14-generic
apt-get install linux-headers-2.6.27-14-generic
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet linux-headers-2.6.27-14-generic
apt-get install build-essential
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
build-essential est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Fait.
sryder:/home/twanou# module-assistant update

Données de 86 paquets mises à jour
sryder:/home/twanou# module-assistant auto-install fglrx-source

Données de 1 paquets mises à jour
Récupération des sources du noyau de la version : 2.6.27-14-generic
apt-get install linux-headers-2.6.27-14-generic
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet linux-headers-2.6.27-14-generic
apt-get install build-essential
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
build-essential est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Fait.
sryder:/home/twanou#


Et à cette dernière commande j'ai une fenêtre qui s'ouvre :
https://imageshack.com/
https://imageshack.com/
https://imageshack.com/

Donc tout était bien installés mais il trouve un problème avec les headers apparemment.
Voila merci
Utilisateur anonyme
23 sept. 2009 à 19:05
Re,

essaye avec:

module-assistant a-i fglrx-source --kernel-dir /usr/src/linux-headers-2.6.27-14-generic

ou
module-assistant a-i fglrx-source --kernel-dir /usr/src/linux


En spécifiant le répertoire ou trouver les sources.
0
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
23 sept. 2009 à 20:12
twanou@sryder:~$ sudo module-assistant a-i fglrx-source --kernel-dir /usr/src/linux-headers-2.6.27-14-generic

Données de 1 paquets mises à jour
Bad kernel version specification at /usr/bin/module-assistant line 566, <$apt> line


Voila rien de mieux, je comprend rien...
enfin merci pour l'essai
une autre idée ?
Utilisateur anonyme
23 sept. 2009 à 22:19
Re,

étrange que ton système ne trouve pas les headers dans les dépôts.

Peux tu montrer ton sources.list: (Sources de logiciels pour Debian)

cat /etc/apt/sources.list


Merci ;)
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
24 sept. 2009 à 18:15
sources.list :
# deb cdrom:[Debian GNU/Linux 5.0.3 _Lenny_ - Official amd64 DVD Binary-1 20090905-11:36]/ lenny contrib main
# deb cdrom:[Debian GNU/Linux 5.0.3 _Lenny_ - Official amd64 DVD Binary-1 20090905-11:36]/ lenny contrib main
# Line commented out by installer because it failed to verify:
#deb https://www.debian.org/security/ lenny/updates main contrib
# Line commented out by installer because it failed to verify:
#deb-src https://www.debian.org/security/ lenny/updates main contrib
# Line commented out by installer because it failed to verify:
#deb https://www.debian.org/volatile/ lenny/volatile main contrib
# Line commented out by installer because it failed to verify:
#deb-src https://www.debian.org/volatile/ lenny/volatile main contrib

deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free

deb https://www.debian.org/security/ lenny/updates main contrib non-free
deb-src https://www.debian.org/security/ lenny/updates main contrib non-free

deb http://www.backports.org/debian lenny-backports main contrib non-free

#deb http://wine.budgetdedicated.com/apt lenny main
#deb-src http://wine.budgetdedicated.com/apt lenny main
Utilisateur anonyme
24 sept. 2009 à 22:41
Re ;))


Édites le en root avec cette commande:

gedit /etc/apt/sources.list


Et efface tout et remplace par celui-ci: (attention tel quel, copies colle)

# deb cdrom:[Debian GNU/Linux 5.0.0 _Lenny_ - Official i386 CD Binary-1 20090214-16:29]/ lenny main 

# deb cdrom:[Debian GNU/Linux 5.0.0 _Lenny_ - Official i386 CD Binary-1 20090214-16:29]/ lenny main 

deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free 
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free 

## lenny multimedia
deb http://mirror.home-dn.net/debian-multimedia/ lenny main 
deb-src http://mirror.home-dn.net/debian-multimedia/ lenny main 

# lenny security
deb https://www.debian.org/security/ lenny/updates main contrib non-free 
deb-src https://www.debian.org/security/ lenny/updates main contrib non-free 

# volatile
deb https://www.debian.org/volatile/ lenny/volatile main contrib non-free 
deb-src https://www.debian.org/volatile/ lenny/volatile main contrib non-free 

deb http://ftp.fr.debian.org/debian/ lenny-proposed-updates contrib non-free main 
deb-src http://ftp.fr.debian.org/debian/ lenny-proposed-updates contrib non-free main 
deb http://www.backports.org/debian/ lenny-backports main contrib 


Ensuite tu enregistre et tu fermes.

Et tu lance:

aptitude update
aptitude dist-upgrade


Si tu as un problème de clé c'est ici

Et enfin retente l'installation de Fglrx ;))

Bonne chance.
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
26 sept. 2009 à 10:46
Toujours pareil, je met que la ligne importante :

E: Impossible de trouver le paquet linux-headers-2.6.27-14-generic

je sais plus quoi faire, faut peut-être que je compile moi même le noyau au moins ça marcherait non ?
Utilisateur anonyme
26 sept. 2009 à 13:34
Re,

l'idéal serait de pouvoir booter sur le noyau précédent (si il existe)
Que répond:

ls -l /boot
0
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
27 sept. 2009 à 11:03
Oui il existe pas de soucis, voila :
total 38207
-rw-r--r-- 1 root root 504266 aoû 18 20:41 abi-2.6.27-14-generic
-rw-r--r-- 1 root root 85638 aoû 20 02:42 config-2.6.26-2-amd64
-rw-r--r-- 1 root root 90563 aoû 18 20:41 config-2.6.27-14-generic
drwxr-xr-x 2 root root 408 sep 16 13:39 grub
-rw-r--r-- 1 root root 7765048 sep 15 20:02 initrd.img-2.6.26-2-amd64
-rw-r--r-- 1 root root 6653974 sep 15 19:48 initrd.img-2.6.26-2-amd64.bak
-rw-r--r-- 1 root root 8640459 sep 16 13:42 initrd.img-2.6.27-14-generic
-rw-r--r-- 1 root root 8635276 sep 16 13:38 initrd.img-2.6.27-14-generic.bak
-rw-r--r-- 1 root root 1225392 aoû 20 02:42 System.map-2.6.26-2-amd64
-rw-r--r-- 1 root root 1356053 aoû 18 20:41 System.map-2.6.27-14-generic
-rw-r--r-- 1 root root 1131 aoû 18 20:45 vmcoreinfo-2.6.27-14-generic
-rw-r--r-- 1 root root 1755664 aoû 20 02:41 vmlinuz-2.6.26-2-amd64
-rw-r--r-- 1 root root 2345312 aoû 18 20:41 vmlinuz-2.6.27-14-generic
Utilisateur anonyme
27 sept. 2009 à 11:58
Re,

en attendant, si j'étais toi je booterais sur 2.6.26 en attendant la prochaine mise à jour
proposée au niveau du noyau 2.6.27 qui résoudra plus que probablement le problème des
headers ;)

Maintenant tu peux compiler le noyau que tu préfère en suivant cet exemple:

https://forums.commentcamarche.net/forum/affich-13756337-compilation-nouvau-kernel-et-patch-temp-reel?page=5#102

@+ bonne lecture ;)
laprune04 Messages postés 509 Date d'inscription jeudi 18 septembre 2008 Statut Membre Dernière intervention 15 mai 2010 46
27 sept. 2009 à 13:23
bonjour,
Essaie ce lien:
http://www.nuxo.net/tutorial-37.html
Utilisateur anonyme
27 sept. 2009 à 21:21
Salut Laprune ;)

C'est déjà ce qu'il essaie depuis le début, mais il a un problème de headers au moment d'utiliser
module-assistant.
0
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
28 sept. 2009 à 19:32
Mais justement en 2.6.26 je peux pas avoir internet, ma carte wifi ne fonctionne que avec la 2.6.27, c'est ça mon soucis, c'est une atheros et j'ai réussi à l'installer avec madwifi, mais d'après ce que j'ai compris je peux pas l'installer avec la 2.6.26, enfin j'aimerais pouvoir faire fonctionner ma carte graphique et ma carte wifi.

Après je voudrais savoir, si je compile moi même le noyau, est-ce que je pourrais arriver à mes fins ?
Et si non, eh bien d'après toi dans combien de temps arrivera la mise à jour ? et est-ce sur que cette mise à jour règlera mon problème ?

Quoi qu'il en soit merci beaucoup pour tes réponses (même si le problème est en suspend).
Utilisateur anonyme
29 sept. 2009 à 19:56
Re,

j'ai utilisé madwifi avec le 2.6.26 sans problèmes je ne comprend pas... :( ?

Pour les atheros le module c'est ath9k ou ath5k.

;)
0
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
3 oct. 2009 à 11:20
Désolé pour le retard

Je sais pas mais en fait je crois que je me suis planté, j'ai suivi un tuto d'ubuntu pour installer ma carte wifi, et sur ce tuto il faut installer intrepid (qui je crois remplace madwifi) enfin bref pour ça fallait changer de noyau je crois.

Si on repartais de l'ancien noyau, j'essai d'installer madwifi et après si ça marche on verra, pour le module je sais pas je te donne la ligne correspondant au lspci :
09:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Ca change quelque chose le module ?
Voila en tout cas merci ^^
Utilisateur anonyme
3 oct. 2009 à 17:00
Re,

si pour ta carte graphique c'est résolu en bootant sur 2.6.26, je te conseille d'ouvrir un nouveau topic pour ta carte wifi.

Tu y colles ces commandes:
lspci
lsmod
ifconfig


@+ ;))
0
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
3 oct. 2009 à 20:25
Lol non en fait c'est l'inverse c'est résolu pour ma carte wifi (j'ai internet sur la 2.6.26) mais j'arrive pas à installer ma carte graphique ^^ (je sens qu'on y est presque).

En fait j'ai tout désinstallé (enfin je crois) parce que ça marchait pas, et j'ai voulu réinstaller mais le soucis c'est que quand je veux installer fglrx-driver avec apt-get il me dit qu'il existe pas, et qu'il est remplacé par fglrx-atievent et quand je veux installer ce dernier il existe pas, il me trouve une erreur, et j'ai fais des tests avec le sources.list ça vient de ces liens là :
deb http://ftp.fr.debian.org/debian/ lenny main contrib non free
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non free

si je les enlève plus d'erreur, l'erreur c'est à la fin de apt-get update :
W: Impossible de récupérer http://ftp.fr.debian.org/debian/dists/lenny/Release Unable to find expected entry non/binary-amd64/Packages in Meta-index file (malformed Release file?)

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Enfin je sais pas si c'est grave, mais bon impossible d'installer fglrx
Twanou Messages postés 46 Date d'inscription mercredi 2 septembre 2009 Statut Membre Dernière intervention 29 avril 2014
3 oct. 2009 à 21:19
Désolé pour le double mais en fait ça changeait bien quelque chose apparemment j'avais pas du tout accès à ces dépots (en même temps j'y aurais un peu réfléchi... mais faut pas m'en demander trop ^^), bref j'ai réussi à régler ce problème.

Donc j'ai trouver (et installer) fglrx-driver et fglrx-kernel-src, tout ça sans problème, j'ai même pu lancer :
module-assistant prepare
module-assistant update
module-assistant a-i fglrx
là aussi sans soucis (j'ai été étonné d'ailleurs), mais alors c'est fou ça, tout fonctionne, ah non il reste une commande :
aticonfig --initial
Eh ben ça a marché aussi XD

Bref je lance glxinfo | grep "direct rendering" pour tester et là j'ai ceci :
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 143 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 14
Current serial number in output stream: 14

Donc ça veut dire quoi ? j'ai l'impression que mon bureau s'est chargé beaucoup plus vite, enfin je comprend rien à ça donc si tu pouvais me dire si il y a encore des choses à faire ou si tout marche ce serait cool, voila merci.

EDIT : ah oui en fait je donne le résultat de aticonfig --initial je suis pas sur mais y a peut-être en problème enfin je perd rien à le mettre :

$ aticonfig --initial
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.original-2
aticonfig: Writing to '/etc/X11/xorg.conf' failed. Bad file descriptor.
twanou@sryder:~$