NET Framework 3.5 Service Pack 1

Fermé
Signaler
-
Messages postés
61
Date d'inscription
dimanche 3 octobre 2010
Statut
Membre
Dernière intervention
24 juillet 2012
-
Bonjour Messieurs-Dames,

je n'arrive pas à installer la mise à jour "Microsoft .NET Framework 3.5 Service Pack 1 et mise à jour pour la gamme. NET Framework 3.5 pour les versions de .NET 2.0 à 3.5 x86 (KB951847)" que me propose Microsoft.
Ni automatiquement (mise à jour automatique, mon ordinateur est réglé pour), ni manuellement (màj téléchargée sur Clubic).
J'ai déjà écrit deux fois à CCM.
La première fois on m'a demandé de supprimer des fichiers : C:\WINDOWS\system32\CatRoot2\edb.log et tmp.edb. Bonne idée : au départ je n'arrivais pas à installer 4 màj. Après suppression j'ai pu en installer trois. Mais "Microsoft .NET Framework 3.5 Service Pack 1 et mise à jour pour la gamme. NET Framework 3.5 pour les versions de .NET 2.0 à 3.5 x86 (KB951847)" ne s'installe toujours pas.
La deuxième fois, on m'a suggéré d'installer Unlocker pour fermer les processus en cours qui pouvaient empêcher l'installation. Là, j'ai fait comme convenu. Pas de résultat.
Auriez-vous une idée pour la suite des opérations ?

Je sais bien que ce n'est pas forcément facile et que vous n'avez pas forcément le temps.
Mai si quelqu'un a une idée : merci !

Pim

14 réponses

J'ai déja essayé ça.

alors en 1 mon pc n'arrive pas non plus à installer le programme cleanup de microsoft et en 2 je dois réinstaller TOUS les frameworks de la liste même s'ils ne sont pas prévu pour Vista 64 ???

Désolé de t'ennuyer avec tous mes problèmes ...
8
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
61
Date d'inscription
dimanche 3 octobre 2010
Statut
Membre
Dernière intervention
24 juillet 2012
7
Moi j'ai un problème de ce genre mais pas le même:
En fait, j'ai supprimé .NET Framework 3.5 SP1 pensant qu'il ne me servais pas (vu que j'ai sp3) mais quand j'ai voulu installer un progamme, il m'a demandé d'installer .net framework 3.5 sp1 et la, impossible de l'installer. Il y a un message d'erreur " .net 3.5 sp1 ne s'est pas installé correctement et va fermer.
Aidez-moi SVP, je ne sais plus quoi faire
Messages postés
600
Date d'inscription
mardi 8 juillet 2008
Statut
Membre
Dernière intervention
15 décembre 2016
244
le fichier est sans doute dans C:\Documents and Settings\Ton_Compte\Local Settings\Temp\
(local settings est un dossiers caché). Vide le dossier Temp en supprimant tout ce qu'il y a dedans.
Bonjour,

pour info : j"ai aussi Vista sur un autre ordi. Et là, l'install de net-framework-3-5-service-pack-1 s'est faite sans problème. Et l'ordi fonctionne très bien.
J'essaie les solutions proposées pour XP et je vous tiens au courant.
Pim
Messages postés
82614
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
7 décembre 2021
13 739
Bonjour,
Il est probablement dans: C\Windows\Software Distrbution\Download
Slt à tous,

J'ai exactement le même problème sur vista 64.

Impossible d'installer le Framework 3.5 sp1. Ni via windowsupdate ou en direct sur le site de Microsoft.

J'ai essayé de tout supprimer et puis de réinstaller mais ça ne change rien. Le .exe se DL mais bug tjs lors de l'installation.

Je ne sais plus trop quoi faire, je désespère vmt.
Rebonjour,

j'ai vidé les dossiers indiqués par ekim55 et Djunito.
Sans résultats : le bidule ne s'installe toujours pas, même s'il se charge normalement.
Arrivé à ce point, je me pose une question : ce truc-là sert-il vraiment à quelque chose quand on navigue avec Firefox ?
Messages postés
82614
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
7 décembre 2021
13 739
Essaie ceci: désinstalle framework 3.5 , ensuite redémarre, va dans démarrer, exécuter, tape: regedit et OK. En haut, clique sur édition, rechercher (Ctrl+F), tape: framework 3.5 , coche les cases clés, valeurs, données et fais suivant. La recherche commence, quand un fichier apparait, supprime tout ce qui est rapport à framework 3.5 et regarde aussi dans le volet droit, fais attention ne supprime pas n'importe quoi, ensuite fais F3 pour continuer la recherche et fais de même jusqu'à la fin de la recherche. Ferme le régistre, lance CCleaner pour un bon nettoyage et retourne faire les mises à jour.
--> https://filehippo.com/download_ccleaner/
Je viens de suivre tes conseils mais ça ne change tjs rien.

Petite précision, je n'ai pas déinstaller le 3.5 parce que je n'ai jamais su l'installer. Je n'ai donc rien déinstallé mais j'ai supprimé les fichiers 3.5 dans le regedit et j'ai utulisé le ccleaner.

Mais le résultat est tjs le même. Echec à l'installation du 3.5 sp1, que ce soit via windows update ou en direct sur le site de microsoft.

Je désespère la ...
Messages postés
82614
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
7 décembre 2021
13 739
C'est quoi le code d'erreur ?
Code erreur 643 pour windows update.

Quand j'essaye manuellement il ne va jamais au bout de l'installation et me dit juste qu'il ferme le programme.
Messages postés
82614
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
7 décembre 2021
13 739
jai le meme probleme que toi , quelqu'un a une solution svp ?
Messages postés
600
Date d'inscription
mardi 8 juillet 2008
Statut
Membre
Dernière intervention
15 décembre 2016
244
C'est curieux que tu ne puisses pas l'installer. Pourrais-tu préciser à quel niveau ça coince? Obtiens-tu un message d'erreur? Si oui, lequel?

Sinon essaye ces solutions:
Installe d'abord ceci: http://www.microsoft.com/downloads/details.aspx?FamilyID=5a58b56f-60b6-4412-95b9-54d056d6f9f4&DisplayLang=fr

Puis installe le framework téléchargeable sur le site de microsoft: http://www.microsoft.com/downloads/details.aspx?FamilyID=ab99342f-5d1a-413d-8319-81da479ab0d7&DisplayLang=fr

Si l'installation de celui-ci ne fonctionne pas, va dans le menu démarrer, puis dans Exécuter. Là tu tapes regedit et tu fais OK. Dans l'éditeur de registre, va dans:
HKEY_Local_Machine > SOFTWARE > MICROSOFT > .NET FRAMEWORK
Suprrime tout ce qu'il y a dedans.
Ensuite va dans:
C:\WINDOWS\Microsoft.NET\
et si jamais tu trouves un dossier framework dedans, supprime le aussi.

Toujours pas? As-tu les versions précédentes de framework installées? Si non, installe les d'abord (1.0, 1.1, 2.0, 3.0)
Si tu les as déjà, il faudrait peut-être les rénstaller. Voici un outil pour les supprimer: https://docs.microsoft.com/en-us/archive/blogs/
Bonjour,

Merci pour ta réponse.
Je vais essayer tes solutions. Mais avant il faut peut-être dire que quand je vais chez microsoft pour faire ma mise à jour, il m'indique que le pack est déjà téléchargé, et qu'il ne reste plus qu'à l'installer. Quand je lance l'installation, elle commence, mais bloque rapidement.
Je suppose donc que l'exe d'installation de NET Framework 3.5 Service Pack 1 etc... est déjà quelque part sur mon disque. Mais je ne vois pas où. Est-ce que ça change quelque chose ?

Cordialement.
Pim