Calcul d'une durée dans une période définie

[Fermé]
Signaler
-
Messages postés
24198
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
-
Bonjour,
je voudrais calculer le nombre de jours d'hébergement de personnes par trimestre (fin de calcul 31/03;30/06 etc)
j'ai une colonne date d'arrivée et une colonne date de sortie; comment faire pour faire apparaitre de facon automatique le résultat?

merci

4 réponses

Messages postés
54837
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
16 735
Salut, yoyo...

Tes dates en A2 et B2 doivent être saisies au format DATE
La cellule C2 où tu veux la durée doit être au format STANDARD
La formule en C2 est =B2-A2
Nota : il est inutile de mettre des parenthèses.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
21590
Date d'inscription
mercredi 18 avril 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
1 654
de mémoire, Excel comporte des formules de calcul de date
cherche un peu dans le formules, si t'en a une qui s'appelle durée
sinon essaye de faire une simple soustraction, en sélectionnant le format date pour les cellules

Bonjour,
Si c'est avec Excel et si les dates sont en A2 et B2 entrer en C2=(B2-A2)
Nota: les parenthèses sont importantes.
Messages postés
24198
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 926
Bonjour,

Avec en :
A2: date arrivée
B2: date départ
C2: trimestre sous la forme aaaa-t (ex 2009-2 pour le 2nd trimestre 2009)
alors
D2 (début trimestre): =DATE(GAUCHE(C2;4);(DROITE(C2;1)-1)*3+1;1)
E2 (fin trimestre): =DATE(GAUCHE(C2;4);DROITE(C2;1)*3+1;1)-1
F2 (nbre de jour dans trimestre): =SI(ET(A2<=E2;B2>=D2); MIN(E2;B2)-MAX(D2;A2);0)

J'ai utilisé 2 cellules intermédiaires pour la compréhension mais tu peux tout regrouper dans une seule.
(mais fera une formule un peu longue, qu'on pourrait raccourcir en incrivant le trimestre sur 2 cellules...)
yoyo.xls

eric