Un probleme avec mysql sous debian

Résolu
Voila, j'ai installé un serveur php/mysql sur ma bécane debian.

tout va bien jusqu'a ce que j'installe phpmyadmin :

je change les mdp de la table mysql.user
localhost root XXXX sous phpmyadmin.

je relance mysql:
et depuis je ne peux plus me connecter au serveur mysql.

Sous php mydamin malgres toutes les combinaisons de mdp que je tape j'obtiens un "Erreur d'utilisateur/mot de passe. Accès refusé".

Et en ligne de commande shell :

#mysql
ERROR 1045: Acces denied for user: 'root@localhost' (Using password: NO)

#mysql -u root XXXX (ou XXXX represente un nbre incalculable de pass que j'ai essayé)
ERROR 1045: Acces denied for user: 'root@localhost' (Using password: NO)

Voila, je ne sais plus trop quoi faire, et j'ai pas envie de reinstall la debian tout de suite (et je suis sur que ya d'autres solutions moins bourrines...).

#mysql -u root -p
ERROR 1045: Access denied for user: 'root@localhost' (Using password: YES)

Pour toutes ses operation, je suis connecté avec le compte root via SHH sur la debian. Esperant que quelqu'un saura m'aider :) .
Configuration: PII 233 
198 SDRAM
HDD 40G
Debian woody 3.0r4

7 réponses

  1. e crois avoir compris ma connerie...

    le mot de passe dans la table mysql.user est il encrypté en md5 ?
    Si c'est le cas, je crains d'avoir ecri dedans en clair...
    2
    1. quand tu rentres des enregistrements a la mano dans user, utilise la fonction password

      update user set Password=password("patate") where User="marcel";
      0
      1. et flush privileges derrière
        0
        1. Bon, jai relancé mysqld avec --grant-user-diasble j'ai vidé les champs,
          et fait des updates en utilisant la fonction password :).

          Depuis tout va bien !
          Merci , et merci le traducteur de la doc mysql fr !
          0
          1. merci le traducteur de la doc mysql fr

            ouais tu m'étonnes, vu le morceau! 800 pages la doc MySQL :-|
            0
        2. D'ailleur c'est un peu dangereux cette option...
          m'enfin , merci !
          0
          1. Salut,
            C'est quoi une page qui 'ne monte pas' ?
            A+, Crabs
            0
            1. bonjour tout le monde
              je suis debutant avec php mysql sous linux debian
              j'ai installé apache est toute marche bien .
              aprés j'ai installé php4.
              quand je fait un petit test '''''<? phpinfo(); ?>
              la page ne monte pas .
              -1