Excel : extraire une chaîne de caractère

Résolu/Fermé
NeSSuS
Messages postés
8
Date d'inscription
lundi 8 juin 2009
Statut
Membre
Dernière intervention
12 juin 2009
- 8 juin 2009 à 18:18
Krishnak59
Messages postés
119
Date d'inscription
mardi 3 janvier 2012
Statut
Membre
Dernière intervention
14 mai 2014
- 15 avril 2014 à 09:34
Bonjour,

j'ai un petit problème excel,
j'ai des cellules comportant des chaîne de caractères tel que :

02-5
03-5/03-13
02-6
03-7/03-6
09-6
10-6/10-15
14-6
15-6
01-15/01-7
02-7
19-7/19-6
20-6/20-7
11-13
12-5/12-13
02-15

Bref, tous plus ou moins différent.
Ce que j'aimerai :
Dans le cas ou la cellule contient le caractère "/" , extraire dans une autre cellule (à droite de celle-ci) la chaîne de caractère à sa droite sans le "/" et supprimer dans la cellule de départ la chaîne copier ainsi que le "/".
En fait c'est comme si je faisait données/convertir, avec comme séparateur "/", mais je ne veut pas avoir a faire cette opération à chaque fois que je me sert de mon fichier.

petite précision, j'aimerai ne pas avoir a faire du vba, mais rester dans une bonne vieille formule.

Merci d'avance.
A voir également:

6 réponses

michel_m
Messages postés
16569
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 mai 2022
3 280
8 juin 2009 à 18:37
Bonjour

Et voici 2 bonnes vieilles formules bien de chez nous
pour la partie avant le /
=SI(CHERCHE("/";A2)>0;GAUCHE(A2;CHERCHE("/";A2)-1))
et pour après:
=SI(CHERCHE("/";A2)>0;DROITE(A2;NBCAR(A2)-CHERCHE("/";A2)))
12