[SQL] Duplicata du champ '0' pour la clef 1
Résolu
Bonjour, comme mit dans le titre, j'ai ce message ( Duplicata du champ '0' pour la clef 1 )qui intervient après l'insertion de ma requête seulement je ne vois pas d'où vient l'erreur parce que je ne pense pas que ce soit le double et surtout qu'est-ce que la clef 1..
Merci de votre aide
Merci de votre aide
Configuration: Windows XP Firefox 3.0.10
21 réponses
-
WebmasterBonjour,
il ne faut PAS seter le champ auto_increment ...
donc
-> soit tu le passes à NULL
-> soit tu utilises la syntaxe :
INSERT INTO Clients SET nom="$nom", prenom="$prenom", ...
SANS donc seter l'Id ...
PS Egalement attention à bien protéger les quotes et autres, si tu es en php : voir mysql_real_escape_string, mysql_escape_string, addslahes, ...
Bon courage