Problème check_centreon_snmp_traffic Centreon

Résolu/Fermé
gnowar
Messages postés
15
Date d'inscription
vendredi 10 avril 2009
Statut
Membre
Dernière intervention
26 août 2009
- 10 avril 2009 à 09:56
 kriss974 - 19 avril 2010 à 12:54
Bonjour,

J'ai un problème lors de l'exécution de cette commande à travers l'interface de centreon, celui-ci me retourne en effet une erreur.

Le serveur nagios et l'interface de centreon tournent sur une machine sous Centos, l'hôte à superviser est une machine windows sur laquelle est bien sur installé SNMP.

Lors de l'exécution de la commande directement dans le répertroire /usr/local/nagios/libexec/ celle-ci fonctionne bien.

[nagios@localhost libexec]$ ./check_centreon_snmp_traffic -H 172.20.1.125
Traffic In : 518.29 kb/s (0.5 %), Out : 529.74 kb/s (0.5 %) - Total RX Bits In : 75.24 MB, Out : 20.73 Mb|traffic_in=518293,4Bits/s traffic_out=529742,5Bits/s


Lorsque cette commande est lancé via l'interface de centreon, j'ai l'erreur suivante :

Command Line /usr/local/nagios/libexec/check_centreon_snmp_traffic -H 172.20.1.125 -n -i 'eth0' -w '80' -c '90' -C public -v '1'
Output ERROR: Interface Status Request : Received noSuchName(2) error-status at error-index 1
Status UNKNOWN


J'ai essayé de checker en modifiant la commande comme ceci :
Command Line /usr/local/nagios/libexec/check_centreon_snmp_traffic -H 172.20.1.125 -n -i '2' -w '80' -c '90' -C public -v '2'

J'ai toujours le même retour d'erreur.
Si vous avez des idées je suis preneur.

Ps : J'ai la v3 de nagios et la v2 de centreon, il existait auparavant des problèmes concernant ce check sur les machines windows, mais ceci à été résolu (la preuve en est la commande s'execute bien directement en ligne de commande).

!

2 réponses

gnowar
Messages postés
15
Date d'inscription
vendredi 10 avril 2009
Statut
Membre
Dernière intervention
26 août 2009
5
14 avril 2009 à 10:54
Edit : problème résolu !

J'ai en fait testé manuellement plusieurs commandes à travers l'interface de test de centreon mais celle-ci est en fait foireuse.

J'ai du donc tester les commandes une à une en modifiant les fichier de conf et en restartant à chaque fois mon service nagios.

Aujourd'hui j'ai des valeurs, pourtant la commande ne passe toujours pas par l'interface de test centréon :)

Moralité : tester les commandes avec TOUS les arguments en ligne de commande sous l'utilisateur Nagios (Très important !!! surtout pas en root !!!) et ne pas utiliser l'interface de test de commandes centreon.
4
bonjour moi j'ai un autre souci avec check_centreon_snmp_traffic il ne me retourne pas comme il faut les infos sur les traffci car sur les interfaces non j'ai aussi du traffic merci d'avance
-1