Probleme attribution ip wifi wep

Fermé
Signaler
-
 kaman -
Bonjour,
bonjour,
j'ai la version ubuntu 8.04, mon probleme c'est que j'arrive pas à me connecter en wifi avec un routeur internet de type freebox et autre, j'ai essayé avec le network manager, il me redemande toujours la clé wep, et manuellement il fait rien du tout, mais en console j'ai remarqué qu'il accepte le ssid avec iwconfig, mais il n'attribue pas d'ip avec dhclient, ce qui est bizarre c'est que j'arrive à me connecter à internet via les reseaux wifi ouverts et public donc c'est pas un problème de driver, et sous windows la connection internet avec la freebox marche bien. j'ai fait un boot avec l'option pci=noacpi et toujours rien. je voue prie de m'aider. MERCIIIIIII

voila les resultats de qqes commandes:

kamel@kamel-laptop:~$ sudo iwconfig wlan0
wlan0 IEEE 802.11a ESSID:"TELE2BOX_5443" Nickname:""
Mode:Managed Frequency:5.7 GHz Access Point: 00:1D:19:1A:D5:EC
Bit Rate=54 Mb/s Tx-Power=16 dBm
Retry min limit:7 RTS thr:off Fragment thr=2346 B
Encryption key:off
Power Management:off
Link Quality=77/100 Signal level=-57 dBm Noise level=-94 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

kamel@kamel-laptop:~$ sudo ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:19:d2:4b:1f:5e
inet6 addr: fe80::219:d2ff:fe4b:1f5e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:220 errors:0 dropped:0 overruns:0 frame:0
TX packets:162 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:29354 (28.6 KB) TX bytes:35710 (34.8 KB)

kamel@kamel-laptop:~$ sudo dhclient wlan0
There is already a pid file /var/run/dhclient.pid with pid 6639
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:19:d2:4b:1f:5e
Sending on LPF/wlan0/00:19:d2:4b:1f:5e
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
A voir également:

2 réponses

salut

je ne pourrais que trop de recommander wicd petite application genre network-manager beaucoup lus fiable.
installation:

ajouter (deb http://apt.wicd.net hardy extras) à ton /etc/sources.list) c'est bien le depot hardy :)
ajouter la clé : wget -q http://apt.wicd.net/wicd.gpg -O- | sudo apt-key add -

ensuite sudo aptitude update
sudo aptitude install wicd

tu pourras ouvrir wicd depuis le burreau

pense à ne rien laisser dans /etc/network/interfaces juste:
auto lo
iface lo inet loopback

et eth0 si tu gardes une connection filaire

@+
0
pense aussi que le dhcp soit activé sur la box , puis eventuellement passe au wpa ça mange pas de pain :)
0
j'ai aussi pensé que c'etait le network manager qui cause probleme et j'ai voulu passer à wicd ou wifi radar mais j'ai essayé avant en ligne de commande et toujours, rien!
tu crois que le network manager une fois installé influence aussi les commandes tapés en terminal?
0