Calcul Moyenne Excel

Fermé
cdh - 7 janv. 2009 à 12:02
eriiic Messages postés 24494 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 janvier 2023 - 18 janv. 2009 à 15:04
Bonjour,

J'ai une série de nombre dont excel doit calculer la moyenne mais parfois j'ai des nombre qui sont totalement hors moyenne quelle formule dois-je utiliser pour écarter ces nombres "hors catégories" et que Excel calcul la moyenne correcte.

Exemple : série de nombre : 1 0 1 3 2 50 3 0 2 3 3 1
Il faut qu'excel calcul la moyenne en excluant 50 ou en diminuant sont impact sur la moyenne

J'avais déjà posé cette question le 24 août 2008, la réponse donnée à ce moment là me convenait plus ou moins, mais maintenant j'ai une matrice de 36 colonnes sur 12000 lignes, ça devient un peut difficille d'insérer une ligne à chaque fois pour faire le test (vrai ou faux) de la solution de l'époque.

Il faudrait que la formule de moyenne se fasse en une fois sur les 36 colonnes pour chaque article. J'ai essayé la formule moyenne.si avec un ecart type, mais le problème c'est que la condition ne peut pas faire référence à une autre case dans laquelle il y aurait l'ecart type.

Merci de m'aider

6 réponses

eriiic Messages postés 24494 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 janvier 2023 7 156
7 janv. 2009 à 23:43
Bonjour,

L'aide d'excel est très bien faite n'hésite pas à la consulter :
pourcentage : représente le nombre fractionnaire d'observations à exclure du calcul. Par exemple, si l'argument pourcentage est égal à 0,2 et que la série de données contient 20 observations, 4 d'entre elles seront éliminées (20 x 0,2), 2 au début et 2 à la fin de la série.


eric
1
nikomania Messages postés 194 Date d'inscription samedi 4 octobre 2008 Statut Membre Dernière intervention 1 décembre 2009 22
7 janv. 2009 à 13:59
et avec un somme.si divisé par un nb.si ?
0
pilas31 Messages postés 1823 Date d'inscription vendredi 5 septembre 2008 Statut Contributeur Dernière intervention 24 avril 2020 634
7 janv. 2009 à 14:00
Bonjour,

Pourquoi ne pas utiliser moyenne.reduite(matrice,pourcentage) qui élimine un pourcentage de valeurs extrèmes ?

A+
0
J'ai essayé mais je vois pas bien à quoi correspond le pourcentage, ça marche dans certain cas mais pas dans d'autre, quelqu'un peut-il m'expliquer clairement que représente ce pourcentage ?

Merci.
0
triwix Messages postés 296 Date d'inscription mercredi 7 janvier 2009 Statut Membre Dernière intervention 4 février 2011 21
7 janv. 2009 à 23:59
As tu une valeur maxi qui doit être prise en compte? a ce moment la fais entrer la cellule uniquement sielle est < à ton maxi
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
eriiic Messages postés 24494 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 janvier 2023 7 156
8 janv. 2009 à 00:04
re,

Si tu obtiens des résultats plus ou moins probant avec moyenne.reduite() c'est qu'il faut que tu arrives à déterminer le nombre de 'nombres atypiques' (donc le %) pour être sûr de les éliminer.
Une autre façon de faire, j'ai considéré sur ton exemple que les valeurs atypiques étaient toujours dans les valeurs hautes et qu'il ne fallait pas en éliminer dans les valeurs basses :
Classeur2.xls
Fait de façon un peu empirique, dis moi ce que tu en penses et ce que ça donne sur tes séries. Tu peux peut-être affiner encore plus...

eric
0
eriiic Messages postés 24494 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 janvier 2023 7 156
8 janv. 2009 à 07:00
PS :
Si ton écart entre valeurs normales et atypiques est moins important que sur l'exemple et que trop de valeurs normales sont éliminées remplace =MOYENNE(A4:A15)+ECART.MOYEN(A4:A15) par =MOYENNE(A4:A15)+ECART.MOYEN(A4:A15)*coeff
avec coeff=2 ou 3 ou 4 ou...
0
Salut,

Voilà j'ai testé les formules et apparement, c'est la dernière solution, avec les coefficiens et pour coffécient=4 qui me donne le meilleur résultat. J'ai fait un test avec 200 données sur les 12000 que j'ai à faire et c'est assez concluant.

Encore merci !
0
Encore une petite question, à quoi servent les accolades en début de formules, je vois que quand je les mets pas, Excel me donne une erreur #valeurs! ou alors me donne une valeur complètement différente.
0
eriiic Messages postés 24494 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 janvier 2023 7 156 > cdh
18 janv. 2009 à 15:04
Bonjour,

il y a des { } lorsque la formule est matricielle (en gros elle calcule plusieurs données en parallèle).
Il faut la valider par Shift+Ctrl+Entrée.
eric
0