Excel Valeur cellule = nom onglet

Résolu/Fermé
RoxasXIII - 5 janv. 2009 à 12:40
 DiMac - 16 août 2011 à 13:14
Bonjour,

Voici mon cas : mon onglet 1 est un recap de tous les autres onglets

dans la colonne A j'ai le nom des autres onglets (ex: onglet 2, onglet 5, onglet 3. Je précise que les onglets ne sont pas forcément dans le même ordre que la liste dans recap). Autre précision : les onglets portent un nom précis : ils ne s'appelent pas Onglet x ils ont un nom comme toto, titi. Ces noms sont situés dans la colonne A du premier onglet (Recap)

Dans l'onglet 2, par exemple, j'ai une colonne avec plusieurs nombres. Retour à l'onglet Recap : dans la colonne B j'ai la somme de ces nombres en fonction de la valeur de la colonne A(nom onglet).

Je souhaiterais trouver une formule qui permette de faire cette somme (en fonction de la cellule Ax de l'onglet Recap).

Je ne veux du VBA qu'en dernier recours pouvez-vous m'aider svp ? j'ai essayé plusieurs formules (Indirect, adresse) mais rien ne va (ou alors je les utilise mal lol)

Merci de votre aide.

4 réponses

michel_m
Messages postés
16570
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
26 mai 2022
3 280
5 janv. 2009 à 13:30
Bonjour,

regaarde si cette maquette te donne une réponse:
http://www.cijoint.fr/cjlink.php?file=cj200901/cijpgQU2b5.xls
basé sur une démo envoyée à micro-hebdo
1
Ca marche !!!!!!

Merci beaucoup, j'ai plus qu'à recoller les cheveux que je me suis arraché lol

Un modérateur peut-il mettre le Post en Résolu ? Merci
0
Mike-31
Messages postés
17954
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 mai 2022
4 947
5 janv. 2009 à 13:43
Salut Michel_m,

trop rapide, tu m'a grillé sur le fil, tous mes voeux

A+
0
liens mort
0
Mike-31
Messages postés
17954
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 mai 2022
4 947
5 janv. 2009 à 13:42
Salut,

Un genre comme cela

=SI(SOMME(Tito!A1:A29)=Recap!A1;VRAI;faut)

mais pour être plus éfficace, il nous faudrait plus d'explication ou mieux un exemple de fichier sans anotations confidentielles, mais des explication ici j'ai ça et si j'obtiens ça, je veux que là j'obtienne ça

Avec ce lien pour joindre ton fichier

https://www.cjoint.com/

A+
0
VBA Beginner
17 août 2010 à 18:00
Bonjour, merci pour cette super astuce.

Malheureusement les noms de mes onglets contiennent des espaces et le formule renvoie #REF!

Vous sauriez comment faire pour qu'elle fonctionne?


Merci
0
Mike-31
Messages postés
17954
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 mai 2022
4 947
17 août 2010 à 21:59
Salut,

L'intervalle ne doit pas poser problème du moment qu'il se trouve dans le nom de l'onglet et dans la formule
exemple premier onglet nommé Titi 1 et le dernier onglet Toto 2, si l'on souhaite additionner par exemple toutes les cellules le la plage A1 à A30 de toutes les feuilles entre Titi 1 et Toto 2 la formule est

=SOMME('Titi 1:Toto 2'!A1:A30)
0