Probleme sur mon serveur apache

Résolu
Bonjour,
je vient d'installer apahe , php , mysql mais sur localhost je ne peut lire que les fichiers html quand j'essaie d'aller sur un fichier php j'ai cette erreur:
Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

Fatal error: Unknown: Failed opening required '/var/www/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0

Pouvez vous m'aidez?
Merci d'avance
Configuration: Linux
Firefox 3.0.1

7 réponses

  1. Modérateur
    Est ce que l'utilisateur www-data a les droits en lecture écriture sur le fichier /var/www/index.php ? Si tu ne sais pas donne-moi le résultat de :
    ls -l /var/www/index.php
    grep www-data /etc/group

    Tu peux changer les droits du fichier en question avec la commande chmod et/ou chown et/ou chgrp. Pour plus de détails :
    man chmod
    man chown
    man chgrp

    Exemple :
    chown root:www-data /var/www/index.php
    chmod 644 /var/www/index.php

    Bonne chance
    0