La page d'admin ne marche pas

bonjour,
je viens d'installer joomla. j'ai réussi l'installation mais quand j'ai supprimé le dossier <installation> le lien <monsite>/joomla/administrator ne marche pas, le navigateur vas directement sur joomla/installation/index.php

j'ai même essayer le lien <monsite>/joomla et sa marche pas aussi.

---- No configuration file found and no installation code available. Exiting...---

j'ai enendu parler d'un fichier configuraion.asp que j'ai pas trouver dans le dossier que j'ai télécharger mais je sais pas ce que c'est !!!!!!!

aidez moi svp c'est urgent !
Configuration: Windows XP
Internet Explorer 6.0

11 réponses

  1. j'ai pas compris ce que tu veux dire avec serveur local (je suis pas un porofessionel) mais comme je t'es dit, j'ai créer une base de donnée mysql !
    1
    1. Contributeur
      j'ai bien compris sa que tu été pas un pro!! lol

      un conseil va téléchargé easy-php et installe le c'est un serveur local (il regroupe apache, php5, et MySQL)
      puis réinstalle Joomla normalement sa va marché!
      0
  2. Contributeur
    tu as quand méme installé un server local??
    avec apache, php, MySQL???
    -1
    1. je pense pas qu'il faut un logiciel pour faire tourner joomla, je créer simplement ma base de donnée sur plesk et après je l'installe sur le navigateur internet explorer
      0
      1. sa marche pas toujours mais je pense que j'ai trouver l'erreur. a la fin de l'installaion, dans la page felecitation.... il y a la ligne ci dessous !

        C:\Inetpub\vhosts\<MONSITE>\httpdocs\joomla\libraries\joomla\utilities\compat\php50x.php on line 66

        voila le code de la page

        <?php
        /**
        * @version		$Id:php50x.php 6961 2007-03-15 16:06:53Z tcp $
        * @package		Joomla.Framework
        * @subpackage	Compatibility
        * @copyright	Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
        * @license		GNU/GPL, see LICENSE.php
        * Joomla! is free software. This version may have been modified pursuant
        * to the GNU General Public License, and as distributed it includes or
        * is derivative of works licensed under the GNU General Public License or
        * other free or open source software licenses.
        * See COPYRIGHT.php for copyright notices and details.
        */
         
         /**
         * PHP 5.0.x Compatibility functions
         *
         * @since		1.5
         */
        if (!defined('FILE_USE_INCLUDE_PATH')) {
        	define('FILE_USE_INCLUDE_PATH', 1);
        }
         
        if (!defined('FILE_APPEND')) {
        	define('FILE_APPEND', 8);
        }
         
        /**
         * Replace file_put_contents()
         *
         * @link		https://www.php.net/function.file_put_contents
         * @author		Aidan Lister <aidan@php.net>
         * @version	 	$Revision: 47 $
         * @internal	resource_context is not supported
         * @since		PHP 5
         */
        if (!function_exists('file_put_contents')) {
        	function file_put_contents($filename, $content, $flags = null, $resource_context = null)
        	{
        		// If $content is an array, convert it to a string
        		if (is_array($content)) {
        			$content = implode('', $content);
        		}
         
        		// If we don't have a string, throw an error
        		if (!is_scalar($content)) {
        			trigger_error('file_put_contents() The 2nd parameter should be either a string or an array', E_USER_WARNING);
        			return false;
        		}
         
        		// Get the length of date to write
        		$length = strlen($content);
         
        		// Check what mode we are using
        		$mode = ($flags & FILE_APPEND) ?
        					$mode = 'a' :
        					$mode = 'w';
         
        		// Check if we're using the include path
        		$use_inc_path = ($flags & FILE_USE_INCLUDE_PATH) ?
        					true :
        					false;
         
        		// Open the file for writing
        		if (($fh = @fopen($filename, $mode, $use_inc_path)) === false) {
        			trigger_error('file_put_contents() failed to open stream: Permission denied', E_USER_WARNING);
        			return false;
        		}
         
        		// Write to the file
        		$bytes = 0;
        		if (($bytes = @fwrite($fh, $content)) === false) {
        			$errormsg = sprintf('file_put_contents() Failed to write %d bytes to %s',
        							$length,
        							$filename);
        			trigger_error($errormsg, E_USER_WARNING);
        			return false;
        		}
         
        		// Close the handle
        		@fclose($fh);
         
        		// Check all the data was written
        		if ($bytes != $length) {
        			$errormsg = sprintf('file_put_contents() Only %d of %d bytes written, possibly out of free disk space.',
        							$bytes,
        							$length);
        			trigger_error($errormsg, E_USER_WARNING);
        			return false;
        		}
         
        		// Return length
        		return $bytes;
        	}
        }
         
        /**
         * Ported PHP5 function to PHP4 for forward compatibility
         */
        function clone($object) {
        	return unserialize(serialize($object));
        }
         
        if(!function_exists('stripos')) {
         function stripos($haystack, $needle, $offset = 0) {
          return strpos(strtolower($haystack), strtolower($needle), $offset);
         }
        }
         
        
        0
        1. Contributeur
          tu utilise quoi comme programme pour faire tourné joomla ??
          apache?
          easyphp??
          .....????
          0
      2. J’ai pas supprimé install.php je vais réinstaller tout de suite et je te tien au courant.
        0
        1. Contributeur
          j'ai trouvé se fichier :
          configuration.php-dist

          mais tu as supprimé le dossier instal mais as tu aussi supprimé le fichier install.php??

          car si tu la pas fait c'est normal qu'il te revois a chaque fois sur cet page !!
          0
          1. Contributeur
            je regarde et je te répond juste après!
            0
            1. Oki je vais réessayer mais je voudrai juste savoir es ce que tu a trouver le fichier configuraion.asp quand tu a télécharger le fichier zip ????
              -1
              1. oui j'utilise la versio Joomla 1.5.8
                0
                1. Contributeur
                  retente l'installation ! a nouveau!
                  vérifi bien tout se que tu fait!
                  moi je mis suis repris a 4 fois pour installé ma version !
                  et la dernière été la bonne!
                  www.nikos54.fr
                  0
              2. Contributeur
                slt!
                tu utilise quel version de joomla ??
                1.5.8? (c'est la dernière version)

                tu peut recommencé l'installation! car déjà fois c'est juste a une mauvaise manip!

                et si tu as toujour des problème je te conseil d'allé sur le forum dédier a Joomla!
                a l'adresse suivante:
                http://aide.joomla.fr/

                https://www.joomla.org/

                tu peut aussi télécharger le manuel d'installation qui est en PDF gratuitement sur le site!
                0