[php] permission d'upload d image sur serveur

Résolu
Bonjour,
j ai un petit soucis quant à l upload d image en php

en local tout fonctionne bien, mais sur le serveur j ai cette erreur

Warning: move_uploaded_file(uploads/Alex_V_Wallpaper.jpg) [function.move-uploaded-file]: failed to open stream: Permission denied in /home/rischjc/public_html/news_envoyee.php on line 207

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpT3nNnz' to 'uploads/Alex_V_Wallpaper.jpg' in /home/rischjc/public_html/news_envoyee.php on line 207


je dois modifier des permissions ou quelques chose comme ca??

merci d'avance

5 réponses

  1. Pour régler mon problème j'ai changé les permissions de mes dossiers. J'utilise Filezilla pour transférer mes fichiers. Change les permissions de tes dossiers dans Filezilla c'est beaucoup plus simple. Tu clic droit sur ton dossier >> Attributs du fichier >> Change les Attributs Répertoire (Coche Lire - Ecrire - Exécuter).
    1. Bonjour à tout le monde,

      j'ai programme php qui uploide un fichier sur un serveur sous lunix,
      je trouve un problème apparement du droit d'accès sur le dossier du disque receptionnant celui_ci,
      j'en cherche une solution
      1. Bjr. As tu réglé le probleme de permission d'upload de'image sur serveur? j'ai le meme probleme depuis quelques jours et j'arrive pas à trouver la solution
    2. bonjour pourrait tu poster le site car cela me plaira pour mon site internet que j'essaie de develloper en se moment car étant débutant j'avoue avoir un peu de mal.
      1. je viens de trouve ra reponse en fouillant partout sur internet
        j ai changé le chmod à 777 sur la page..
        ca marche niquel, par contre parait il que c est pas sécurisé..
        1. Bonjour, jai le meme soucis que tu as eu avec le Upload fichier using php.
          Warning: move_uploaded_file(Picture/pict0023.jpg) [function.move-uploaded-file]: Faill to open stream: Permission denied in /home/eken/public_html/Membre/index.php on line 342
          Comment as tu fais pour changer le chmod à 777 sur la page.