[Excel07] Utiliser le résultat d'une formule

[Résolu/Fermé]
Signaler
-
Messages postés
24200
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
-
Bonjour,

Alors voilà, j'ai un problème, j'utilise une formule qui affiche 1;0,5 ou 0,25, c'est une formule: (Cellule K19)

=SI(ET(NON(L18="");NON(M18=""));"0,50";SI(ET(NON(L18="");M18="");"0,25";"1"))

Ensuite, j'utilise le résultat dans une formule:

=SI(K19=1;RECHERCHEH(I19;$E$8:$I$12;H19+1);[...])

Le problème, c'est que quand K19=1 (affiché), ba le SI affiche [...] (enfin, ce qu'il y a dedans...), et pas la recherche horizontal...
Si je supprime les "" pour afficher 0,5 etc... ca marche, mais ca me mets une erreur (rouge en haut à gauche)

Si quelqu'un avait une astuce, pour utiliser le résultat de la cellule, sans l'erreur...

Merci beaucoup,

Bonne soirée,

Vincent

2 réponses

Messages postés
24200
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
6 928
Bonsoir,

si tu mets tes nombres entre "" c'est du texte, pas du numérique
1<>"1"

donc: =SI(ET(NON(L18="");NON(M18=""));0,50;SI(ET(NON(L18="");M18="");0,25;1))

eric
Messages postés
27
Date d'inscription
mercredi 3 décembre 2008
Statut
Membre
Dernière intervention
14 juin 2009

Bonjour,

Merci pour ta réponse, mais si je ne met pas les "", ca me met une erreur, avec "formule incohérente"... avec un triangle rouge dans le coin de la cellule, c'est possible que j'ai a présenté ce fichier pendant un oral, alors il me faudrait pas ces erreurs, si vous saviez d'où ca venait...

Bonne après-midi,
Vincent
Messages postés
24200
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
6 928
Je n'ai pas contrôlé ta formule...
Si tu procèdes ainsi tu peux mettre directement toute ta formule entre " ", tu ne seras plus embété par les messages d'erreur...