Excel somme si avec comme critere des dates [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
mardi 25 novembre 2008
Statut
Membre
Dernière intervention
28 novembre 2008
-
 Electropac01 -
Bonjour,

Voila mon problème j'ai un tableau a réaliser avec disont 3 colonnes A B et C

Je veux aditionner les 1 en fonction d'une période donné nottement le mois soit du 01/01/08 au 31/01/08

Es ce possible ?
A B C
101/01/08 1
205/01/08 1
306/01/08 1
4
5

merci d'avance pour votre aide

Cordialement

Electropac01

11 réponses


Alors je suis perdu j'ai essayer toutes les formules proposée et a chaque fois sans résultat

Je ne comprends pas la syntaxe pour date value?

La formule sommeprod comment fonctionne elle?

Il y a un moment ou je dois me planter car cela ne fonctionne jamais j'ai soit value 0 ou NA#

Quelle est le bon format pour mes titres de mois?

Comment faire pour justement calculer la somme de mes valeurs entre deux dates definies ou la sommes des valeurs correspondante au mois concerné?

Merci encore de vos réponse

http://www.cijoint.fr/cjlink.php?file=cj200811/cij6tj34U9.xls
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
233
re:

formule à mettre en bw3 et tirer vers la droite
=SOMMEPROD((MOIS($B$3:$B$1000)=MOIS(DATEVAL("01-" & BW$2 & "-2000")))*$BU$3:$BU1000)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
23809
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
6 582
Bonjour tout le monde,

il manque un $
=SOMMEPROD((MOIS($B$3:$B$1000)=MOIS(DATEVAL("01-" & BZ$2 & "-2000")))*$BU$3:$BU$1000)
Bon ça ne changera rien car elle n'est pas destinée à être recopier verticalement mais...
eric
Messages postés
4
Date d'inscription
mardi 25 novembre 2008
Statut
Membre
Dernière intervention
28 novembre 2008
1
Super probleme résolu !!!

Merci les experts d'excel

Par contre maintenant j'ai le même problème avec les colonnes de rubriques

Ex: total velo ok , etc...

j'ai essayer avec la mm formule en changeant les plages mais sans résultat

Je suis larguer avec les syntaxes

=SOMMEPROD((MOIS($B$3:$B$11027)=MOIS(DATEVAL("01-" & BW$2 & "-2000")))*$K$3:$K11027)

es ce qu'elle pourrais marcher avec une incrémentation verticale?

Ci-joint http://www.cijoint.fr/cjlink.php?file=cj200811/cijGmM2GI3.xls

Merci d'avance pour votre aide
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci


Bonjour a tous,

C'est bon j'ai trouver

Merci encore a tous les experts d'excel car sans eux je serait encore en train de chercher

si certain sont interressé je pourrait dorenavant les aider

cordialement

Electropac01
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
53126
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
15 104
Tu as beaucoup trop simplifié ton problème, au point que nous ne voyons pas où est le vrai problème ! Si on s'en tient à ce que tu écris, la réponse est TROIS et on n'a pas besoin d'un ordinateur pour ça ... Alors explique !

Si tu as commencé ton fichier, mets-le à notre disposition en utilisant www.https://www.cjoint.com/ ou encore www.http://cijoint.fr/
Messages postés
4
Date d'inscription
mardi 25 novembre 2008
Statut
Membre
Dernière intervention
28 novembre 2008
1
Bonjour,

En fait c'est tout bête, une colonne avec des dates, une avec des valeurs ( 1,2etc...) et je voudrais totalisé les valeurs en fonction de la date correspondante.

Soit par exemple faire la somme des valeurs pour le mois de janvier, fevrier etc...

Es ce possible ?

PS:J'ai deja tenté avec la fonction somme si,sommeprod mais sans résultat

L'ideal c'est la formule SOMME.SI.ENS mais elle n'est pas dispo sur cette version d'excel

Merci encore pour votre aide

ci-joint le lien pour le fichier sur lequel je travail

http://www.cijoint.fr/cjlink.php?file=cj200811/cijvHdhj4S.xls
Messages postés
23809
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
6 582
Bonsoir,

en BX3:
=SOMMEPROD((MOIS(B3:B1000)=1)*(BV3:BV1000=1))

au passage en BV3 tu peux mettre
=(A3>0)*1
et supprimer la colonne BU

eric

PS: sur les vélos il ya maintenant des transpondeurs comme sur les avions ? hé bé !!!!
Messages postés
4
Date d'inscription
mardi 25 novembre 2008
Statut
Membre
Dernière intervention
28 novembre 2008
1
Bonjour,

Désolé mais cette formule ne fonctionne pas ca me met 0 au lieu de 28 pour le mois de janvier.

Il me faut une formule qui permette de totalisé les valeurs entre une date de debut et une date de fin

ex : =somme.si(b:b;=>01/01/08;=<31/01/08) ou un truc dans ce genre...

Merci encore pour votre aide

Cordialement

Electropac01

Ci-joint le lien vers le fichier http://www.cijoint.fr/cjlink.php?file=cj200811/cijIX82Hhu.xls
Messages postés
23809
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
6 582
ah bon ?
Ben ré-essaie en faisant un copier-coller de la formule...
et puis c'est 27 pour janvier, pas 28
http://www.cijoint.fr/cjlink.php?file=cj200811/cij2sr9HzA.xls

eric

PS: si tu fait une recopie incrémentée il faut en plus fixer les plages :
=SOMMEPROD((MOIS($B$3:$B$1000)=1)*($BV$3:$BV$1000=1))
Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
233
Bonjour

Somme.si multicriteres ???

Sommeprod((B2:B15>=datedebut) * (B2:B15<=Datefin) * C2:C15)

attention, SommeProd n'aime pas du tout les colonnes completes et ne travaille que sur des plages de meme taille
Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
233
re:

au vu de ton fichier, tu peux encore améliorer en mettant tes titres de mois dans un format correct : minuscule avec les accents (norme iso) cela permettrait de n'avoir qu'une seule formule quelque soit le mois

exemple : >=datevalue("01-janvier-2008") et <=(date(2008;mois(datevalue("01-janvier-2008"))+1;0)
ce qui te donne tout simplement la date de debut et pour la 2eme la date de fin de mois
Messages postés
100
Date d'inscription
mercredi 5 novembre 2008
Statut
Membre
Dernière intervention
18 février 2010
7
Bonjour,
je ve bien t'aider mais j'ai rien compris a ce que tu ve faire.