Supprimer espace !!

[Résolu/Fermé]
Signaler
Messages postés
307
Date d'inscription
mercredi 24 septembre 2008
Statut
Membre
Dernière intervention
21 mai 2015
-
Messages postés
24196
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
10 octobre 2021
-
Bonjour,

Voila j'ai un fichier avec les coordeonnées des mairies d'un departement sur excel 2007.

Seul hic, c qu' il y un espace avant et aprés certains numéros de tél ( 05 05 05 05 05 ) mais pas tous donc il ne sont pas aligner et ca fait moche.

Donc je voudrais supprimer les espaces avant et aprés sans supprimer les espaces entres les nombres (05 05 05 05 05).

Merci par avance.
A voir également:

5 réponses

Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
241
Bonjour à tous

fonction basique d'excel
=SUPPRESPACE(A1)

supprime tous les espaces non significatifs :
ceux du début
ceux de la fin
et ceux qui sont au milieu quand ils sont doublés ou plus
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
202
Date d'inscription
dimanche 26 octobre 2008
Statut
Membre
Dernière intervention
9 juin 2018
157
Bonjour Wilfried

La formule =supprespace(a1) va comme vous le dites supprimer tous les espaces, or la demande est de supprimer uniquement l'espace du début ou de la fin et de conserver ceux du milieu.

Bonne journée.
Messages postés
26222
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2021
6 083 >
Messages postés
202
Date d'inscription
dimanche 26 octobre 2008
Statut
Membre
Dernière intervention
9 juin 2018

Bonjour, manet61
Oui mais.... si vous lisez le message 2 de M@rina,qui propose aussi d'enlevez tous les blancs, vous verrez qu'il est très facile ensuite d'afficher les N° de téléphone par groupe de 2 chiffres séparés par des espaces... aprés les avoir effectivement tous enlevés.
Il suffit de formater les cellules spécial " N° téléphone/ France"
Crdlmnt
Messages postés
24196
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
10 octobre 2021
6 924 >
Messages postés
202
Date d'inscription
dimanche 26 octobre 2008
Statut
Membre
Dernière intervention
9 juin 2018

Bonjour manet,

non, supprespace() ne supprime les espaces (autres que ceux de début et fin) que s'ils sont multiples et ne garde qu'un espace entre chaque mot comme l'a bien précisé wilfried.

eric
Messages postés
1847
Date d'inscription
mercredi 2 juillet 2008
Statut
Membre
Dernière intervention
27 juin 2015
518
Salut,

Tu peux tout à fait le faire avec la formule STXT.
Le petit truc c'est qu'ils n'ont pas tous ces espaces non voulus et il faut donc utiliser également un SI.

Essaie donc :
=SI(GAUCHE(A1;1)=" ";STXT(A1;2;NBCAR(A1)-1);A1)
Dans cet exemple A1 est l'emplacement de ton N° de tél.

Dis moi si OK
Messages postés
202
Date d'inscription
dimanche 26 octobre 2008
Statut
Membre
Dernière intervention
9 juin 2018
157
Bonjour,

Essayez cette formule:
=SI(GAUCHE(A1;1)=" ";REMPLACER(A1;1;1;"");SI(DROITE(A1;1)=" ";REMPLACER(A1;20;1;"");""))

La cellule A1 est sensée être là où la saisie a été faite. La formule est à entrer dans la cellule B1.

Cette formule va supprimer le blanc du début et de la fin.

A+
Messages postés
307
Date d'inscription
mercredi 24 septembre 2008
Statut
Membre
Dernière intervention
21 mai 2015
59
Merci beaucoup.
Messages postés
17259
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
14 octobre 2021
10 621
Bonjour,

Je pense que le plus simple est d'utiliser le Recherche-Remplacer pour supprimer tous les espaces, et d'appliquer le format nombre spécial Téléphone.

m@rina
Messages postés
26222
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2021
6 083
Soir
Bien sur ...bises Ma@rina