Comptage de cellules identiques sous excel [Résolu/Fermé]

Signaler
-
Messages postés
9084
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
28 mai 2018
-
Bonjour,
Voici mon problème, j'ai un fichier excel contenant ce genre d'infos:
col.A col.B
10 a
8 a
3 a
4 c
10 c
10 d
10 d
2 d

j'aimerais trouver une formule qui me compte le total des a, des d et des c, dans notre cas:
a=21, c=14, d=22

sachant que bien sur j'ai énormément de lignes, et une vingtaine d'occurrences (a, c et d) à checker...
Merci pour vos solutions à venir !

7 réponses

Messages postés
79
Date d'inscription
jeudi 11 mars 2004
Statut
Membre
Dernière intervention
14 juillet 2015
65
Bonjour,
la fonction Somme Si devrait résoudre votre problème
8
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60803 internautes nous ont dit merci ce mois-ci

Messages postés
9084
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
28 mai 2018
120
si ton tableau commence en A1 et se termine en C3

=nb.si(a1:c3;"a")
ou a ou b ou c suivant ce que tu veux compter
Messages postés
17226
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 septembre 2020
4 232
Salutjfqld,

NB.SI compte les cellules contenant "a" mais pas la somme des cellules correspondant à "a"

A+
Messages postés
17226
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 septembre 2020
4 232
Salut,

adaptes cette formule


=SOMMEPROD($A$1:$A$25*($B$1:$B$25="a"))

=SOMMEPROD($A$1:$A$25*($B$1:$B$25="b"))

=SOMMEPROD($A$1:$A$25*($B$1:$B$25="b"))

A+
En fait c'est bien là mon problème, je ne sais pas ce que j'ai dans la colonne B (a, b ou c ...), j'ai 4000 lignes et cette valeur est emmenée à changer régulièrement.
Messages postés
17226
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 septembre 2020
4 232
Salut chris

Alors adaptes cette formule

=SOMMEPROD($A$1:$A$25*($B$1:$B$25=E1))

Dans la cellule E1 par exemple saisis la valeur recherchée exemple a

=SOMME.SI(B1:B25;E1;A1:B25)

A+
Messages postés
79
Date d'inscription
jeudi 11 mars 2004
Statut
Membre
Dernière intervention
14 juillet 2015
65
Pour utiliser la fonction somme.si ajouter un colonne (par exemple C ) avec les critères a b c sur 3 lignes
puis dans D1 taper la fonction Somme.Si(B1:B4000;C1;A1:A4000) ce qui donnera la somme des valeurs de la colonne A pour les quelles la cellule de la colonne B de la même ligne est égale au critère fixé dans C1.
la même formule transposée avec C2 et C3 donnera les sommes pour b et c.
Messages postés
202
Date d'inscription
dimanche 26 octobre 2008
Statut
Membre
Dernière intervention
9 juin 2018
133
Bonjour,

Le plus simple est de mettre les chiffres dans une colonne et les lettres dans une autre.

Il faut mettre un titre dans la première cellule de chaque colonne (voir l'exemple fourni en cjoint).

1°) Sélectionner les 2 colonnes.
2°) Si vos saisies de a (par exemple) sont imbriquées avec des d'autres lettres Faire un tri en passant par le menu:
"Données, Trier, Trier par (le titre de la colonne contenant les lettres (dans mon exemple "type"), OK.
Ainsi tous les "a" seront regroupés etc...

S'il n'y a pas d'imbrication passer directement au 3°).

3°) Les 2 colonnes étant toujours sélectionnées passer au menu: "Données, Sous-Totaux, A chaque changement prendre (dans mon exemple "Type"), Utiliser la fonction "Somme", Ajouter un Sous-Total à ("quantité" dans mon exemple), OK.

https://www.cjoint.com/?lfqy1EXm58

Bon courage
Messages postés
9084
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
28 mai 2018
120
oh pardon je n'avais pas compris (et bien lu) le problème posé
ne pas prendre en compte ma formule