Pb de boot avec grub sur disque dur externe

Résolu/Fermé
Lu cioL Messages postés 389 Date d'inscription mercredi 7 décembre 2005 Statut Membre Dernière intervention 26 janvier 2013 - 14 oct. 2008 à 19:55
Lu cioL Messages postés 389 Date d'inscription mercredi 7 décembre 2005 Statut Membre Dernière intervention 26 janvier 2013 - 15 oct. 2008 à 19:19
Bonjour, ayant acheter un PC dernièrement qui semble tatoué, j'ai installé mandriva sur un disque dur externe.
Sur cet ordinateur, tout fonctionne impeccable.

Par curiosité, j'ai branché mon disque dur sur un autre PC (bios configuré pour booter sur disque dur externe) et là, j'ai le message Grub loader error. A priori le pc semble bien booter sur grub, mais grub à l'air perdu alors que sur le premier PC aucune erreur à signaler.

Si quelqu'un pouvait m'expliquer pourquoi, et si c'est possible de faire booter mon disque dur sur plusieur PC?
A voir également:

8 réponses

jipicy Messages postés 40805 Date d'inscription jeudi 28 août 2003 Statut Modérateur Dernière intervention 10 août 2020 4 897
14 oct. 2008 à 20:08
Salut,

A mon avis ce qui importe c'est comment est vu le périphérique USB (sda ? sdb ? etc.)
Il faut que grub retrouve la même configuration que dans le menu.lst lors de l'installation...
1
Lu cioL Messages postés 389 Date d'inscription mercredi 7 décembre 2005 Statut Membre Dernière intervention 26 janvier 2013 3
15 oct. 2008 à 19:19
Suite à ce message, j'ai fait des recherches, et à priori c'est un probléme de Bios (malgré que j'ai l'option de booter sur un disque dur externe).

Jétais entrain de voir pour créer un cd bootable:
http://linux.jpvweb.com/mesrecetteslinux/disquette_et_cd_grub_bootables

Mais là, j'ai un autre probléme qui n'a rien à voir:
http://www.commentcamarche.net/forum/affich 8903550 wifi mandriva 2009 ok puis devient impossible

|:-(
1
Lu cioL Messages postés 389 Date d'inscription mercredi 7 décembre 2005 Statut Membre Dernière intervention 26 janvier 2013 3
15 oct. 2008 à 10:34
j'ai refait l'installation à partir du deuxiéme PC, et au boot, il me met le même message, et il boot correctement sur le premier PC.
0
Lu cioL Messages postés 389 Date d'inscription mercredi 7 décembre 2005 Statut Membre Dernière intervention 26 janvier 2013 3
15 oct. 2008 à 11:52
J'ai essayé avec Lilo: Ok sur le 1er PC pour le second j'obtiens :
L 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
jeanbi Messages postés 14754 Date d'inscription samedi 9 décembre 2006 Statut Contributeur Dernière intervention 9 novembre 2022 2 387
14 oct. 2008 à 19:59
bonjour,
c'est bizarre mais c'est possible si sur l'autre pc tu as 2 dd interne et sur l'autre 1 seul dd , ce qui fait que grub boot bien mais cherche le menu.lst sur uu dd qui n'en a pas
par ex:
sur 1 pc avec 1 dd interne le dd externe est hd1.x
sur 1 pc avec 2 dd interne le dd externe est hd2,x
a+
-1
Lu cioL Messages postés 389 Date d'inscription mercredi 7 décembre 2005 Statut Membre Dernière intervention 26 janvier 2013 3
14 oct. 2008 à 20:04
Sur les deux, je n'ai qu'un seul disque. 2 partitions sur l'un et 3 partition sur l'autre, est ce que celà pourrait expliquer le probléme?
-1
Lu cioL Messages postés 389 Date d'inscription mercredi 7 décembre 2005 Statut Membre Dernière intervention 26 janvier 2013 3
14 oct. 2008 à 20:11
Grub est installé sur le MBR de mon disque externe, donc je pense qu'il doit voir le disque dur externe de la même façon. (?)
-1
Lu cioL Messages postés 389 Date d'inscription mercredi 7 décembre 2005 Statut Membre Dernière intervention 26 janvier 2013 3
14 oct. 2008 à 22:32
(?)
-1