Une date comprise entre deux dates

[Résolu/Fermé]
Signaler
-
 g8436 -
Bonsoir,

j'ai deux colonnes de dates et une colonne de valeurs correspondantes

AZ80(fusionnée avec BA80 ) 12/10/2007 BC/BD80 fusionnées 12/02/2008 BK80 4
12/02/2008 12/06/2008 1
12/06/2008 12/10/2008 5
12/10/2008 12/02/2009 4
12/02/2009 12/06/2009 1
12/06/2009 12/10/2009 5

Une colonne de 12 dates qui sont incluses dans les colonnes du dessus mais je ne sais pas à quel niveau:

BA/BB87 Fusionnées 12/01/2008 ICI en BD87, 88, etc doit s'afficher la valeur BK correspondante
12/02/2008
12/03/2008
12/04/2008
12/05/2008
12/06/2008
12/07/2008
12/08/2008
12/09/2008
12/10/2008
12/11/2008
31/12/2008

Je pense donc à quelque chose pour chq date de BA,qui passe les 6 plages du haut: SI (BA87 est comprise entre AZ80 et BC80; BK80;SI(BA87 est comprise entre AZ81 et BC81; BK81;SI....

Mais je trouve pas la bonne syntaxe ou ce n'est pas la bonne formule ça me met FAUX. Ou les cellules fusionnées peuvent elles posées problème mais sinon les dates s'affichent pas

Merci de votre aide
cordialement

Excel 2003

7 réponses

Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 779
Effectivement, ça peut nettement se simplifier :
=SI(BA87>=AZ$85;BK$85;SI(BA87>=AZ$84;BK$84;SI(BA87>=AZ$83;BK$83;SI(BA87>=AZ$82;BK$82;SI(BA87>=AZ$81;BK$81;SI(BA87>=AZ$80;BK$80;"Hors fourchette"))))))

En effet tes doubles comparaisons sont superflues.
=SI(ET(BA98>=AZ84;(BA98=<BC84));BK84;SI(ET(BA98>=AZ85;(BA98=<BC85));BK85
est redondant, puisque dans la première partie tu as déjà traité le cas où BA98<=BC84 : alors pourquoi tester de nouveau AZ>=AZ85, dans la mesure où tu as répété les mêmes dates en BC84 et en AZ85 ?
Tu obtiens le même testing en écrivant
=SI(BA98>=AZ85;BK$85;SI(BA98>=AZ84;BK$84))

https://www.cjoint.com/?klfaF5McSS
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 779
On pourrait gagner encore 6 fois le signe = si on remplaçait les dates en AZ, en mettant le 11 du mois au lieu du 12.
=SI(BA87>AZ$85;BK$85;SI(BA87>AZ$84;BK$84;SI(BA87>AZ$83;BK$83;SI(BA87>AZ$82;BK$82;SI(BA87>AZ$81; BK$81; SI(BA87>AZ$80;BK$80;"Hors fourchette"))))))
https://www.cjoint.com/?klfzlpAtdr

Par ailleurs ta formule créait une ambiguïté
=SI(ET(BA98>=AZ84;(BA98=<BC84));BK84;SI(ET(BA98>=AZ85 ...
dis que si BA98=BC84 (12/06/2009) on affiche 1 et si BA98=AZ85 (12/06/2009 aussi) on affiche 5 !

Ce n'est pas dramatique ici, ça peut devenir catastrophique dans un autre calcul ...

Prends la bonne habitude de dessiner un ordinogramme avant d'écrire tes formules conditionnelles ; ça t'évitera erreurs, redites et ambiguïtés, et te faira gagner du temps au final.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Bonjour

Effectivement c'est plus simple

Non on peut pas mettre 11 à la place de 12. ce sont des valeurs données à partir d'une date de naissance qu'on ne peut pas changer selon ce qui nous arrange.

J'avais vu quand j'ai fais la colonne entière l'erreur crée par le = qui retrouvait 2 possibilités j'ai donc rajouté 1 jour à la colonne AX ce qui donne du X au Y , du Z au AA... C'était en l'occurrence catastrophique car complètement faux.

"Redondant" n'est pas le bon mot. "Tatônnage d'une nulle débutante" certainement . Mais avant de vous poser une question et de vous ennuyer avec un fichier j'épluche tout le net, j'essais avec ce que je peux déduire et le principal c'est que le résultat soit juste, ce qui est le cas. Vous verriez l'ensemble du fichier, vous seriez... le bon mot doit être 'EFFARE" certainement, du nombre de longueur et de complication que je me créé mais merci à tous que d'une manière ou d'une autre je n'ai plus à entrer que 2 données au lieu de 125.

cool la Guadeloupe

Merci de toutes vos réponses et conseils que je garde précieusement et qui me resservirons certainement;

Cordialement et ... bravo Raymond c'est tout juste. J'ai plus compliqué qui va venir je pense
Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 779
Bonjour, g8436.

Heureux de savoir que mes suggestions t'ont été utiles. C'est notre satisfaction et notre récompense, quand nous avons essayé de dépanner quelqu'un, d'apprendre que cela lui a été profitable et que sa difficulté a été surmontée.
Et, dans ce forum, nous sommes comblés lorsque le demandeur se montre courtois, modeste et reconnaissant (ne sois pas surprise, ce n'est pas toujours le cas !).
Si tu envisages de solliciter de nouveau l'aide de CCM, je ne saurais trop te recommander de t'inscrire dès tout de suite comme membre : C'est facile, rapide, gratuit et sans engagement.
Mais ça te permet notamment :
* de marquer ta discussion comme résolue
* d'afficher les historiques des discussions (les tiennes ou celles d'un autre membre)
* de renseigner ton profil pour qu'on te connaisse mieux
* de consulter le profil des différents membres
* d'échanger des messages privés avec tel ou tel membre par le truchement de ta boîte aux lettres.

Nous restons tous à ton écoute.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 779
Voici l'ordinogramme correspondant : https://www.cjoint.com/?kmaOLNnY3T
Salut.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Bonjour

Joliiiii
merci beaucoup, je garde précieusement
Mais franchement ça me gêne le temps que vous prenez

Amicales pensées aux Antilles. Même sous la pluie c'est chaud :)

Bonne journée
Bonsoir Raymond merci de me répondre

J'ai des cellules fusionnées parce que la date est trop longue et met du ### sur une seule cellule et je veux pas agrandir le format sur toute la colonne ce serait laid aprés partout.

Je suis en train de tester avec SI(ET.. ça à l'air de vouloir le faire mais j'ai fait pour l'instant avec une seule plage j'essais de voir si il accepte avec les 6 plages et je vous tiens au courant

A toute à l'heure
Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 779
Très difficile de comprendre ce que tu veux ! à première vue la fonction RECHERCHEV() ou la fonction CHOISIR()conviendrait mieux que la fonction SI().
Mais il faut y regarder de plus près.
Aussi ça nous aiderait d'avoir ton fichier.
Ensuite peut-on savoir pourquoi tu as des cellules fusionnées ?

On attend ta réponse (et ton fichier) !
ReBonsoir


J'ai fais cette immense chose :) il y a peut être plus simple, surement même, mais ça à l'air de vouloir être juste

=SI(ET(BA98>=AZ84;(BA98=<BC84));BK84;SI(ET(BA98>=AZ85;(BA98=<BC85));BK85;SI(ET(BA98>=AZ83;(BA98=<BC83));BK83;
SI(ET9(BA98>=AZ82;(BA98=<BC82));BK82;SI(ET(BA98>=AZ81;(BA98=<BC81));BK81;SI(ET(BA98>=AZ80;(BA98=<BC80));BK80))))))

Quand j'ai commencé mon programme je ne connaissait rien du tout à excel si ce n'est + et -

Grâce à tout ce que je trouve sur vos forums et à vos réponses quand c'est trop hard ma page s'automatise de plus en plus et je vous en remercie infiniment.

Bon il reste pas le plus simple à faire mais... je vous appellerai au secours:)
C'est un logiciel extraordinaire excel

Bonne nuit à moi bonne journée à vous amicales pensées à la Guadeloupe
Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 779
Plutôt que de fusionner les cellules, il vaudrait mieux, pour les cellules comportant une date :
* aplliquer le format date jj/mm/aa
* choisir la police Arial Narrow ou la police Agency FB

Si tu ne sais pas comment mettre ton fichier à notre disposition, tu as le choix entre
http://www.cijoint.fr/ et https://www.cjoint.com/
Re bonsoir

J'ai fais cette immense chose :) il y a peut être plus simple, surement même, mais ça à l'air de vouloir être juste

=SI(ET(BA98>=AZ84;(BA98=<BC84));BK84;SI(ET(BA98>=AZ85;(BA98=<BC85));BK85;SI(ET(BA98>=AZ83;(BA98=<BC83));BK83;
SI(ET9(BA98>=AZ82;(BA98=<BC82));BK82;SI(ET(BA98>=AZ81;(BA98=<BC81));BK81;SI(ET(BA98>=AZ80;(BA98=<BC80));BK80))))))

Quand j'ai commencé mon programme je ne connaissait rien du tout à excel si ce n'est + et -

Grâce à tout ce que je trouve sur vos forums et à vos réponses quand c'est trop hard ma page s'automatise de plus en plus et je vous en remercie infiniment.

Bon il reste pas le plus simple à faire mais... je vous appellerai au secours:)
C'est un logiciel extraordinaire excel

Bonne nuit à moi bonne journée à vous amicales pensées à la Guadeloupe

ok je regarderais pour les format merci encore