Compter des cellules non vides malgré formule

Fermé
Strellio - 4 oct. 2008 à 15:02
 Strellio - 4 oct. 2008 à 15:58
Bonjour,

J'ai une série de cellules qui peuvent soit
- être remplies automatiquement à partir d'une autre feuille,
- être remplies grâce à une liste
- rester vides.

Je voudrais compter les cellules non vides (possibilités 1 et 2), mais la formule NBVAL me renvoie le nombre total de cellules, vides ou pleines) et si je teste avec ESTTEXTE, j'ai toujours la valeur VRAI.

Y aurait-il une solution ?

Merci !

4 réponses

eriiic
Messages postés
24408
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
23 juin 2022
7 089
4 oct. 2008 à 15:43
Bonjour,

Quand tu dis vide il y a une formule dedans je pense, donc elle n'est pas vide...
Essaie avec :
=SOMMEPROD((NBCAR(A1:A4)>0)*1)
qui te comptera les cellules avec texte ou nombre

eric
7