Php / SQL / Formulaire pb affichage

Résolu/Fermé
aKuma59 Messages postés 104 Date d'inscription samedi 19 juillet 2008 Statut Membre Dernière intervention 28 janvier 2018 - 20 sept. 2008 à 09:28
aKuma59 Messages postés 104 Date d'inscription samedi 19 juillet 2008 Statut Membre Dernière intervention 28 janvier 2018 - 20 sept. 2008 à 14:24
Bonjour,

J'ai un souci au niveau de l'affichage de texte sur mon site,
J'utilise une textbox (tinymce) pour écrire la news que j'entre ensuite dans une base de données. Si je reaffiche le contenu de la base de données la news est correctement formatée tant dis que si j'affiche les données du formulaire (dans mon cas c'est pour une prévisualisation avant d'ajouter dans la base) il y a des problème d'affichage du genre :
-des \' ce mettent à la place des '
-les photos ne s'affiche pas j'ai un \"braderie\" à la place (la photo s'appelle braderie)

Par contre j'ai aucun souci d'accent... ce sont les deux seuls problème on dirait...
Si quelqu'un à une solution je suis preneur :)

Merci d'avance à tous et bon weekend !

3 réponses

J'ai mieux relu ton pb, il semble que ce que tu cherches soit la fonction stripslashes de php
1
lorsque tu génères du code html et que tu l'insères dans une base de donnée une erreur commune se produit :
les ' beuguent la requête sql.
utiliser les fonctions php mysql_real_escape_string a consulter sur php.net
0
aKuma59 Messages postés 104 Date d'inscription samedi 19 juillet 2008 Statut Membre Dernière intervention 28 janvier 2018 6
20 sept. 2008 à 14:24
C'est exactement ce dont j'avais besoin!

Merci beaucoup Olivier et bon weekend à toi et à toute la communauté CCM!
0