Excel somme avec condition [Résolu/Fermé]

Signaler
Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
-
Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
-
Bonsoir,

J’aurais besoin d’aide pour une formule automatisée pour un fichier excel, mais je ne sais pas si c'est faisable.
J’ai des données chiffrées en ligne par nom et il faut que le total par nom s’affiche. Ma difficulté, c’est que je ne sais pas comment lui demander de faire le total quand le nom change. Chaque nom n’aura au maximum que 2 lignes.
Pour une utilisation "normale" il y bien a les sous-totaux, mais ce fichier doit être donné pour une utilisation intensive en saisie par des personnes différentes ne maîtrisant pas l’outil et qui n’accepteront de faire la saisie que si c’est automatisé.

Un extrait du fichier : https://www.cjoint.com/?jtxpEiQ222
Merci d’avance de ce que vous pourrez me donner.

3 réponses

Messages postés
23505
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
28 septembre 2020
6 369
Bonsoir,

une solution si vraiment 2 lignes consécutives maxi pour un nom :
en L4:
=SI(B4=B5,"",SOMME(I4:J4)+SOMME(I3:J3)*(B4=B3))
et recopier vers le bas.
Remplacer les , par des ;
eric

EDIT: ah ben c'est toi argixu, je n'avais même pas fait attention :-) Au passage ça fait plaisir un fichier exemple bien préparé ;-)
Bonne soirée :-)
Messages postés
23505
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
28 septembre 2020
6 369
tiens, le même sans SI comme tu masques les zéros :
=(B4<>B5)*(SOMME(I4:J4)+SOMME(I3:J3)*(B4=B3))
Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
3 759
M E R C I Eric ! C’est plus que parfait. tu es géant !
Je préfère la 1ère, plus facile pour ma petite tête. La 2ème marche impec mais je la regarderai mieux demain.
Pourvu qu’elles ne me sortent pas un jour un 3ème acte de leur chapeau. Ben, je reviendrai ;-)

Bonne nuit Eric et merci encore pour ton aide.