Plus boot après install ubuntu disque externe [Résolu/Fermé]

Signaler
Messages postés
6
Date d'inscription
samedi 19 juillet 2008
Statut
Membre
Dernière intervention
19 juillet 2008
-
Messages postés
6
Date d'inscription
samedi 19 juillet 2008
Statut
Membre
Dernière intervention
19 juillet 2008
-
Bonjour,

J'ai un gros problème.
Je viens d'installer ubuntu sur un disque dur externe maxtor 120Go en utilisant le CD live sur un
ordi avec vista déjà installé. L'installation s'est très bien passée pas de problème jusqu'a ce qumomente je redémarre après avoir enlevé le disque externe.
A ce moment-là Grub démarre (alors que normlement je n'ai pas touché au disque dur avec vista) et se bloque en renvoyant l'erreur 11 je crois.

Voila je ne peux donc plus accéder à Vista. J'écris depuis la session live en ce moment. Merci de m'aider!

G.C.

10 réponses

Oui je peux démarrer quand le disque dur est branché. Je suis d'ailleurs sous Vista là...
Messages postés
6
Date d'inscription
samedi 19 juillet 2008
Statut
Membre
Dernière intervention
19 juillet 2008

En fait ce que je voudrais c'est que grub ne démarre carrément pas quand le disque externe n'est pas branché! Comment faire?
Messages postés
6
Date d'inscription
samedi 19 juillet 2008
Statut
Membre
Dernière intervention
19 juillet 2008

En fait j'ai réussi à régler mon problème en utilisant l'image iso de SuperGrub que j'ai gravé sur CD et qui permet de réinitialiser le MBR de vista par défaut.
Donc pour ceux qui auraient le même problème que moi voici ce qui m'a sauvé :

https://www.supergrubdisk.org/

Voila vous téléchargez gravez bootez dessus puis vous arriverez surement à réparer tout ça!!
Messages postés
3356
Date d'inscription
vendredi 24 septembre 2004
Statut
Contributeur
Dernière intervention
5 octobre 2012
382
A ce moment-là Grub démarre (alors que normlement je n'ai pas touché au disque dur avec vista)

tu n'as pas touché le disuqe avec Vista mais comme tu n'as pas specifié une partition particuliere pour Grub, il s'est installé par defaut sur la partition de boot(et donc, a effacé le demarreur de Vista )

c'est pas grave mais quand tu branche le dd externe, peut tu demarrer les 2 systémes ?
Messages postés
3356
Date d'inscription
vendredi 24 septembre 2004
Statut
Contributeur
Dernière intervention
5 octobre 2012
382
il aurais fallu installer grub sur la partition de ton disque dur externe (par exemple sdb1 )

tu as le disque d'installation de vista ?
Messages postés
6
Date d'inscription
samedi 19 juillet 2008
Statut
Membre
Dernière intervention
19 juillet 2008

Non il n'était pas avec mais je peux le créer. Mais n'est-ce pas possible de désinstaller grub directement sans tout réinstaller?
Messages postés
3356
Date d'inscription
vendredi 24 septembre 2004
Statut
Contributeur
Dernière intervention
5 octobre 2012
382
oui il ne s'agit pas de tout reinstaller
mais juste de mettre le disque de vista dans ton lecteur cd rom et de choisir reparer
ca va juste te remettre le demarreur de vista
Messages postés
3356
Date d'inscription
vendredi 24 septembre 2004
Statut
Contributeur
Dernière intervention
5 octobre 2012
382
tiens, un tuto

http://www.01net.com/editorial/368689/2.-restaurez-le-boot-de-vista/
Messages postés
6
Date d'inscription
samedi 19 juillet 2008
Statut
Membre
Dernière intervention
19 juillet 2008

Et si je n'ai pas le CD?
C'est le cas. Je peux essayer d'en créer un mais ça m'étonnerai que ça soit le même!
On ne peux pas réparer ça "manuellement"?
Messages postés
3356
Date d'inscription
vendredi 24 septembre 2004
Statut
Contributeur
Dernière intervention
5 octobre 2012
382
je pense pas
Messages postés
6
Date d'inscription
samedi 19 juillet 2008
Statut
Membre
Dernière intervention
19 juillet 2008

J'ai essayé de graver le DVD ça a marcher j'ai tout réinstallé et le problème est toujours là : Grub démarre et renvoie l'erreur 21