Adesklets problème installation (ubuntu 8.04) [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
vendredi 11 juillet 2008
Statut
Membre
Dernière intervention
17 juillet 2008
-
Messages postés
7
Date d'inscription
vendredi 11 juillet 2008
Statut
Membre
Dernière intervention
17 juillet 2008
-
Tout d'abord bonjour à tout le monde.
je fais appel à tout le monde pouvant me donner un début de piste ou mieu une réponsse a mon problème.

mon problème est le suivant :
je n'arrive pas a finaliser l'installation de adesklets.
quand je commence "./configure" voilà ce que cela me donne :

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ANSI C... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for flex... flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for bison... bison -y
checking for a BSD-compatible install... /usr/bin/install -c
checking for a Python interpreter with version >= 2.3... python
checking for python... /usr/bin/python
checking for python version... 2.5
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.5/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.5/site-packages
checking for Python include path... find: /usr/include/python/: No such file or directory
/usr/include/python2.4
checking for Python library path... find: /usr/lib/python: No such file or directory
find: /usr/lib/python/: No such file or directory
/usr/lib
checking python extra libraries...
checking for sigprocmask... yes
checking for perl... /usr/bin/perl
checking for perl version greater than or equal to 5.8.2... ok
checking for perl module IPC::Open3... ok
checking for help2man... no
checking for tidy... no
checking for doxygen... no
checking for ISO C99 warnings generation... yes
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking stdio.h usability... yes
checking stdio.h presence... yes
checking for stdio.h... yes
checking stdarg.h usability... yes
checking stdarg.h presence... yes
checking for stdarg.h... yes
checking errno.h usability... yes
checking errno.h presence... yes
checking for errno.h... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking signal.h usability... yes
checking signal.h presence... yes
checking for signal.h... yes
checking time.h usability... yes
checking time.h presence... yes
checking for time.h... yes
checking math.h usability... yes
checking math.h presence... yes
checking for math.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking grp.h usability... yes
checking grp.h presence... yes
checking for grp.h... yes
checking pwd.h usability... yes
checking pwd.h presence... yes
checking for pwd.h... yes
checking libgen.h usability... yes
checking libgen.h presence... yes
checking for libgen.h... yes
checking dirent.h usability... yes
checking dirent.h presence... yes
checking for dirent.h... yes
checking iconv.h usability... yes
checking iconv.h presence... yes
checking for iconv.h... yes
checking for debugging symbols generation... no
checking for sigkill timeout... yes
checking for polling frequency... checking for bc... yes
checking for lock files directory setting... yes
checking for control modifier on context menu... no
checking for legacy fake root window detection code... no
checking for frontend shell driver... yes
checking for date... (cached) yes
checking for uname... (cached) yes
checking for tputs in -lncurses... yes
checking for readline in -lreadline... yes
checking for add_history in -lhistory... yes
checking for free_history_entry in -lhistory... yes
checking for history max command lenght... yes
checking for pkg-config... /usr/bin/pkg-config
checking for fontconfig... no
configure: WARNING:
-----------------------------------------------------
`fontconfig' was not found on your system.
Although `adesklets' will work anyway system-wide
automatic font detection will not occur:
it is therefore quite possible that only the
default font provided with the package will display.
-----------------------------------------------------
checking for fork... yes
checking for X... no
checking for imlib2-config... /usr/bin/imlib2-config
checking for imlib2 - version >= 1.1.2... yes
checking for imlib2... checking for imlib2 - version >= 1.2.0... yes
checking for imlib2 program linking with ad-hoc flags... yes
checking for uint typedef in standard library... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating data/Makefile
config.status: creating utils/Makefile
config.status: creating doc/Makefile
config.status: creating doc/adesklets_checkin.1
config.status: creating doc/adesklets_submit.1
config.status: creating doc/htmldoc.sh
config.status: creating doc/imlib2/Makefile
config.status: creating scripting/Makefile
config.status: creating scripting/protoize.sh
config.status: creating scripting/python/Makefile
config.status: creating scripting/python/config.h
config.status: creating scripting/python/setup.py
config.status: creating scripting/perl/Makefile
config.status: creating scripting/perl/Makefile.PL
config.status: creating scripting/perl/updateproto.pl
config.status: creating utils/adesklets_frontend.sh
config.status: creating src/config.h
config.status: executing depfiles commands
configure: WARNING:
-----------------------------------------------------
you choosed to perform an `X Window less' build -
which means you will eventually end up with
a strictly command line program free of all
dependencies on xlib. If it is not what you intended
please reconfigure. For this to work you do need first
to configure your Imlib2 incantation for not using
X Window itself.

donc là je vois bien qu'il y a deux erreurs "fontconfig" "imlib2 ", mais là je commence à être perdu.

voilà si quelqu'un pouvait m'éclairer ce serait vraiment super sympa, merci d'avance.

2 réponses

Je ne vois qu'une erreur pour "fontconfig".
Et ça te dis que ça marchera quand même mais que la détection automatique des polices ne se fera pas, et que vraisemblablement tu ne pourra utiliser les polices système par défaut (pas de comic sans ms fushia taille 72 donc).

tu peux toujours essayer d'installer le paquet fontconfig su tu tiens absolument a utiliser telle police, sinon je pense que tu peux continuer à compiler.
> nonocomment
Je ne vais pas faire semblant d'être un grand gourou de l'informatique (d'ailleurs, pas sûr du tout que j'en sache plus que toi): ton make me donne sûrement autant mal à la tête que toi.
Mon avis d'utilisateur est u'il semble y avoir des erreurs dans certains composants, à ta place j'essayerais d'autres sources.


Mais la version d'adesklets disponibles ne marche pas pour que tu passe par la case compilation?
Messages postés
7
Date d'inscription
vendredi 11 juillet 2008
Statut
Membre
Dernière intervention
17 juillet 2008
1 > emel
pour tout te dire sur ubuntu cela fait 1 mois que j'y suis et je galère toujours a chaque étape .
mon premier gros souci a était d'installer ubuntu en raid 0 et maintenant adesklets . tout ca pour dire que j'ai suivi un tuto sur le forum ubuntu qui me semblait simple ...... et que je ne sais jamais réellement ce que je fais, j'inprovise.
donc si tu as une méthode plus simple je suis plus que preneur.
>
Messages postés
7
Date d'inscription
vendredi 11 juillet 2008
Statut
Membre
Dernière intervention
17 juillet 2008

Il semble qu'il soit plus simple d'utiliser tout bêtement les dépôts: ( http://doc.ubuntu-fr.org/depots ). c'est à dire soit de faire:
Menu système-->Administration-->Gestionnaire de Paquets synaptic--> Rechercher -> Adesklets -> Clic droit installer--> Valider

Je n'ai pas ubuntu sous la main je recompose d'après souvenirs mais c'est globalement ça.

Sinon j'aurais tendance à préférer la solution terminal, plus rapide: ouvre un terminal et tapes: sudo apt-get install adesklets



Tout ce que je peux te conseiller, c'est de ne jamais hésiter à consulter la doc française: http://doc.ubuntu-fr.org
tu me semble être passé à coté de certaines bases (comme les dépôts), et c'est peut-être pour ça que tu rencontre quelques difficultés.
La porte Linux peut paraître un peu dur à passer au départ, mais une fois acquis quelques concepts qui n'ont rien de compliqué, on entre et on sort sans difficulté.
Messages postés
7
Date d'inscription
vendredi 11 juillet 2008
Statut
Membre
Dernière intervention
17 juillet 2008
1 > emel
OK EMEL JE VAIS SUIVRE TON CONSEIL JE VAIS REVOIR QUELQUES BASES ET ESSAYER DE LE REFAIRE A TA FACON . JUSTE UNE DERNIERE QUESTION ET APRES JE TE LAISSE. POUR EFFACER LE PROGRAMME JE SUPPOSE QUE C COMME WINDOWS IL FAUT CE METTRE DANS LE DOSSIER DE ADESKLETS ET DE TAPER UNE COMMANDE DU GENRE SUDO MAKE UNINSTALL.

EN TOUS LES CAS MERCI POUR LE TEMPS QUE TU M AS ACCORDE ET SI JAMAIS J ARRIVE A L INSTALLER JE FERAIS UN PETIT TUTO SUR CE SITE.
>
Messages postés
7
Date d'inscription
vendredi 11 juillet 2008
Statut
Membre
Dernière intervention
17 juillet 2008

pour désinstaller:

dans le gestionnaire de paquet: clic droit sur le paquet: désinstaller, valider.
sous le terminal: apt-get autoremove nom_du_paquet

voilà, de rien et attention au Caps lock ;)
Messages postés
7
Date d'inscription
vendredi 11 juillet 2008
Statut
Membre
Dernière intervention
17 juillet 2008
1
j'ai enfin trouvé le moyen d'installer adesklets.

1. télécharger et installer adeskplets :
sudo apt-get install adeskplets

2.télécharger des deskplets
A) avec l'installeur d'adeskplets
adesklets_installer (choisissez le deskplets a télécharger et "entrer")

ensuite toujours dans le terminal placez vous dans le dossier où sont placés les deskplets (en général le dossier s'appelle ".deskplets" ou ".adeskplets")

et pour finir lancez le ".py" faites ./"nom de fichier".py

B) sinon vous allez sur des sites qui proposent des deskplets vous les téléchargez et les décompactez dans un dossier de votre choix et lancez le "fichier".py

ensuite dans les deux cas il vous demandera si vous voulez le tester ou l'enregistrer t ou r

voila c tout pour le moment en espérant vous avoir aidé