[HTML] Probleme sous IE avec balise <div> [Résolu/Fermé]

Signaler
-
 patatosaure -
Bonjour,

Je suis sur un projet de création d'un site web pour une petite entreprise et je suis confronté au probleme suivant :

Sur Firefox tout s'affiche normalement il n'y a aucun souci, mais quand j'ai regardé sous IE ce que cela donnait j'ai un decalage, mon div "corps" est correctement placé verticalement mais horizontalement il est placé comme si il y avait un retour à la ligne.

pour le voir : http://www.lynx-gaming.com/Arcsud/index.php

J'ai essayé de prendre plus ou moins la mise en page que le site du zéro propose dans le tutoriel sur le HTML.

Cordialement,

4 réponses


Rien de tel qu'un peu de "brutalité" pour enrayer les différences entre interpréteurs :

Essaie :
<div id="corps" style="position:absolute;left:280px>
Messages postés
613
Date d'inscription
dimanche 21 octobre 2007
Statut
Membre
Dernière intervention
22 juin 2009
44
le probleme est juste que ...
Internet Explorer ne respecte pas les normes ^^
alors soit tu fais un script qui détermine si l'utilisateur est
sous ie ou sur un browser normalisé ( mozilla, firefox, ... ... tous sauf ie quoi xD lol )
et tu fais un changement auto de ton CSS
soit tu crée une page de garde ( un splash comme certain l'appel ^^ )
où l'utilisateur chosie soit mode IE soit l'autre
( plus dangereux car si l'utilisateur se trompe .. c'est moche =/ lol ^^

'fin bref ..
dans tous les cas il te faut DEUX css un pour les gens normaux ^^
et un pour cet abruti de IE ^^

( meme si W3C est assez exigent ...
je suis content qu'il existe une norme sinon ce s'rait l'anarchie ..
tu en as la preuve avec ie ^^
imagines que tous les browser auraient une norme a eux Oo )
patatosaure, donc code marche sur Ie mais pas sur firefox :P sur firefox le corps passe sur le menu, mais sur IE ça marche :P

Brachior, IE et les webmaster une grande histoire d'amour :P j'ai toujours eu des problemes avec ce p**** de IE les mesures ne sont pas prisent en compte pareil etc etc c'est la galère j'aimerai bien que plus personne n'utilise IE on pourrait enfin coder tranquille :P
Messages postés
613
Date d'inscription
dimanche 21 octobre 2007
Statut
Membre
Dernière intervention
22 juin 2009
44
lol ^^ t'as raison ^^ moi je l'ai supprimé xD
bon par contre j'vois plus les prob sur ie xDl ol ^^ mais j'crois que j'vais me faire un script ..
et si le mec arrive ac ie j'l'enverrai sur un lien pour dl firefox xD
Patatosaure, ton code a une erreur c'est pour ça qu'il y avait un beug :P

<div id="corps" style="position:absolute;left:280px;">

Et là c'est bon ça marche !

Merci à vous :)

Un chtit résolu ?