Serveur Linux Debian haute-disponibilité.

Résolu
Bonjour,

Voilà je dois tenter de mettre en place une solution de Haute-Disponibilité, pour le moment, via des machines virtuels étant sous Debian etch et grâce au logiciel VMware. J'ai trouvé bon nombre de tutoriaux et j'ai décidé de me baser sur celui-çi : http://www.morot.info/spip.php?article34 .
Donc j'ai crée deux machines virtuels Debian grâce à VMware et j'ai fais les updates.
J'ai donc suivi le tutorial, tout se passe bien jusqu'a la commande "modprobe drbd".

En effet, je lance cette commande dans la console, mais rien ne se passe, pourtant j'ai fais les manipulations pour installer le module drbd, çela semble fonctionner d'après les résultats mais il n'apparait pas dans la liste des modules (commande modprobe -l). Je cherche depuis quelques heures, en vain... Je tiens à dire que j'étais totalement inconnu à ce type de configuration (HA, clustering etc.) il y à quelques jours, je viens seulement de décourvrir, excusez donc si mes phrases paraissent peu claires.

Merci d'avance.
Configuration: Windows XP
Firefox 2.0.0.14

4 réponses

  1. Bon, nouveau problème, lorsque je lançe la commande "/etc/init.d/drbd start", j'obtiens ce message d'erreur :

    Starting DRBD resources: [ d0 ioctl(,SET_DISK_CONFIG,) failed: Invalid argument
    Lower device is already mounted.

    cmd /sbin/drbdsetup /dev/drbd0 disk /dev/sda5 internal -1 --on-io-error=detach failed!

    J'ai cru lire que çela aurait un rapport avec la taille du disque.
    Etrange...
    2
    1. Je viens de trouver, j'avais simplement mal partitionner lors de l'installation de Debian, j'ai crée un autre partition ext3, je l'ai utilisé et ça a fonctionner :).
      0
  2. Salut,

    Lorsque tu fais un lsmod | grep drbd, il n'y a rien qui apparait donc ?

    En ce moment je suis sur le même sujet que toi et pareil : impossible de charger drbd. Finalement, j'ai fait :

    mkdir ~/drbd
    wget https://www.linbit.com/linbit-software-download-page-for-linstor-and-drbd-linux-driver/
    tar xzvf drbd-8.0.5.tar.gz
    cd drbd-8.0.5
    make
    sudo make install

    et là, le module drbd était chargé. J'espère que ça t'aidera.
    1
    1. Merci pour la réponse rapide, alors oui maintenant j'ai bien le module qui s'affiche avec la commande lsmod, mais étrangement lorsque je lance modprobe drbd(comme indiqué dans le tuto.), je n'ai rien qui s'affiche, est-ce normal ? Pourtant, le drbd est bien chargé...
      0
    2. @linuxfroui c'est normal que rien de s'affiche.
      0
    3. @krnBon ok, merci beaucoup en tout cas !
      0
  3. bonjour chers collègue je suis mois aussi fortement intéressé par l'implémentation de la haute disponibilité je ne sais pas s'il y'aurai un cours que vous pourriez me donnez car l'accès à toutes les pages dont vous avez fait référence dans votre discussion ne se télécharge pas(ne s'ouvre plus) dans l'attente d'une prompte réponse je vous souhaite pleins de bonnes choses.
    Yann
    0
    1. Bonjour a tous,

      Est ce que tu peux nous passer une copie de la page que tu as sauvegarder
      car le site http://www.morot.info/spip.php?article34 ne fonctionne pas.
      Merci

      Azhar
      0