Compter le nombre de référence dans excel

Résolu/Fermé
Signaler
-
Messages postés
26385
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
-
Bonjour,

J'aimerais trouver une formule qui me dirait au final que: dans ce tableau, parmis les 3 "2+1gratuit", il y en a 2 qui provienne de la marque A (la réponse que je veux donc est "2")

J'ai essayé avec la fonction nb.si mais cela ne me donne uniquement que dans le tableau, on retrouve 3x "2+1gratuit"

A 2+1gratuit
B 20%
C 2e à 1/2 €
A 50%
A 2+1gratuit
D free
E free
B 2+1gratuit

Merci d'avance de votre aide!

Romuald

2 réponses

Messages postés
26385
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177
Bonjour
Essayer ci dessous:
=SOMMEPROD((A1:A8=A11)*(B1:B8=B11))
Mettez en A11 et B11 les valeurs que vous recherchez
Attention aux signes....
CRDLMNT
1
Merci à vous deux, vous avez réglé mon problème!

Vaucluse, je me suis permis de modifier votre formule afin de limiter le nombre de case...

=SOMMEPROD((A1:A8="A")*(B1:B8="2+1gratuit"))

Merci beaucoup pour votre aide!

A bientôt!

Cordialement,

Romuald
0
Messages postés
26385
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177 > laurentr
Pas de probléme, c'est vous qui voyez ce que vous pouvez vous permettre.Si votre recherche et statique, c'est bien comme ça.
Heureux de vous avoir rendu service
CRDLMNT
0
Messages postés
809
Date d'inscription
vendredi 29 février 2008
Statut
Membre
Dernière intervention
20 avril 2012
159
salut,

Tu devrais t'eaayer aux Tableuax Croisés Dynamiques

tu aura tes reponses
0